DeveloperSide.NET Forums

DeveloperSide.NET => Anything else goes here => Topic started by: lvadillo on April 16, 2007, 03:59:09 PM



Title: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: lvadillo on April 16, 2007, 03:59:09 PM
This may be something trivial for sure, but when updating to the new 1.95 in a Windows 2000 server I get the title message ("You don't have permission to access /phpmyadmin/ on this server") when accessing phpmyadmin.
I've tried this in 2 Windows 200 servers with the same result. OK if in XP. I've checked the environment variables and they look OK. I'm up to a situation of mental frost (totally lost right now).


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: admin on April 16, 2007, 05:50:27 PM
Are you accessing from a different system than the one the Suite is install on? If so, you need to edit \www\Apache22\Suite-extra\phpmyadmin.conf


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: lvadillo on April 17, 2007, 08:08:34 AM
Yes, I'm in the local PC, as per default the phpmyadmin.conf (identical to 1.94 version) is enabled (via components.conf). A clean version 1.94 works, but a clean 1.95 doesn't. I'm using the 2000 server with the service pack 4 and the hosts file has the "127.0.0.1  localhost".

My question basically is to ask if someone with this configuration has this problem, I may have some weird setup in the servers and that's why both behave the same. I'll do a reinstall of 1.94 from scratch later today to confirm 1.94 works, if it doesn't or doesn't I'll report that here in this message (I have a meeting in a few minutes).

UPDATE:
_______

In one of the servers I had a conflicting IP (it was setup to use 2). Left 1 and now it's working. Now this will help me find out what's going on with the other server (the production on-line one).


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: lvadillo on May 14, 2007, 11:44:01 AM
Sorry that I come back with this again, I though it was traced.

I'm using a Windows 2000 server and service pack 4 (see my first topic entry). With a fresh 1.95 installation I get:

----------------
Forbidden
You don't have permission to access /phpmyadmin on this server
----------------

I'm in the local PC and the result is the same using "localhost" or "127.0.0.1". Only when taking out the code "Deny from all" from phpmyadmin.conf I'm able to access. I have no problem with a i.94 fresh install in the same PCs (happens on 2) or if I install i.95 in one PC loaded with XP Windows !!!

Has anyone with a Windows 2000 server and pack 4 made an install and is it working properly  ?

Is there a way to trace what happens somewhat? I just don't know what to look for at the moment.


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: admin on May 14, 2007, 01:02:32 PM
Did you reboot after the initial installation? Some problems can be traced to this.

If you look at the code of phpmyadmin.conf, its only allowing access from 127.0.0.1 in those "if php 4 or 5 module is loaded" blocks -- for security reasons.

I'm not sure why thats happening like that, but you can always add 'allow from 127.0.0.1' right after the deny line. Restart Apache after config changes.


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: lvadillo on May 14, 2007, 03:18:40 PM
It was a good idea to put it righ after. I did it but unfortunately that did not cleared after reinitalizing the PC.
I compared the 2 phpmyadmin.conf files (i.95 and i.94) and they were equal. Just to make sure I re-installed i.94 and reinit the PC, phpmyadmin worked OK. With i.95 keeps on failing. Terrible!


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: admin on May 14, 2007, 10:05:27 PM
It might be a bug.

Try this instead for that file...
Code:
Alias /phpmyadmin "/www/phpmyadmin"

<Directory "/www/phpmyadmin">
Options None
AllowOverride None

Order Deny,Allow
Deny from all
Allow from 127.0.0.1

AddType text/html .php .phps
AddHandler application/x-httpd-php .php
AddHandler application/x-httpd-php-source .phps
</Directory>


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: lvadillo on May 16, 2007, 12:13:07 PM
Thank you for your hint, I tried above but the problems remains.

I've also tried using the i94 apache "Conf" subdirectory in order to see if it's a configuration change somewhere (doesnīt work).
Changing the conf files so to load the Minimum (with no mod_ssl, mod_fastcgi nor mod_perl) didnīt help.

i95 starts working once I replace in the apache subdirectory yhe "bin" and "modules" with the i94 ones, I also need to put the i94 "conf" just to avoid loading problems. So, once I'm with these 2 subdirectories I don't know how to further troubleshoot in order to isolate the conflicting module/binary!

-----------
(Just for info: I cannot revert back to i94 as my website seems to have coding problems and  I have memory access problems, with i94 Apache halts too often, with i95 the server keeps on).


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: admin on May 16, 2007, 01:39:49 PM
Try this instead for those 3 lines...

order allow,deny
allow from 127.0.0.1
deny from all


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: lvadillo on May 16, 2007, 03:37:29 PM
Tested that and the counterpart

order deny,allow
deny from all
allow from 127.0.0.1

The only way to make phpmyadmin is:
order allow,deny
allow from all
# deny from all

and, consecuently I can access phpmyadmin from any place.

tried the following:
order allow,deny
allow from 127.0.0.1
#deny from all

but the Apache service aborted due to: "The Apache service reported the following error: >>> order takes one argument, "allow, deny", "deny,allow", or "mutual-failure".

I tried other combinations but it seems that once "deny from all" is issued, nothing gets access, but, if I try:
order deny,allow
deny from all
allow from all

I can access phpmyadmin, so:

"allow from 127.0.0.1" may be the culprit, as it doesn't enable phpmyadmin, "allow from all" does!!!.
Kind or weird. What in my system forces it no to recognize 127.0.0.1 as itself ?!?


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: admin on May 16, 2007, 06:41:19 PM
Try 'Allow from 127.0. 192.186.' which should allow all the local IPs.


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: lvadillo on May 17, 2007, 08:31:43 AM
No way. I have a clean "hosts file", in there I only left the usual "127.0.0.1 localhost". I'ce tried with many addresses without a valid response (including the PC 192.168.0.104).

If someone tells me that it works in a clean installation of Windows 2000 with pack 4, I could try hoping that what makes this version of Apache respond in this way could be something loaded aside.

Thank you for your help.


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: admin on May 17, 2007, 02:13:32 PM
You could try that line to see if it works? Have you checked Apache's error.log?


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: lvadillo on May 17, 2007, 03:25:59 PM
No way unless I enable all (allow from all), the error I get is:
Code:
[Wed May 16 13:39:55 2007] [error] [client 0.0.0.0] client denied by server configuration: C:/www/webroot/stats/
[Wed May 16 13:40:05 2007] [error] [client 0.0.0.0] client denied by server configuration: C:/www/phpmyadmin

I have no idea why it refers to client o.o.o.o. ?!?
Will try in a couple of days a fresh reload of Windows 2000 to see what happens.


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: admin on May 17, 2007, 03:47:54 PM
0.0.0.0 usually means all interfaces on the system -- all IPs. Which is a bit unusual for a 'client' IP.


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: applepeel on May 21, 2007, 08:35:26 PM
Just to chime in here -- I have installed 1.95 on two fresh installs of both Windows 2000 Pro SP4 and Windows 2000 Advanced Server - Both exhibit the same behavior as above.  I am unable to access any of the web applications - get a 403 for all of them.



Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: admin on May 21, 2007, 09:21:27 PM
From the local system? Have you tried uncommenting the 'allow from all' line under \www\Apache22\conf\Suite-extra\webapps\*.conf ?

What are the contents of \www\Apache22\logs\error.log?


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: applepeel on May 21, 2007, 10:00:48 PM
Thanks for the tip.  It is now working after uncommenting those lines.

However, I AM connecting via localhost-- any reason you can think of that may be causing this?


Thanks!


Title: Re: 1.95. You don't have permission to access /phpmyadmin/ on this server
Post by: applepeel on May 21, 2007, 10:05:15 PM
Forgot to paste in what I was getting in the error log-- basically what the OP was getting:

[Mon May 21 11:59:17 2007] [error] [client 0.0.0.0] client denied by server configuration: C:/www/webapps/joomla, referer: http://localhost:0/webdeveloper/
[Mon May 21 13:34:13 2007] [error] [client 0.0.0.0] client denied by server configuration: C:/www/webroot/stats/, referer: http://localhost:0/webdeveloper/
[Mon May 21 13:34:22 2007] [error] [client 0.0.0.0] client denied by server configuration: C:/www/webapps/phpbb2, referer: http://localhost:0/webdeveloper/
[Mon May 21 13:34:44 2007] [error] [client 0.0.0.0] client denied by server configuration: C:/www/webapps/wordpress, referer: http://localhost:0/webdeveloper/

Client is seen as 0.0.0.0 -- probably the reason why the config "allow from 127.0.0.1" didn't do the trick.