DeveloperSide.NET Forums

DeveloperSide.NET => Anything else goes here => Topic started by: jmcgarvey on April 19, 2007, 01:08:35 PM



Title: WAMP-stack Controller Crashing
Post by: jmcgarvey on April 19, 2007, 01:08:35 PM
Hi,
I just installed WAMP on a new XP machine a few days ago and all was running fine.  Suddenly, the controller application is crashing.  I have uninstalled and reinstalled several times with no luck. Apache/Tomcat/PHP/MySQL are all fine.  Just the controller crashes.  Does anyone know why this might be happening?  See image and error files:

http://www.josephmcgarvey.com/f906_appcompat.xml (http://www.josephmcgarvey.com/f906_appcompat.xml)

(http://www.josephmcgarvey.com/error_01.GIF)

Thanks!

Joe


Title: Re: WAMP-stack Controller Crashing
Post by: admin on April 19, 2007, 06:38:50 PM
Odd. I've never had anyone have problems with it crashing.


Title: Re: WAMP-stack Controller Crashing
Post by: jmcgarvey on April 19, 2007, 10:14:00 PM
Yeah... I run it on another XP machine and it's fine.  It has to be a conflict with another app.  Will update if I find the culprit.


Title: Re: WAMP-stack Controller Crashing
Post by: hrvoje on April 22, 2007, 09:35:51 PM
Hello,
I have the same problem. Controller was working and now it can't be started. In controller.log file I can see that
it is stopped when reading environment - i.e. PATH value. When I truncate PATH, then it is stopped on some other
environment variable (CATALINA_HOME).
If someone is interrested :o) in these log files, I can send it.
Regards
Hrvoje


Title: Re: WAMP-stack Controller Crashing
Post by: vatulaulau on May 20, 2007, 04:04:25 AM
Hi,
I just installed WAMP on a new XP machine a few days ago and all was running fine.  Suddenly, the controller application is crashing.  I have uninstalled and reinstalled several times with no luck. Apache/Tomcat/PHP/MySQL are all fine.  Just the controller crashes.  Does anyone know why this might be happening?  See image and error files:

http://www.josephmcgarvey.com/f906_appcompat.xml (http://www.josephmcgarvey.com/f906_appcompat.xml)

(http://www.josephmcgarvey.com/error_01.GIF)

Thanks!

Joe

I have the same problem on Windows Vista-everything is working fine except for the controller.Having installed/uninstalled and then re-installing the server suite a number of times-it is rather frustrating(Maybe you guys could do a bit more testing with the controller.)


Title: Re: WAMP-stack Controller Crashing
Post by: vatulaulau on May 20, 2007, 04:14:07 AM
Hey sorry about the way my posting above sounds-rude^^;(you guys are giving your time and effort and would like to thank you for that-in taking the time to reply and in developing the server suite.)Hope someone finds a solution to my problem above.Thanks.


Title: Re: WAMP-stack Controller Crashing
Post by: admin on May 20, 2007, 03:42:33 PM
Try this new one... http://www.devside.net/download/WDController.exe

The only thing I recall doing to the last version was commenting out the dyndns GUI part. I've went back and commented out the rest that was associated with the dydns client. Let me know if it helps, or not.


Title: Re: WAMP-stack Controller Crashing
Post by: vatulaulau on May 22, 2007, 11:32:11 PM
 Okay,I have installed the new stack controller that you have "commented out"-the problem is that on the  controller  it says that Apache and MySQL (the two modules plus PHP and phpMyAdmin which I have selected to be installed)are not installed.This is strange since they appear to be working fine-the phpMyAdmin "control panel" displays fine(Apache and MySQL appear to have installed properly as well-iot is the WAMP stack controller that gives a "not installed" display for Apache and MySQL-what could be the problem? )Thanks in advance.


Title: Re: WAMP-stack Controller Crashing
Post by: admin on May 23, 2007, 12:08:49 AM
Have you tried File >> Requery All ? Or closing it and rebooting?

Is it still crashing?

And are you talking about the Services, or the listed "Server Modules and Extensions"?


Title: Re: WAMP-stack Controller Crashing
Post by: admin on May 23, 2007, 12:15:47 AM
The one thing I can think of right now that would cause that services 'not installed' problem, is if you were running the WDController.exe program from a location other than C:\www\...

Save it as a file and place it under 'www' directory of the drive the Suite is installed on. Do not download it to some random IE or firefox d/l location. Do not run it as a link from the browser.



Title: Re: WAMP-stack Controller Crashing
Post by: vatulaulau on May 24, 2007, 09:43:57 AM
It is the Apache 2.2 and MySQL services that give the "not installed" error.The controller is in the C:\\www
directory.I opened the MCL folder located in directory C:\\www\MCL  and then the "controller.txt"file contained in it-sorry I'll post the complete error message next time(I deleted by mistake from my flash-drive)-it says that the controller was not able to initialize the ".net\Framework\1.0",".net\Framework\1.1" and ".net\Framework\2.0" and it says that a "handle" could not initialize and has 6 errors.

Below is the error file:

//Opening the WDC folder in C:\\www\WDC and then opening the "controller.txt" document
//the following message appears.
OpenSCManager failed (5).

Number of system IPs detected: 1

IP 0: 127.0.0.1 (16777343), 1 [Primary]

Clipping string to fit '210' Dialog Units [if needed]...

Control Width: 315 [pixels]

String: 127.0.0.1 [local]
String Length: 17 [characters]

Retrieving handle to a display device context (DC).

Current Detected Font Face: System

Switching to "MS Sans Serif" Font Face...

[Detected] Pixels per logical inch: 96

[Input] Height of font: 10

Current Type Face name of DC: MS Sans Serif

String Width: 76 [pixels]

Releasing handle to the display device context (DC).

Opening value 'InstallRoot' under key 'SOFTWARE\Microsoft\.NETFramework' via Registry...

Value Name: InstallRoot

Value Type: [1] REG_SZ -- null-terminated string.

Value Size: 36 [BYTES] (with terminating NULL(s) if type is REG_SZ, REG_EXPAND_SZ, or REG_MULTI_SZ).

Value Data: C:\Windows\Microsoft.NET\Framework\

.NET v1.0 Runtime NOT Found.

.NET v1.1 Runtime NOT Found.

.NET v2.0 Runtime Found.
File:                 C:\Windows\Microsoft.NET\Framework\v2.0.50727\mscorlib.dll
MajorVersion:         2
MinorVersion:         0
BuildNumber:          50727
RevisionNumber (QFE): 312

Opening value 'CurrentVersion' under key 'SOFTWARE\JavaSoft\Java Development Kit' via Registry...

RegOpenKeyEx() returns: 2.

Querying System Directories and Info...

Computer name: ACER-PC
User name: Acer

Windows Directory: C:\Windows
System Directory: C:\Windows\system32

Hosts File Directory: C:\Windows\system32\drivers\etc

Process Path: C:\www\WDController.exe
'www' Root Path: C:\www

Webroot Path: C:\www\webroot

Apache Root Path: C:\www\Apache22
Apache Logs Path: C:\www\Apache22\logs
Apache Conf Path: C:\www\Apache22\conf
Apache Conf Extra Path: C:\www\Apache22\conf\extra
Apache Conf Suite Path: C:\www\Apache22\conf\Suite-extra

MySQL INI Path: C:\Windows
PHP INI Path: C:\Windows

Environment Variables...

%PATH% -- C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\www\openssl\bin;C:\www\Apache22\bin;C:\www\php5;C:\www\mysql5\bin;C:\www\perl\bin

%JAVA_HOME% -- %JAVA_HOME%

%CATALINA_HOME% -- %CATALINA_HOME%

Mapping Process IDs to IP:PORTs...
CloseServiceHandle(hSCManager) failed (6).



Title: Re: WAMP-stack Controller Crashing
Post by: vatulaulau on May 26, 2007, 02:08:47 AM
 I really hope that the information above is of some help-would really like to install the server suite and begin using it.


Title: Re: WAMP-stack Controller Crashing
Post by: admin on May 26, 2007, 01:20:59 PM
I should have picked up that you are running Vista... This is a permissions problem with an easy fix... Right-click the WDController and select "Run as Administrator"...


Title: Re: WAMP-stack Controller Crashing
Post by: vatulaulau on May 27, 2007, 11:31:55 PM
 Thanks a million man-that was the problem.


Title: Re: WAMP-stack Controller Crashing
Post by: wongcr on July 04, 2007, 04:11:51 AM
I too have been having a similar problem with wdcontroller.exe. I get a ""WAMP Stack Controller has encountered a problem and needs to close" running under XP SP1.
The error signature says AppName: wdcontroller.exe AppVer: 0.9.9.9 Modname: unknown
ModVer: 0.0.0.0 Offset: 20623231
Technical information about the error is:
Exception information: Code: 0xc0000005 Address: 0x0000000020620631
System information: Windows NT 5.1 Build: 2600

This is the last lines in controller.log
Performing Initial ServiceQueryConfig (W3svc)...

Configuration of Service:
        Service Type: 0x00000020
        Start Type: 0x00000003
        Error Control: 0x00000001
        Binary Path Name: C:\WINDOWS\System32\inetsrv\inetinfo.exe
        Dependencies: IISADMIN
        Service Start Name: LocalSystem
        Display Name: World Wide Web Publishing

Performing Initial ServiceQueryDescription (W3svc)...
        Description: Provides Web connectivity and administration through the Internet Information Services snap-in

Any ideas?


Title: Re: WAMP-stack Controller Crashing
Post by: admin on July 04, 2007, 01:17:07 PM
Don't know... Have you tried the latest version of WDController.exe?
http://www.devside.net/download/WDController.exe


Title: Re: WAMP-stack Controller Crashing
Post by: oliverg1 on July 29, 2007, 01:39:28 PM
Hi. I need to thank you guys for all you have done. I feel one should not have to search a phorum to initially run a program. I alsp have Windows XP running as administrator. When I click on Icon on desktop it bombs out, sends a message to Msoft etc. My debugger says it is an access violation. I obviously have the right name + password.

regards

Oliver


Title: Re: WAMP-stack Controller Crashing
Post by: admin on July 29, 2007, 03:41:38 PM
I'm not sure why it does not work for some. I'd have to take a look into it. It does use a few undocumented functions that might not work correctly [or exist] under SP1... Have you tried XP SP2?


Title: Re: WAMP-stack Controller Crashing
Post by: oliverg1 on July 30, 2007, 07:37:48 PM
Hi. I have Service Pack Two. Looking at similar posts I have logged in as a user with Administrator rights , right clicked and logged in as ... Just what is the Initial user name and password?

Many thanks


Title: Re: WAMP-stack Controller Crashing
Post by: admin on July 30, 2007, 09:28:28 PM
The user name for Windows login? 'administrator'


Title: Re: WAMP-stack Controller Crashing
Post by: oliverg1 on August 02, 2007, 06:27:20 PM
Sorry if I have been misread but I presume the user/password is the same as my normal admin password? If so I get a wamp crash - a request to send a message to microsoft etc. The VC++ debugger says accesss violation. This does not appear to be  a silly logon problem. What do you suggest?


Title: Re: WAMP-stack Controller Crashing
Post by: admin on August 02, 2007, 07:49:09 PM
The controller app has no user/password. That is all on the Windows side, and has nothing to do with this package.

You have to run it as Windows user 'Administrator'... Which is the main Windows account.

Do not 'run as Current user...'.

Either login to Windows as administrator, or run as 'Administrator.'

And I have no idea what the admin password is for any system other than mine. It is usually set at installation.