DeveloperSide.NET Forums

DeveloperSide.NET => Web.Developer Server Suite Community Edition,
Public Support Forum => Topic started by: natcolley on May 04, 2007, 01:37:17 AM



Title: New Installer
Post by: natcolley on May 04, 2007, 01:37:17 AM
I have downloaded the new installer and it seems to have worked fine, but http://localhost/webdeveloper doesn't bring anything up although www/wdc/wd-guide/index.html is there. I did a search and the notes about related issues all seem to predate the new version. So, I'm really not sure where to begin. The error is "The Apache 2.2 service terminated with service specific error 1 (0x1)". The Event ID is 7024.


Title: Re: New Installer
Post by: admin on May 04, 2007, 02:18:20 AM
The webdeveloper URL works on my local install... Is everything else working?

Run 'httpd -t' to see if there are any syntax errors with the config.

And post the contents of \www\Apache22\logs\error.log


Title: Re: New Installer
Post by: natcolley on May 04, 2007, 02:44:38 AM
1. running anything from the command line makes it go by in a flash that is impossible to read. How do I slow it down or stop it?
2. I don't have an error file in the logs. I have modsec_audit.log and modsec_debug.
3. I found the readme and I need to stop iis. I hope that doesn't mean I have to uninstall and start over. I'm going to bed now. I'll try stopping iis and rebooting and look for your reply.


Title: Re: New Installer
Post by: admin on May 04, 2007, 03:12:39 AM
1. Run 'cmd.exe' first, then use that to run the commands.

2. If there is no error.log file, than something is wrong or Apache was never installed/started.

3. If you have IIS installed and running, Apache would not have been able to start. You do not need to reinstall. Just stop/remove IIS and try starting Apache.


Title: Re: New Installer
Post by: natcolley on May 04, 2007, 12:39:50 PM
1. learning cmd.exe is worth the price of admission all by itself. thank you!
2. syntax ok
3. localhost/webdeveloper works fine.
4. Now all I have to do is work those tweaks I was researching before I downloaded about getting apache and iis to play nice. I know what i'll doing this weekend!

thanx agn


Title: Re: New Installer
Post by: natcolley on May 13, 2007, 01:36:43 AM
Hi there. I'm back.

So I have put in a new internal ip for WAMP, and told both WAMP and IIS to listen to their respective IP's. Both services are running now, as are sql and mysql. I did the -S and corrected the errors it reported. Both of my wamp domains show the apache 403 forbidden page from outside my network. I'm guessing that means I haven't loaded/configured the modules, or they can't find the new IP, but I looked at the components.conf file and I don't know what I'm supposed to do differently. Besides, localhost/webdeveloper and wordpress came up before but don't now ("page cannot be displayed").

Please advise. Thx.


Title: Re: New Installer
Post by: natcolley on May 13, 2007, 02:05:00 AM
p.s. - I checked the error logs: "client denied by server configuration   www/webapps/joomla". Not sure why it says webapps when I set it to webroot. Please advise.


Title: Re: New Installer
Post by: admin on May 13, 2007, 03:59:27 AM
URL http://your-ip/ is shown as forbidden from outside, or just the http://your-ip/<webapp>/ URLs?

If the latter, all webapps are bound locally for security reasons. Just edit the appropriate C:\www\Apache22\conf\Suite-extra\webapps\*.conf file and change...
Code:
order allow,deny
allow from 127.0.0.1
# allow from all

to...
Code:
order allow,deny
# allow from 127.0.0.1
allow from all


Title: Re: New Installer
Post by: natcolley on May 13, 2007, 08:15:04 PM
I can't help but feeling like all of this is either painfully obvious or all written down in a file I haven't found. I think the IP problem is fixed, it was something I did wrong in the httpcfg. But I am still not getting into any of the web developer stuff from localhost or outside my network. I changed the comment on wordpress as you suggested. Now I have these issues:

1. The setup page to my modem flashes on the screen for half a second and then I get the 404 page: 
Quote
http://www.mydomain.com/cgi-bin/webcm?getpage=..%2Fhtml%2Fatec.html.

2. Is there a file that lays out step by step what I am supposed to do to get these apps online? Where is it?

3. Do I have to restart every time I make a change to a conf file see it?

I'd really like to get this done today because I'm usually too zapped with work during the week to spend much time on it. Thx.



Title: Re: New Installer
Post by: admin on May 13, 2007, 10:01:57 PM
You should have been able to access http://localhost/wordpress from the start. Everything has been pre-configured. If that's not working I suggest you put aside anything to do with accessing from the outside for the time being.

You have to restart Apache after a conf change.

Most of the basic info is in the online Guide, which also comes under http://localhost/webdeveloper/


Title: Re: New Installer
Post by: natcolley on May 13, 2007, 10:31:20 PM
I'm really not that fluent in technology. I was hoping for a step by step, do this, then do that, sort of guide that would tell me how to get my apps up and running since they aren't installed by default. For example, I would not have known that I needed to move the # sign as you instructed in an earlier message in this thread.

The guide and the notes simply do not give me this level of detail as to what I am supposed to be doing here.

You say I should set aside accessing from the outside "for the time being". And how long is that? And what am I supposed to be doing in the mean time? Let my server just sit there? The whole point was to get these sites up and running. I need more direction.

The install did work, and I could access wordpress from localhost, but now I can't. I think this started when I altered httpcfg to make apache and iis work together. I tried just blocking iis from the ip and port set aside for apache, but apache still wouldn't start. then I went back and told iis to listen only to it's ip, and both apache and iis started automatically and seem to run fine. But since I could not access webdeveloper, (this is when I was getting the forbidden 403 error) I went back in and re-set the apache ip in httpcfg. After that, I got 404 errors and the modem setup page instead of my domains from outside and page cannot be displayed from inside.

The only thing I can think of now is to go back to httpcfg and start from scratch. I would greatly appreciate some specific feedback on this issue, as well as that step by step, here's how to turn on your apps guidance. And if I need to uninstall and reinstall, I can do that too, I just need some specific guidance from you.

Thank you.


Title: Re: New Installer
Post by: admin on May 13, 2007, 10:45:15 PM
Quote
You say I should set aside accessing from the outside "for the time being". And how long is that? And what am I supposed to be doing in the mean time? Let my server just sit there? The whole point was to get these sites up and running. I need more direction.

Until it's working from localhost, there is no point in trying to get it to work from the outside. One follows the other.

In any case, with the default setup, to install a webapp, and allow access from outside...
1) Hit the specified URL, do the setup where you enter something like name of blog, email, etc... Everything else has been pre-configured.
2) Uncomment 'access from all', as we talked about earlier.

Nothing else is needed.

It seems your problem is with the IIS/Apache combination. I suggest you stop IIS, and start with Apache by itself. Once everything is working, you can add IIS into the mix if you really need it.

Unless you have made other config changes, all the webapp URLs will work. Go back to 'Listen 80' for Apache.

If you are behind a router/modem, you might also need to 'port forward' port 80 to the local LAN IP [to access from outside].


Title: Re: New Installer
Post by: natcolley on May 15, 2007, 05:39:40 PM
Ok, I disabled IIS and put the apache conf back to 'listen 80'. I'm at work now so I didn't have a chance to test localhost but I can tell you that all of my domains from outside come to the same page, which is "index of /" and it lists files like webdeveloper.php and phpinfo.

Clicking on webdeveloper.php from this page in firefox brings up 'can't establish a connection to the server at localhost'. Should it be making reference to localhost when contacted from outside?

Clicking on phpinfo brings up that whole page. Should this be happening from outside?

It seems to me this is a path problem. Under "apache environment" it says the path is

Quote
C:\Program Files\Support Tools\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Microsoft SQL Server\80\Tools\Binn\;C:\www\openssl\bin;C:\www\Apache22\bin;C:\www\php5;C:\www\mysql5\bin;C:\www\perl\bin;C:\Program Files\Microsoft Windows Small Business Server\Networking\

I hope this helps you help me. Thx.


Title: Re: New Installer
Post by: admin on May 15, 2007, 08:16:38 PM
Quote
Clicking on webdeveloper.php from this page in firefox brings up 'can't establish a connection to the server at localhost'. Should it be making reference to localhost when contacted from outside?

Clicking on phpinfo brings up that whole page. Should this be happening from outside?

Sounds like everything is working as it should....

webdeveloper.php redirects to 'localhost'...  And the system you are accessing from, will always think 'localhost' is itself... So no connection will be established unless its done from the local system that Web-Developer Server Suite is running from.

If phpinfo.php is displaying the php info, and you are seeing it from the outside, then php is working, and your router/modem is port forwarding port 80. If you do not want others to see it, delete the phpinfo.php file.

So everything is good.


Title: Re: New Installer
Post by: natcolley on May 17, 2007, 07:20:14 PM
Yea, I think I'm good. Thx.Two things:

When Apache is set to listen 80, what exactly is it listening to? The wan? I would think not. The gateway? Maybe. The IP assigned to that machine? Seems reasonable. I may have screwed up by using the ip from the firewall's internal rather than external network.

Why aren't you offering SMF as part of your installer package, especially since this forum is SMF? Does it work with SMF?

Thx for all the good work.


Title: Re: New Installer
Post by: admin on May 17, 2007, 09:30:45 PM
'Listen 80' mean listen on port 80, which is the "http" port, on all interfaces on the system [all IPs of the system].

"LAN -- modem/router -- WAN" is how it is. Everything is LAN on our side.

I would get rid of phpBB from the distro, and replace it with SMF if I could... SMF's license does not permit redistribution.


Title: Re: New Installer
Post by: natcolley on May 17, 2007, 11:07:49 PM
Quote
I would get rid of phpBB from the distro, and replace it with SMF if I could... SMF's license does not permit redistribution.

Can we download it from SMF ourselves and make it work with your distro?


Title: Re: New Installer
Post by: admin on May 17, 2007, 11:13:18 PM
Yes. It will work just fine, I've had it running locally on the Suite, to test it out, before I switched our Forums from phpBB to SMF on our Linux Server.


Title: Re: New Installer
Post by: natcolley on May 21, 2007, 01:22:44 AM
Quote
In any case, with the default setup, to install a webapp, and allow access from outside...
1) Hit the specified URL, do the setup where you enter something like name of blog, email, etc... Everything else has been pre-configured.
2) Uncomment 'access from all', as we talked about earlier.

Nothing else is needed.

I don't want to keep having to come back to you with this, but I'm not getting it. I have stopped IIS, I can get the site to come up on localhost, I uncommented access to all, but I still can't get it over the internet. I'm sure it is something simple but I have no idea what it is. How do I get wordpress to come up as my domain on the internet?

I'm pretty sure the browser is hitting my server. The 404 error includes references to apache.

I ran -t again and there are no syntax errors but I did get a warning that "DocumentRoot [c:/www/webroot/wordpress] does not exist". The whole webroot vs webapps thing is a complete mystery to me.

Can you remote in and check my code? Should I paste my code here for you to look at? If so, which files? If not, I need instruction. Keep it simple, step by step, dummed down, assume I know nothing, because apparently I don't.


Title: Re: New Installer
Post by: admin on May 21, 2007, 02:20:13 AM
So you changed the DocumentRoot under httpd.conf? Because you want to see wordpress from domain/ and not domain/wordpress? What else have you changed?


Title: Re: New Installer
Post by: admin on May 21, 2007, 02:31:56 AM
From the _default_ setup you would...
1) Move everything that is under \www\webapps\wordpress to \www\webroot
2) Edit wordpress.conf to...
Code:
<IfModule !mod_rewrite.c>
LoadModule rewrite_module modules/mod_rewrite.so
</IfModule>

AccessFileName .htaccess
<Files ~ "^\.htaccess$">
order allow,deny
deny from all
</Files>

<Directory "/www/webroot">
Options FollowSymLinks
AllowOverride FileInfo

order allow,deny
allow from all

AddType text/html .php
AddHandler application/x-httpd-php .php
</Directory>

3) Edit \www\webroot\.htaccess to...
Code:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress


Title: Re: New Installer
Post by: natcolley on May 21, 2007, 03:10:21 AM
So you changed the DocumentRoot under httpd.conf?

No. Here is what I assume to be the relevant portion of httpd.conf:

Quote
Listen 80

ServerRoot "/www/Apache22"
DocumentRoot "/www/webroot"

ServerName localhost:80
ServerAdmin admin@localhost

ErrorLog logs/error.log
LogLevel error

Quote
Because you want to see wordpress from domain/ and not domain/wordpress?
Yes.

Quote
What else have you changed?

This is httpd-vhosts.conf:

Quote
#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

# Use name-based virtual hosting.

NameVirtualHost *:80

<VirtualHost *:80>
    ServerAdmin admin@mydomain2.com
    DocumentRoot /www/webroot/wordpress
    ServerName mydomain1.com
    ServerAlias mydomain1.com *.mydomain1.com
    ErrorLog logs/mydomain1.com-error_log
    CustomLog logs/mydomain1.com-access_log common
</VirtualHost>

<VirtualHost *:80>
    ServerName www.mydomain2.com
    DocumentRoot /www/webroot/joomla
    ServerName mydomain2.com
    ServerAlias mydomain2.com
    ErrorLog logs/mydomain2.com-error_log
    CustomLog logs/mydomain2.com-access_log common
</VirtualHost>
#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#
#<VirtualHost *:80>
#    ServerAdmin webmaster@dummy-host.example.com
#    DocumentRoot /www/webroot/dummy-host.example.com
#    ServerName dummy-host.example.com
#    ServerAlias www.dummy-host.example.com
#    ErrorLog logs/dummy-host.example.com-error_log
#    CustomLog logs/dummy-host.example.com-access_log common
#</VirtualHost>
#
#<VirtualHost *:80>
#    ServerAdmin webmaster@dummy-host2.example.com
#    DocumentRoot /www/webroot/dummy-host2.example.com
#    ServerName dummy-host2.example.com
#    ErrorLog logs/dummy-host2.example.com-error_log
#    CustomLog logs/dummy-host2.example.com-access_log common
#</VirtualHost>
[/quote]


Title: Re: New Installer
Post by: admin on May 21, 2007, 03:14:33 AM
Add the modified wordpress.conf code into the VH block.


Title: Re: New Installer
Post by: natcolley on May 21, 2007, 04:08:03 AM
Quote
From the _default_ setup you would...
1) Move everything that is under \www\webapps\wordpress to \www\webroot
2) Edit wordpress.conf to...
3) Edit \www\webroot\.htaccess to...

I'm just a guy with an idea for a website. I didn't go to school for any of this. If I could have found a hosting service that didn't have so damn many rules and restrictions, I wouldn't be trying to do all this tech stuff myself, I'd just be posting content. But I'm here now, I own the server, so since I'm doing it I really want to understand as much as I can. So, how would I have known to make all these changes? Is it in a book or website somewhere? Because I looked all over your notes, wordpress.org, and googled the hell out of it and got nowhere.

Quote
Add the modified wordpress.conf code into the VH block.

I've made the changes, restarted apache, and from outside, Firefox is unable to connect as it did a few minutes ago. I went back to the server and got the message "windows is not able to start apache". I then went to the event viewer and found:
Event Type:   Error
Event Source:   Apache Service
Event Category:   None
Event ID:   3299
Date:      5/20/2007
Time:      10:29:23 PM
Description:
The Apache service named  reported the following error:
>>> Warning: DocumentRoot [C:/www/webroot/joomla] does not exist     .

fyi, joomla is supposed to be mydomain2, which is why I was trying to use virtualhost. I have not tried to install joomla because I wanted to get wordpress right first.


Title: Re: New Installer
Post by: admin on May 21, 2007, 05:33:20 AM
Quote
Warning: DocumentRoot [C:/www/webroot/joomla] does not exist

Chances are, as per the message, you have not created that directory... C:/www/webroot/joomla... Create it and restart Apache. Specified VH DocumentRoots have to exist.

As far as knowing how to do this and that, well, it all comes down to experience. Mine is from starting this project back in 2003, working on it, getting my hands dirty, persisting in solving problems, providing user support, etc...

There are a few books and a few good sites, but if you ask me, just work on it, start of simple, and read the Apache Manual.


Title: Re: New Installer
Post by: natcolley on May 21, 2007, 03:49:54 PM
ok, so I'm getting my hands dirty ;-). In order to create the joomla document root, I moved the /webappps/joomla folder to /webroot/joomla, at which time I got an 0x1 error and apache would not start. So I assume that means either I need to empty the joomla folder contents into webroot as I did with wordpress, or I need a file (rather than a folder) in /webroot that acts as a documentroot and tells the server where to go to get the rest of the joomla stuff, which is mydomain2. Is this right? Do I also need to alter .htaccess? Thx.


Title: Re: New Installer
Post by: admin on May 21, 2007, 04:33:36 PM
All I wanted you to do was create an empty directory named 'joomla', nothing more... So we could get past the error and establish wp is working like you want it too.

I would undo any damage done so far [just start over] and keep it this way...

<VirtualHost *:80>
    ServerAdmin admin@mydomain2.com
    DocumentRoot /www/webroot/wordpress
    ServerName mydomain1.com
    ServerAlias www.mydomain1.com
    ErrorLog logs/mydomain1.com-error_log
    CustomLog logs/mydomain1.com-access_log common
</VirtualHost>

<VirtualHost *:80>
    ServerName www.mydomain2.com
    DocumentRoot /www/webroot/joomla
    ServerName mydomain2.com
    ServerAlias www.mydomain2.com
    ErrorLog logs/mydomain2.com-error_log
    CustomLog logs/mydomain2.com-access_log common
</VirtualHost>

Edit wordpress.conf and joomla.conf...
Remove the alias lines.
Update 'allow from all'.

Update wp's .htaccess file as above.

What you are doing will not work.

You might, or might not, also need put dir permissions under each VH block -- but that really should have already been taken care of by wordpress.conf, etc...

Just start out doing one thing, and check Apache's error.log when you get an error.


Title: Re: New Installer
Post by: admin on May 22, 2007, 03:51:04 PM
My mistake... The above VH blocks should have docroots of /www/webapps/wordpress, /www/webapps/joomla, etc... if done my way.


Title: Re: New Installer
Post by: natcolley on May 22, 2007, 04:56:59 PM
Ok, thx, I will incorporate first chance I get. I undid everything else as you suggested. Apache starts and webdeveloper comes up in localhost again, but the sites did not come up from outside nor did it appear I was even hitting the server, but as I said, I will look into it more first chance I get (work gets in the way) and let you know how it goes.


Title: Re: New Installer
Post by: natcolley on May 29, 2007, 03:21:27 AM
I have these identified issues at the moment:

1. I followed your earlier suggestions and now I get wordpress as the default for mydomain1. Thank you. However, it is just plain html. I get none of the formatting/css or whatever that I see from localhost/wordpress. I checked the source code and the links are all to localhost/wordpress, therefore, from the internet, none of the links are reachable. However, the default blogroll has full links and bring up those other blogs. Surely I don't have to go thru every line of code to fix this?

2. If I type in mydomain1.com/joomla, joomla comes up. This is NOT what I want. Joomla is supposed to be mydomain2.com - only, and the homepage thereof. Similarly, if I type in mydomain2.com, I get the mydomain1.com homepage, i.e., wordpress.

3. I configured vhosts.conf as I had before, and as before both domains went to the same default " index of / " page. Then I made the changes so that wordpress became the homepage of mydomain1, but vhosts is obviously not working because in addition to #2 above, I did not get back to change DocumentRoot from /www/webapps/wordpress and yet wordpress does come up now.

Please advise.


Title: Re: New Installer
Post by: natcolley on May 29, 2007, 04:00:29 AM
p.s.

I read on wordpress.org that I should move the wordpress files to the right directory before installing, but since webdeveloper is set to localhost, is that going to solve my problem? Can I just uninstall wordpress and start that over without uninstalling the whole suite?

I forgot to mention that in addition to the issues outlined in my last post, I can't access siteadmin from wordpress. I'm guessing that's the same issue - i.e., by default it is set to look on localhost not /. Is this right?

thx


Title: Re: New Installer
Post by: natcolley on May 29, 2007, 11:32:20 AM
p. s. s.

What did you envision being put in the root directory to be served out to the internet by your users? Because I would think most users would want one of the webapps to be the default just like I do, and if you have to move the app out of /www/webapps/whatever then your whole security rationale for putting the apps there in the first place is shot, right? So, how did you envision this working on a real public site? That would help me understand the system and it's setup. Thx.


Title: Re: New Installer
Post by: natcolley on May 30, 2007, 11:46:13 AM
It's been more than 24 hours and I have not heard from you? What's up? If I can't get this thing off localhost, or get vhost to work, I can't use this thing. This is why I was asking for step by step instructions. You are reaching beyond other computer types to ordinary folks who don't know their way around as easily. Please respond. Thx.


Title: Re: New Installer
Post by: admin on May 30, 2007, 02:34:28 PM
There are many ways you can do this... This is the simplest... This is how it would work from the default, untouched, setup...

Edit \www\Apache22\conf\Suite-extra\components.conf

Comment out lines...
Include conf/Suite-extra/webapps/drupal.conf
Include conf/Suite-extra/webapps/wordpress.conf

Edit \www\Apache22\conf\httpd.conf

Uncomment line...
#Include conf/extra/httpd-vhosts.conf

Edit \www\Apache22\conf\extra\httpd-vhosts.conf

Add...

<VirtualHost *:80>
   ServerName domain1.com
   ServerAlias www.domain1.com
   DocumentRoot /www/webapps/drupal
   ErrorLog logs/domain1-error.log
   CustomLog logs/domain1-access.log common

   <Directory "/www/webapps/drupal">
      Options FollowSymLinks
      AllowOverride All
      order allow,deny
      allow from all

      AddType text/html .php .phps
      AddHandler application/x-httpd-php .php
      AddHandler application/x-httpd-php-source .phps

   </Directory>
</VirtualHost>

<VirtualHost *:80>
   ServerName domain2.com
   ServerAlias www.domain2.com
   DocumentRoot /www/webapps/wordpress
   ErrorLog logs/domain2-error.log
   CustomLog logs/domain2-access.log common

   <Directory "/www/webapps/wordpress">
      Options FollowSymLinks
      AllowOverride All
      order allow,deny
      allow from all

      AddType text/html .php .phps
      AddHandler application/x-httpd-php .php
      AddHandler application/x-httpd-php-source .phps

   </Directory>
</VirtualHost>

Edit \www\webapps\drupal\.htaccess and comment out line...
RewriteBase /drupal

Edit \www\webapps\wordpress\.htaccess

Comment out line...
RewriteBase /wordpress/

Edit line...
RewriteRule . /wordpress/index.php [L]
to...
RewriteRule . /index.php [L]

I've done this on my local install and it works, loading drupal on domain1.com and wordpress on domain2.com.

Since you are not using localhost anymore, when you hit the setup/install scripts of the webapps, do not install to "localhost", but to the actual domains -- or the css is going to come out all wrong on the screen.

As a note: without further configuration http://localhost will also now be the 1st VH that Apache finds [domain1], and not \www\webroot


Title: Re: New Installer
Post by: admin on May 30, 2007, 02:45:58 PM
Quote
What did you envision being put in the root directory to be served out to the internet by your users? Because I would think most users would want one of the webapps to be the default just like I do, and if you have to move the app out of /www/webapps/whatever then your whole security rationale for putting the apps there in the first place is shot, right? So, how did you envision this working on a real public site? That would help me understand the system and it's setup. Thx.

I could have put 1 of the webapps under webroot, and it would have turned into 'localhost', which defeats the base setup and the easy ability to test things out: thrown some html or php here and see what happens.

I do understand what you are saying about most users want one of the webapps set up to localhost by default, probably wordpress as blogs are now everywhere.

As far as the security goes, its not the difference between "not-secure" and "secure", but more like the difference between "secure" and "a-little-more-secure-and-cleaner". And you do not have to move any webapps into webroot as long as you either use VHs [as above] or Aliases [as under Suite-extra\webapps\*.conf]



Title: Re: New Installer
Post by: natcolley on May 30, 2007, 05:22:04 PM
Ok, thx. I will report back as soon as I am able.


Title: Re: New Installer
Post by: natcolley on June 05, 2007, 07:17:08 PM
Quote
Edit \www\webapps\drupal\.htaccess and comment out line...
RewriteBase /drupal

I am actually using joomla, not drupal, for this site, but I figured it didn't make any difference until I got to this point, because it says RewriteBase / without the joomla. Should I still uncomment or leave it alone?


Title: Re: New Installer
Post by: admin on June 05, 2007, 08:01:36 PM
In this case, it should not make any difference either way since joomla is a / of a vh.


Title: Re: New Installer
Post by: natcolley on June 08, 2007, 01:20:27 PM
Ok, my domains are up and running. Thank you. I've gone back to revive my old post under "configuration" in 'anything else goes here'.