DeveloperSide.NET Forums

DeveloperSide.NET => Anything else goes here => Topic started by: createdcreator on July 21, 2007, 02:14:38 AM



Title: IE cannot display the page
Post by: createdcreator on July 21, 2007, 02:14:38 AM
Hello everyone.

I am new to web development. I recently installed  wamp server suite into my computer. However, as I make several web pages using PHP, IE tells me that it cannot display the page which definitely exists in my directory.

How will I resolve this problem?

Thanks.

Jess


Title: Re: IE cannot display the page
Post by: admin on July 21, 2007, 03:01:23 PM
Can you see http://localhost and http://localhost/phpinfo.php ? Are you placing your PHP file under \www\webroot and naming them with the .php extension?


Title: Re: IE cannot display the page
Post by: omnyx on July 21, 2007, 09:22:53 PM
i'm having the same issue. typing
http://localhost/
or
http://localhost/phpinfo.php

gives me a 404 error (page does not exist even though i know the pages exist in the webroot folder)...Also whatever else is in the webroot folder is not accessible (error 404) from the http://localhost except the 'stats' folder which for some reason is visible, i.e.
http://localhost/stats/
returns the 'stats' folder
but
http://localhost/aspsample/
doesn't return anything (page not found)...even if I create a new folder within webroot it's 'non-existant' to the browser...
so, should I put all my .php files in 'stats' folder and work from there? :)


Title: Re: IE cannot display the page
Post by: admin on July 21, 2007, 09:38:01 PM
What are the contents of \www\Apache22\logs\access.log and error.log?


Title: Re: IE cannot display the page
Post by: omnyx on July 22, 2007, 12:04:41 AM
both access.log and error.log have nothing for today's date.
i.e. access.log has been last modified when I installed the suite (back in june)
and error.log has nothing for today's date (last message is from two days ago...might be something i did with drupal)...today was the first time when I typed something like this in localhost so the error never happened before...
thanks


Title: Re: IE cannot display the page
Post by: admin on July 22, 2007, 02:00:32 PM
Load up localhost, phpinfo.php, and stats in your browser. There is nothing under access.log and error.log about those requests?


Title: Re: IE cannot display the page
Post by: omnyx on July 22, 2007, 02:15:22 PM
so the access.log wasn't modified for over a month (since the date I installed the suite).
this is what I got under error.log (for today's date)

[Sun Jul 22 10:54:27 2007] [notice] Server built: Mar 20 2007 13:02:00
[Sun Jul 22 10:54:27 2007] [notice] Parent: Created child process 3612
Warning: DocumentRoot [C:/www/webroot/dummy-host.example.com] does not exist
Warning: DocumentRoot [C:/www/webroot/dummy-host2.example.com] does not exist
[Sun Jul 22 10:54:30 2007] [notice] ModSecurity for Apache 2.1.0 configured
[Sun Jul 22 10:54:32 2007] [notice] Child 3612: Child process is running
[Sun Jul 22 10:54:32 2007] [notice] Child 3612: Acquired the start mutex.
[Sun Jul 22 10:54:32 2007] [notice] FastCGI: process manager initialized
[Sun Jul 22 10:54:32 2007] [notice] Child 3612: Starting 250 worker threads.
[Sun Jul 22 10:54:32 2007] [notice] Child 3612: Starting thread to listen on port 443.
[Sun Jul 22 10:54:32 2007] [notice] Child 3612: Starting thread to listen on port 80.

though, I was doing some things in drupal today....
again, I can only see /stats/ folder and everything inside...however, just localhost or anything within it except for stats folder is still giving me error 404.


Title: Re: IE cannot display the page
Post by: admin on July 22, 2007, 02:52:32 PM
Perhaps you have turned off the log feature somehow and edited the config files in a bad way. All 404, and otherwise, errors get reported under error.log, all other requests get logged under access.log.


Title: Re: IE cannot display the page
Post by: omnyx on July 22, 2007, 03:14:10 PM
huh...but how would I get it back (the log settings)?
I just started using the suite 'out of the box' when I installed...didn't do any other configuration on my own...
thanks


Title: Re: IE cannot display the page
Post by: admin on July 22, 2007, 05:21:25 PM
Is the option of uninstalling and reinstalling the suite feasible for you? That would be the quickest way.

Thought it does look like you have made changes to the config files under \www\Apache22\conf\ as the error log shows some VHs that are not turned on by default.


Title: Re: IE cannot display the page
Post by: createdcreator on July 23, 2007, 05:31:22 AM
Thanks for the help guys!

Jess