DeveloperSide.NET Forums

DeveloperSide.NET => Anything else goes here => Topic started by: jtwchang on July 25, 2007, 09:23:21 PM



Title: problem with first login to drupal, first account, password, and sending emails
Post by: jtwchang on July 25, 2007, 09:23:21 PM
Hello.  I installed the developer.net package on Windows XP professional, and I am trying to log in to Drupal.  I seem to have created an account (I don't remember doing this, but when I try to create a new account with my favorite account name, I get the message that the name is already taken).  [By the way, I have been spending way too much time at my computer and have a bad memory, so I am ready to believe that I forgot that I created an account, or maybe somehow created one unintentionally.]  But I don't know the password  for that account (I tried my favorite password and it didn't work, which also seems strange, since if I had created an account with my favorite name, I believe I would have used my favorite password).  So I tried to do the "Request new password" operation, and when I clicked "email new password", I got the message

warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\www\webapps\drupal\includes\common.inc on line 1970.  Unable to send mail. Please contact the site admin.

I know extremely little about any of this, and I tried reading on the web.  This led me to think maybe I could use gmail's SMTP, and so I tried making a couple of changes in the file C:\WINDOWS\php.ini, commenting out (with ";;;") and replacing two lines as follows:

[mail function]
; For Win32 only.
;;; SMTP = localhost
SMTP = smtp.gmail.com
smtp_port = 25
; For Win32 only.
;;; sendmail_from = admin@localhost
sendmail_from = jtwchang@gmail.com

And I found out about restarting Apache using services.msc, which I did.  This led to a similar error message:

warning: mail() [function.mail]: Failed to connect to mailserver at "smtp.gmail.com" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\www\webapps\drupal\includes\common.inc on line 1970.  Unable to send mail. Please contact the site admin.

So at this point, I am not sure what is the best way to get unstuck.  If I learn how to enable Drupal to send emails, I can find out my missing password, I imagine.  (I am still even a bit confused about what happened and doubtful about my having created an account, though...)  Or is there another way to do this?  If I have to and if it would be likely to work, I could uninstall developerside.net and reinstall it and start over again hopefully when I am alert.

Hope that made sense; thanks very much for any help!




Title: Re: problem with first login to drupal, first account, password, and sending ema
Post by: admin on July 25, 2007, 09:29:57 PM
Check the sticky thread in the support forum about sending mail... You might be able to use the gmail smtp server, I don't know... But I do know you need to specify the username and password for that smtp server.

And unless you want to edit the drupal database, and reset the password manually, the quick way would be just to uninstall/reinstall.


Title: Re: problem with first login to drupal, first account, password, and sending emails
Post by: night2dark2 on August 30, 2007, 09:49:40 PM
I've been trying to find googles SMTP. I know its not port 25.
And you use
[mail function]
; For Win32 only.
;;; SMTP = localhost
SMTP = smtp.gmail.com
smtp_port = 467
; For Win32 only.
;;; sendmail_from = admin@localhost
sendmail_from = jtwchang@gmail.com:(PASSWORD HERE)