DeveloperSide.NET Forums

DeveloperSide.NET => Web.Developer Server Suite Community Edition,
Public Support Forum => Topic started by: BernieW on May 26, 2008, 04:26:41 PM



Title: Odd issue with starting the Apache22 server service
Post by: BernieW on May 26, 2008, 04:26:41 PM
I have an odd issue with starting the Apache22 server service.

When I try to use the manual (demand) option to start Apache, I receive an Error[1] message. However if I set the Automatic option to start the service automatically I have no problem.

This is the only service I am having that problem with, MySQL and Tomcat5 have no problems with starting via the manual option.

I am using Web.Developer Server Suite Community Edition v2.0


Title: Re: Odd issue with starting the Apache22 server service
Post by: admin on May 26, 2008, 04:30:39 PM
Check file C:\www\Apache22\logs\error.log for any clues available.


Title: Re: Odd issue with starting the Apache22 server service
Post by: BernieW on May 26, 2008, 05:10:36 PM
There does not seem to be any errors listed in the error.log file.

This is from the last successful start (when configured for Automatic)

Quote
[Mon May 26 12:15:25 2008] [notice] ModSecurity for Apache 2.1.3 configured
[Mon May 26 12:15:38 2008] [notice] Apache/2.2.6 (Win32) mod_ssl/2.2.6 OpenSSL/0.9.8g PHP/5.2.5 configured -- resuming normal operations
[Mon May 26 12:15:38 2008] [notice] Server built: Sep 20 2007 14:13:35
[Mon May 26 12:15:38 2008] [notice] Parent: Created child process 2880
[Mon May 26 12:15:40 2008] [notice] ModSecurity for Apache 2.1.3 configured
[Mon May 26 12:15:42 2008] [notice] Child 2880: Child process is running
[Mon May 26 12:15:42 2008] [notice] Child 2880: Acquired the start mutex.
[Mon May 26 12:15:42 2008] [notice] Child 2880: Starting 250 worker threads.
[Mon May 26 12:15:42 2008] [notice] Child 2880: Starting thread to listen on port 443.
[Mon May 26 12:15:42 2008] [notice] Child 2880: Starting thread to listen on port 80.
[Mon May 26 12:25:52 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon May 26 12:25:52 2008] [notice] Child 2880: Exit event signaled. Child process is ending.
[Mon May 26 12:25:53 2008] [notice] Child 2880: Released the start mutex
[Mon May 26 12:25:54 2008] [notice] Child 2880: Waiting for 250 worker threads to exit.
[Mon May 26 12:25:54 2008] [notice] Child 2880: All worker threads have exited.
[Mon May 26 12:25:54 2008] [notice] Child 2880: Child process is exiting
[Mon May 26 12:25:54 2008] [notice] Parent: Child process exited successfully.

I did try to start apache from the command prompt and this is what is returned:

Quote
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\HP_Administrator>cd \

C:\>cd www\apache22\bin

C:\www\Apache22\bin>httpd -k start
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted.  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

C:\www\Apache22\bin>


Title: Re: Odd issue with starting the Apache22 server service
Post by: admin on May 26, 2008, 05:13:09 PM
The last part means Apache was already started when you ran httpd -k start. The rest looks good. I'm not sure what would cause the original problem.


Title: Re: Odd issue with starting the Apache22 server service
Post by: BernieW on May 26, 2008, 05:52:52 PM
Thank you very much for the help, I found the problem.

The Apache service will not start manually when IIS W3 is running; I must stop IIS W3 then start Apache then start IIS W3.

I am guessing that when the Apache service starts automatically during Windows startup it is started before IIS.