DeveloperSide.NET Forums

DeveloperSide.NET => Web.Developer Server Suite Community Edition,
Public Support Forum => Topic started by: Shareworks on September 27, 2003, 09:40:49 AM



Title: .php works, but .php3 is shown as text
Post by: Shareworks on September 27, 2003, 09:40:49 AM
Hi everybody,


I'm runnign Apache 2, PHP 4.3.3 and MySQL 4 on a Win2K Pro machine with all the servicepacks (1 to 4)
Needless to say, I'm new at this whole server stuff, but I have some experience with some other software, so I got everything running, except for 2 things:

1:

when I use the internet to go to my site (which is hosted from the same PC) I can use .php sites. However, documents with the .php3 extension are shown as text. Do I have to add something to my httpd.conf, and if so, what?

Next, somewhat more complicated..

2:

I installed MySQL 4, and ran the WinAdmin program that came with it.
Is also donloaded and installed MySQL Control Center. I disabled the WinAdmin program and the service that was started with it. I then used the Control Center to create a new database. However, the program hangs all the time. This means I can't start the database or service.
Do you know how this is normally done? I need this database to run Phorum.

Thank you very much for all the help you can give me,

Ralf


Title: First one is fixed!!
Post by: Shareworks on September 27, 2003, 09:45:23 AM
hi there,

Never mind the first question, I simply added the .php3 on the wrong line in httpd.conf.

I created a new Addtype, but this was wrong. Just add ' .php3' after '.php' on the existing AddType line.

Stupid me...

a yes, can't know everything...

thanks,


Title: .php works, but .php3 is shown as text
Post by: Anonymous on September 27, 2003, 08:01:46 PM
you need to make sure mysql is installed in services and is running.

read the mysql tutorial/building instructions on this site