DeveloperSide.NET Forums

DeveloperSide.NET => Building a Web Server, for Linux => Topic started by: LinuxRules on October 29, 2004, 08:06:47 AM



Title: Apache/MySQL servers not passing variables to next page?!
Post by: LinuxRules on October 29, 2004, 08:06:47 AM
Built the complete suite of programs as per the tutorial - everything working fine except for one thing - when you click on a link in a page that takes you to another page with results of an SQL query passed, the query string does not seem to arrive at the other page - any ideas?

example:
file1:
<a href="goto_next_page.php?showitem='12345'">Go to next page and pass '12345' to it</a>

file goto_next_page.php:
.
.
connect to mysql sever and database... (connects fine)
.
.
$sql_string = "SELECT * FROM sometable WHERE SomeTableVar = $showitem;";

Result displayed on next page:
Couldn't execute query - SELECT * FROM sometable WHERE SomeTableVar = ;


My variable named $showitem not passed it seems?!
Strange thing, this exact same code works on a Windows ME and XP box/setup without any problems!

Any ideas?
Thanx.


Title: Apache/MySQL servers not passing variables to next page?!
Post by: admin on October 29, 2004, 10:18:15 AM
Maybe something related to the problem (register_globals, _GET[]) under...
http://forums.devside.net/viewtopic.php?t=506


Title: Apache/MySQL servers not passing variables to next page?!
Post by: LinuxRules on October 30, 2004, 09:11:11 PM
Thanks Admin

Made the change to the .CONF file, rebooted the Apache and MySQL servers and that solved the problem - Thanks again.