DeveloperSide.NET Forums

DeveloperSide.NET => Building a Web Server, for Linux => Topic started by: slackwbas on October 12, 2005, 12:45:30 PM



Title: apache 2.0.54 compile error (PCRE)
Post by: slackwbas on October 12, 2005, 12:45:30 PM
when i trying compile apache 2.0.54 i got this error
Code:

Making all in pcre
make[2]: Entering directory `/usr/src/source/server/httpd-2.0.54/srclib/pcre'
make[3]: Entering directory `/usr/src/source/server/httpd-2.0.54/srclib/pcre'
/usr/src/source/server/httpd-2.0.54/srclib/apr/libtool --silent --mode=compile gcc  -g -O2 -pthread    -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE -DAP_HAVE_DESIGNATED_INITIALIZER   -I/usr/src/source/server/httpd-2.0.54/srclib/apr/include -I/usr/src/source/server/httpd-2.0.54/srclib/apr-util/include -I. -I/usr/src/source/server/httpd-2.0.54/os/unix -I/usr/src/source/server/httpd-2.0.54/server/mpm/prefork -I/usr/src/source/server/httpd-2.0.54/modules/http -I/usr/src/source/server/httpd-2.0.54/modules/filters -I/usr/src/source/server/httpd-2.0.54/modules/proxy -I/usr/src/source/server/httpd-2.0.54/include -I/usr/src/source/server/httpd-2.0.54/modules/generators -I/usr/src/source/server/httpd-2.0.54/modules/dav/main -prefer-non-pic -static -c pcre.c && touch pcre.lo
pcre.c: In function `pcre_compile':
pcre.c:2534: error: `pcre_default_tables' undeclared (first use in this function)
pcre.c:2534: error: (Each undeclared identifier is reported only once
pcre.c:2534: error: for each function it appears in.)
make[3]: *** [pcre.lo] Error 1
make[3]: Leaving directory `/usr/src/source/server/httpd-2.0.54/srclib/pcre'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/source/server/httpd-2.0.54/srclib/pcre'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/source/server/httpd-2.0.54/srclib'
make: *** [all-recursive] Error 1

i googled many times .i found that bug but didnt find any soultion..
i am on kernel 2.6.13.2 slackware 10.2
and i installed PCRE 6.3 but no use .and i have perl v5.8.7 ,openssl 0.8.9
any one know anything about that bug or if there a patch?


Title: apache 2.0.54 compile error (PCRE)
Post by: admin on October 12, 2005, 01:29:28 PM
Its not a problem with PCRE.

I remember having seeing this too, and figuring out what was wrong...  Just cant remember right now.

Patch your openssl (to be able to build mod_ssl with openssl 0.9.8) and make sure that 'openssl version' displays 0.9.8

http://forums.devside.net/viewtopic.php?t=104


Title: apache 2.0.54 compile error (PCRE)
Post by: slackwbas on October 12, 2005, 01:43:19 PM
#openssl version
OpenSSL 0.9.8 05 Jul 2005

where can i find the patch for the openssl 0.9.8..and how can i patch it

BTW i found that packge in the packge manger (openssl-solibs-0.9.7g-i486-1)
is that package could be the problem cause it 0.9.7 and should be 0.8.9..i mean
am i shoukd update the solibs to 0.9.8?? :?  :?  :?