DeveloperSide.NET Forums
December 10, 2019, 07:42:10 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
  Home Help Search Login Register  
  Show Posts
Pages: [1] 2 3 ... 5
1  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Re: Security
on: February 14, 2008, 06:01:12 AM
Could be. I've had firefox crash on me in yahoo mail before, and they use a lot of flash ads.
2  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Security
on: February 13, 2008, 04:46:20 PM
This is unrelated to the sigterm issue. When I was looking at the error logs, I saw this:
Code:
[Tue Feb 12 20:19:55 2008] [error] [client 127.0.0.1] ModSecurity: Warning. Pattern match "\\\\%(?![0-9a-fA-F]{2}|u[0-9a-fA-F]{4})" at REQUEST_HEADERS:Cookie. [id "950107"] [msg "URL Encoding Abuse Attack Attempt"] [severity "WARNING"] [hostname "ad.yieldmanager.com"] [uri "/st?ad_type=iframe&ad_size=728x90&site=140464&section_code=12054307&cb=1202869194967719&ycg=m&yyob=1956&pub_redirect_unencoded=1&pub_redirect=http://us.ard.yahoo.com/SIG=14tf0448g/M=619213.12054307.12499351.10748017/D=mail/S=150500152:N/Y=YAHOO/EXP=1202876394/L=N2qqpM6.Jpn0kVOvR2bXQwCXnGM3fUeyU8oABhu9/B=HpYhBdj8a5k-/J=1202869194967719/A=4919325/R=0/*"] [unique_id "zyDrncCoAdIAAAH0bj0AAAD1"]
[Tue Feb 12 20:19:55 2008] [error] [client 127.0.0.1] ModSecurity: Warning. Pattern match "(?:\\\\((?:\\\\W*?(?:objectc(?:ategory|lass)|homedirectory|[gu]idnumber|cn)\\\\b\\\\W*?=|[^\\\\w\\\\x80-\\\\xFF]*?[\\\\!\\\\&\\\\|][^\\\\w\\\\x80-\\\\xFF]*?\\\\()|\\\\)[^\\\\w\\\\x80-\\\\xFF]*?\\\\([^\\\\w\\\\x80-\\\\xFF]*?[\\\\!\\\\&\\\\|])" at REQUEST_HEADERS:Cookie. [id "950010"] [msg "LDAP Injection Attack. Matched signature <)(:!>"] [severity "CRITICAL"] [hostname "ad.yieldmanager.com"] [uri "/st?ad_type=iframe&ad_size=728x90&site=140464&section_code=12054307&cb=1202869194967719&ycg=m&yyob=1956&pub_redirect_unencoded=1&pub_redirect=http://us.ard.yahoo.com/SIG=14tf0448g/M=619213.12054307.12499351.10748017/D=mail/S=150500152:N/Y=YAHOO/EXP=1202876394/L=N2qqpM6.Jpn0kVOvR2bXQwCXnGM3fUeyU8oABhu9/B=HpYhBdj8a5k-/J=1202869194967719/A=4919325/R=0/*"] [unique_id "zyDrncCoAdIAAAH0bj0AAAD1"]

Repeated many many times. Can you translate? It looks like someone tried to get into my laptop while I was getting my yahoo mail - but what I don't understand is that I wasn't browsing yahoo with apache. I guess that's just the nature of this attack? Is this something I should worry about? Do something about? Or is this just an attempt to serve an ad that is being interpreted as an attack?

Thx.
3  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Re: sigterm
on: February 13, 2008, 04:36:01 PM
I guess my memory of htaccess is confused because of the way I set up the web server. There doesn't seem to be a relevant htaccess to change here. Here is my conf:
Code:
Alias /SugarCRM "/www/webapps/SugarCRM"

<Directory "/www/webapps/SugarCRM">
Options None
AllowOverride None

order allow,deny
allow from 127.0.0.1
# allow from all

AddType text/html .php
AddHandler application/x-httpd-php .php
</Directory>

allow from 127.0.0.1 should work on localhost, shouldn't it? But this is the error I got:

Code:
[Wed Feb 13 10:04:26 2008] [error] [client 127.0.0.1] Directory index forbidden by Options directive: C:/www/webapps/SugarCRM/install/

But I took the # off 'allow from all' restarted apache (do I need to keep restarting mysql too?) and it is still forbidden. So I'm confused. It must be in the option 'none', but that's the same option I copied over from joomla. What gives?
4  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Re: sigterm
on: February 13, 2008, 04:07:38 PM
Yes, of course, you're right. The reason I didn't have this problem on the web server is that I set up the new program as a subdirectory of an existing, known web app. So I have made the config file and added sugar to compenents.conf, and now it is 'forbidden', not 'not found'. I consider this progress! ;-). I'll keep poking around, starting with htaccess and report back, but if you see this and know the answer right away, feel free to save me the effort.
5  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Re: sigterm
on: February 12, 2008, 11:27:22 PM
I have Apache running, at least for now, and joomla and wordpress come up as they should, but for SugarCRM I get 'not found'. It is on the webapps folder with all the others. I'm sorry to bother you with this again. I'm sure it's something simple like .htaccess or a conf file, but I don't know which. I didn't have this problem when I added a program to the suite on my webserver. Ideas? Thx.
6  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Re: sigterm
on: February 12, 2008, 06:58:14 PM
Thx. Even more reason not to use them.... :-(
7  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ sigterm
on: February 12, 2008, 02:28:41 AM
I wanted to run a web based crm called Sugar on my laptop. I had earlier tried a different crm called vtiger which came with it's own stack because it didn't run with php 5.2. However, after it supposedly installed I got nothing and no help from the website so I uninstalled. I suspect it did something to php.ini even though they were supposedly in separate directories. So tonight I re-installed 1.95 in order to put Sugar on, but the WD controller tells me Apache has an error[1]. The logs look fine until the last line
Code:
[Mon Feb 11 19:43:13 2008] [notice] ModSecurity for Apache 2.1.0 configured
[Mon Feb 11 19:43:28 2008] [notice] Apache/2.2.4 (Win32) mod_ssl/2.2.4 OpenSSL/0.9.8e mod_fastcgi/mod_fastcgi-SNAP-0404142202 PHP/5.2.1 mod_perl/2.0.3 Perl/v5.8.8 configured -- resuming normal operations
[Mon Feb 11 19:43:28 2008] [notice] Server built: Mar 20 2007 13:02:00
[Mon Feb 11 19:43:28 2008] [notice] Parent: Created child process 2080
[Mon Feb 11 19:43:31 2008] [notice] ModSecurity for Apache 2.1.0 configured
[Mon Feb 11 19:43:33 2008] [notice] Child 2080: Child process is running
[Mon Feb 11 19:43:33 2008] [notice] Child 2080: Acquired the start mutex.
[Mon Feb 11 19:43:33 2008] [notice] Child 2080: Starting 250 worker threads.
[Mon Feb 11 19:43:33 2008] [notice] FastCGI: process manager initialized
[Mon Feb 11 19:43:33 2008] [notice] Child 2080: Starting thread to listen on port 443.
[Mon Feb 11 19:43:33 2008] [notice] Child 2080: Starting thread to listen on port 80.
Terminating on signal SIGTERM(15)

Ideas? Thx.
8  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ webserver user
on: February 04, 2008, 08:08:09 PM
What 'user' is my apache webserver operating as? I don't see any user that specifically calls itself apache or webserver. Is it just one of the default users? Thx.
9  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Switch to Drupal
on: January 21, 2008, 02:35:13 AM
Forget it. After I sent this off, I went back to vhosts to put it back to joomla while waiting for your answer, only to see I didn't change the document root. Sheesh. It's ok now.

As I mentioned, I've been playing with Drupal and have decided to switch one of my sites over to it. However, it keeps coming up forbidden, you do not have permission to access / on this server.

When I decided to make the switch, here are the changes I made, trying to follow what I did on the folder Drupal is replacing:

I changed vhosts for this domain from joomla to drupal
I changed drupal htaccess to uncomment allow from all
I commented out rewrite base /drupal in drupal htaccess

But it still comes up forbidden. What did I miss? I tried it with rewrite base / uncommented but that didn't work either.

If it matters, this domain is second on the vhosts list. The other domain still comes up fine. Drupal is uncommented on components.conf and Thx.
10  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Re: Additional Program
on: January 02, 2008, 09:35:12 PM
Thanks. I mentioned before that I don't seem to be able to get into localhost/webdeveloper anymore. I assume I could reconstruct the old vhost setup, get in that way and then put it back the way it is now, but I would think there would be a simpler way. I tried putting c:/www/phpmyadmin/index.php into the url but I got file not found: firefox can't find the file at /C:/www/phpmyadmin/navigation.php<?php echo $url_query; ?>. It suggests I check for capitalization or typing errors, or to see if the file was moved, renamed or deleted. There is a navigation.php in the same folder. Suggestions?
11  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Additional Program
on: December 28, 2007, 04:23:46 PM
Full disclosure: technically, this is not a webdeveloper problem. this has to do with the additional program I mentioned to you a few weeks ago. I got it running on a test server (not my box) set up with php4 and mysql4 so I could at least play with it. Now I am trying to get it working on 1.95, which of course is php5 and mysql5 - and windows too, which the original developers apparently never tested it on. The problem is, you may recall, that the original developers abandoned it. Not only that, they refuse to talk about it, which includes answering questions.
Anyway, there is an _.htaccess file which one is supposed to turn to in case there are installation problems. But my system will not let me rename this file .htaccess. I get the error message "you must type a file name". I went to the apache site, where it talks about AccessFileName, but that seems to relate to what file apache should be looking for. I don't know why I can't rename it, there are plenty of other .htaccess files already in 1.95 as you know. The problem seems to be the 'dot' - windows sees htaccess as the extension, not the file name, so what do I need to do here?

also, can you tell me what a k.o. p parameter is?
12  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Re: Localhost (still/again)
on: December 26, 2007, 05:17:22 PM
Quote
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

>mysqladmin create phpMyTicket -u root -pass
word rootwdp
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: YES)'
>

Here's more. I got this error trying to create a new database from the command line. These are the user and password you gave us. What went wrong?
13  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Re: Localhost (still/again)
on: December 26, 2007, 04:12:51 PM
I'm sorry, I should clarify. I'm not seeing a way into either phpmyadmin or the webdeveloper.php page. The invalid path messages came when trying to use Dreamweaver to at least pull up the phpmyadmin and look at it that way.
14  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Re: Localhost (still/again)
on: December 26, 2007, 04:09:11 PM
Happy New Year
You didn't say, but I infer, that I should add a vh block for localhost and put it first in line.
this comes up now because now I can't seem to get into phpmyadmin. I get messages that it contains an invalid path.
Please advise.
15  DeveloperSide.NET / Web.Developer Server Suite Professional Edition,
Support Forum
/ Re: Localhost (still/again)
on: December 03, 2007, 02:46:00 PM
Both sites come up over the web correctly as they always did. whew!

However, only artsreporter comes up when I type in localhost. I have not figured out how to make tinytickets come up under localhost but since most of what I want to do with dreamweaver involves artsreportere maybe that's not urgent right now.

Any thoughts?
Pages: [1] 2 3 ... 5
Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!