DeveloperSide.NET Forums
February 24, 2020, 11:54:51 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
  Home Help Search Login Register  
  Show Posts
Pages: [1]
1  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: 'Forbidden' message running cgi-bin scripts
on: September 04, 2007, 09:47:53 PM
If I understood correctly I should replace <Directory /> with <Directory /easy/cgi-bin> in the httpd.conf file.
I tried with and without the trailing slash ie <Directory /easy/cgi-bin/> or <Directory /easy/cgi-bin>. Also tried with and without the full path ie:
<Directory D:/www/webroot/easy/cgi-bin/> or <Directory /easy/cgi-bin/> It still doesn't work.
I get the same: \Forbidden message 'You don't have permission to access /easy//cgi-bin/progress.cgi on this server'. It drives me nuts. By the way, is it  normal to have the two forward slashes (easy//cgi.bi...)  in the error message?

Thanks



2  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ 'Forbidden' message running cgi-bin scripts
on: September 03, 2007, 06:58:58 PM
Hi,
I installed two different file tranfer scripts. Both give me the same error when ran:
'Forbidden
you don't have permission to access /'appdir'/cgi-bin/progress.cgi on this server'
I get this message after I followed your instructions and introduced the following lines into the www\Apache22\conf\httpd.conf file:

AddHandler cgi-script .cgi .pl
<Directory />
    Options ExecCGI
    AllowOverride None
    Order allow,deny
    Deny from all
</Directory>

My understanding is that this change allows Apache to run cgi-bin scripts outside the cgi installation folder: www\cgi-bin\
Those two scripts created their own cgi-bin directories in their respective installation folders within the webroot. I changed the first line of all the files in the newly created cgi-bin directories to *!C:/www/perl/bin/perl.exe from the original *!/usr/perl/bin/perl (the initial symbol is not '*' but I couldn't get it here)
Just to mention that, before this change I was getting the text in the /'appdir'/cgi-bin/upload.cgi file dysplayed on the screen.Now I get  the forbidden message.
My system is windows 2000 server. I set the permissions to allow all in the cgi-bin  folders.

Please help.

Thank you

3  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: Problems with PHP SMTP mail
on: September 01, 2007, 04:50:53 PM
Dear Admin,

It's working. I replaced in php.ini localhost with 127.0.0.1 and I changed the line mail@localhost to 'postmaster'@'mylocalhost'

Thank you very much for your constructive and prompt advice.

4  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: Problems with PHP SMTP mail
on: August 30, 2007, 10:41:27 PM
I reinstalled the web-developer package and the hmail server. I also changed some settings in the router. The hmail server is working ok now via roundcubemail both for sending and receiving e-mails (with a dynamic IP address updated via the router). The problem is that php still does not send e-mails - ie from within an address book script for instance. I tried in php.ini both the original option 'localhost' and the one with smtp passwords - the email server running in the background. It does not seem to be working.
Please help.

Thank you
5  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: Problems with PHP SMTP mail
on: August 23, 2007, 08:43:01 PM
The more I test as you suggest, the more I think there is a local configuration problem.
I followed step by step the suggestions on the http://support.microsoft.com/kb/153119. I can send e-mails via telnet to an outside e-mail address. I double checked the port 25 - it is OK, not blocked by the ISP (outgoing). I was suspecting that from the beginning because I have a second linux based server (a NAS with web and phpmyadmin) which sends mails OK to the outside world (from the same IP address).
I also created a real registered domain via dyndns and entered that in the hmaiserver. The A records and the MX records are set correctly. Unfortunately I still can't send any e-mails to the outside world.
I am getting very frustrated with all this.

Of note, when trying to send e-mails from squirrel mail I get an almost instantaneous message saying: 'Message not sent.Server replied: Unable to find the socket transport "http" -did you forget to enable it when you configured PHP? 0 Can't open SMTP stream'
From the roundcubemail, trying to send an e-mail out I just get the message 'Failed to send the message'

I really need your help step by step eliminating the possible culprits. I mentioned before my machine is a windows server2000.
- Could it be any other service running the same time and creating problems? (I disabled all the services in the IIS window - ie the Default SMTP Virtual Server and the Default NNTP Virtual Server - with these enabled I wasn't able to acccess the hmail server from the mail client)
- Could it be the PHP itself given the error message in squirrel mail?

Please help in a user friendly (idiot proof!), constructive manner.

Thank you
6  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: Problems with PHP SMTP mail
on: August 21, 2007, 11:32:14 PM
The reason I have the problem with the hMailServer is likely due to the fact that I do not have a registered DNS domain. The ad-hoc locally created domain does not seem to work.

All I really want is to be able to send the mail out using my ISP with their server  smtp autentification.

I did enter the details in the smtp details in hMailServer but it does not work.

Coming bach to php, can we somehow set up the php.ini properly (with autentification) in order for the outgoing mail to work?

Thanks
7  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: Problems with PHP SMTP mail
on: August 17, 2007, 04:12:30 PM
Yes, I get the message '220 ESMTP server ready' when entering  > open smtp.aol.com 25. The next line I don't have the prompter like '>', I just have ablinking '_' where you cannot see what you write. In any case, typing in the message 'helo me'  I get: 250 aamtaout01-winn.ispmail.aol.com'. I have no idea how to send you an e-mail via telnet.
The local mailserver you are talking about and I have installed is hMailServer which is already configured to the AOL smtp details. I thought you need the php configured  to connect to smtp to get the damn thing working. Do you mean you can by-pass php?. what about all the scripts (like file uploading/ downloading etc) you need a working mail? They all ask you about either phpmail, or sendmail or pear. Can you use the microsoft oulook - connected somehow to php? (silly question)
What I can't understand is why in MS outlook the smtp details work fine while in hMailServer the same details don't seem to be working.

Are we completely giving up the idea of configuring the php.ini?

Lawrence
8  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: Problems with PHP SMTP mail
on: August 16, 2007, 07:00:13 PM
To be more exact, when I enter (in the cmd window) telnet.smtp.aol.com 25 I get the message: '220 ESMTP server ready'. I assume this is OK.
9  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: Problems with PHP SMTP mail
on: August 16, 2007, 06:40:50 PM
Thank you for the prompt reply. I changed as you suggested but unfortunately still doesn't work (tested via telnet as you suggested to another user). Port 25 is available - I checked this, again  as you suggested.

Regards
10  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Problems with PHP SMTP mail
on: August 15, 2007, 11:17:15 PM
I need your help in configuring php.ini with my provider's smtp details (including username and password). My machine is a windows2000 server.
I installed the web-developer server, the hMailServer and  Squirrel mail OK. They all seem to be integrated; I could  log in the hMailServer, configure the settings in the hMailServer (including smtp), and could access the folders in squirrel e-mail.
The problem is that the e-mail does not go out (or come in). I read the information already on the forum and followed the instructions on how to change php.ini as shown below.  Unfortunately I am a beginner in php and most of the stuff discusssed sounds pretty cryptic to me.
I struggled to understand the username and password should be like this: 'user:password@smtp.aol.com', and I hope it is  correct. Should that however be entered before or after the smtp_port line?:

[mail function]
; For Win32 only.
SMTP = smtp.aol.com
smtp_port = 25
user:password@smtp.aol.com

; For Win32 only.
sendmail_from = john@aol.com

In the above I just replaced user and password with my user and my password. This does not seem to work unfortunately. On other discussion forums there seems to be a belief that if you need smtp autentification you are stuck - and can not do it as easily as above. Others suggest somee kind of add-on script to some other script (I don't think it was php.ini). PLEASE HELP!!

Sendmail line above - without the user name and password it surely is useless??

Of note, on the same computer (windows2000 server), the smtp account details work fine in microsoft outlook.

Regards
11  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: Problem with Apache 2.2.4 under Windows 2000 [permissions denied]... IP 0.0.0.0
on: August 12, 2007, 02:21:42 PM
Before I got your message, I changed the file phpmyadmin.conf to 'allow from all' from 'allow from 127.0.0.1". I did the same with the file mod_perl.conf. It seems to have worked.
Is this OK or I still need to do what you mentioned in your reply?

If I still need to follow your advice and change the file www/Apache22/conf/httpd.conf  do I add the line 'Win32DisableAcceptEx' without any commas, ", <,  > or ', right at the end after the last line in the file with or without a paragraph?

I'm sorry for the basic question!

Thank you
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!