DeveloperSide.NET Forums
January 28, 2020, 03:49:32 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
  Home Help Search Login Register  
  Show Posts
Pages: [1]
1  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: Strange errors in access.log
on: February 22, 2010, 02:44:29 PM
I'm not sure what would happen with 0.0.0.0. That usually specifies "all interfaces"/IPs.

Blocking them as 0 seemed to do the trick.
2  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: Strange errors in access.log
on: February 21, 2010, 04:23:46 PM
Example: edit the Windows hosts file, add...
127.0.0.1 www.google.com

Save file. Go to the above URL. You should see it in your logs.

I see. So if they're blocked as 0.0.0.0 they don't appear in access.log ?
3  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Re: Strange errors in access.log
on: February 20, 2010, 10:43:58 PM
ga.js is the Google Analytics tracking script.

Quote
I wonder if it's because I blocked a load of adware via the HOSTS file as:

Could be... Anything of the form blocked-domain.tld\... in any webpage or ad display would go to 127.0.0.1

Why does access.log show external sites I visited via my browser, and not just the localhost ones I set up with virtualhosts?
I'm confused...
4  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Strange errors in access.log
on: February 20, 2010, 09:50:15 PM
I checked my access.log the other day and this is what I got (these are just snippets of a lengthy log)...
Quote

[Sat Feb 20 21:38:33 2010] [notice] ModSecurity for Apache 2.1.3 configured
[Sat Feb 20 21:38:34 2010] [notice] Apache/2.2.6 (Win32) mod_ssl/2.2.6 OpenSSL/0.9.8g PHP/5.2.5 configured -- resuming normal operations
[Sat Feb 20 21:38:34 2010] [notice] Server built: Sep 20 2007 14:13:35
[Sat Feb 20 21:38:34 2010] [notice] Parent: Created child process 5160
[Sat Feb 20 21:38:36 2010] [notice] ModSecurity for Apache 2.1.3 configured
[Sat Feb 20 21:38:37 2010] [notice] Child 5160: Child process is running
[Sat Feb 20 21:38:37 2010] [notice] Child 5160: Acquired the start mutex.
[Sat Feb 20 21:38:37 2010] [notice] Child 5160: Starting 250 worker threads.
[Sat Feb 20 21:38:37 2010] [notice] Child 5160: Starting thread to listen on port 443.
[Sat Feb 20 21:38:37 2010] [notice] Child 5160: Starting thread to listen on port 80.
[Sat Feb 20 21:38:47 2010] [error] [client 127.0.0.1] (20024)The given path misformatted or contained invalid characters: Cannot map GET
[Sat Feb 20 21:29:40 2010] [error] [client 127.0.0.1] File does not exist: C:/www/vhosts/localhost/ga.js, referer: http://www.brmb.co.uk
[Sat Feb 20 21:36:40 2010] [error] [client 127.0.0.1] File does not exist: C:/www/vhosts/localhost/ga.js, referer: http://www.devside.net/

I've got Malwarebytes and antivirus software, so I'm wondering how this could have happened.

The access.log is pretty much the same:
Quote
127.0.0.1 - - [20/Feb/2010:21:48:32 +0000] "GET /ga.js HTTP/1.1" 404 571 "http://www.malwarebytes.org/" "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8 (.NET CLR 3.5.30729)"

Surely an external site shouldn't be trying to access my install of Webdeveloper, especially considering it isn't accessible from outside my own PC.

I wonder if it's because I blocked a load of adware via the HOSTS file as:
127.0.0.1   your-adware-here.com

Please can someone help?
5  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Running Web-Developer and IIS at once
on: September 21, 2009, 10:02:34 PM
I'm trying to run Web-Developer and IIS at once; I changed ports for the IIS, then re-ran Web-Developer and got Error[1] in the Controller.
This is my log:
Quote
[Mon Sep 21 22:17:49 2009] [notice] ModSecurity for Apache 2.1.3 configured
[Mon Sep 21 22:17:53 2009] [notice] Apache/2.2.6 (Win32) mod_ssl/2.2.6 OpenSSL/0.9.8g PHP/5.2.5 configured -- resuming normal operations
[Mon Sep 21 22:17:53 2009] [notice] Server built: Sep 20 2007 14:13:35
[Mon Sep 21 22:17:53 2009] [notice] Parent: Created child process 3868
[Mon Sep 21 22:17:54 2009] [notice] ModSecurity for Apache 2.1.3 configured
[Mon Sep 21 22:17:55 2009] [notice] Child 3868: Child process is running
[Mon Sep 21 22:17:55 2009] [notice] Child 3868: Acquired the start mutex.
[Mon Sep 21 22:17:55 2009] [notice] Child 3868: Starting 250 worker threads.
[Mon Sep 21 22:17:56 2009] [notice] Child 3868: Starting thread to listen on port 443.
[Mon Sep 21 22:17:56 2009] [notice] Child 3868: Starting thread to listen on port 80.
[Mon Sep 21 22:18:27 2009] [error] [client 127.0.0.1] ModSecurity: Warning. Pattern match "(?:>\\\\[To Parent Directory\\\\]<\\\\/[Aa]><br>|<title>Index of.*?<h1>Index of)" at RESPONSE_BODY. [id "970013"] [msg "Directory Listing"] [severity "WARNING"] [hostname "localhost"] [uri "/"] [unique_id "BdHxgcCoAWcAAA8chpMAAAD5"]
[Mon Sep 21 22:18:28 2009] [error] [client 127.0.0.1] File does not exist: C:/www/vhosts/localhost/favicon.ico
[Mon Sep 21 22:18:31 2009] [error] [client 127.0.0.1] File does not exist: C:/www/vhosts/localhost/favicon.ico
[Mon Sep 21 22:33:03 2009] [error] [client 127.0.0.1] ModSecurity: Warning. Pattern match "(?:>\\\\[To Parent Directory\\\\]<\\\\/[Aa]><br>|<title>Index of.*?<h1>Index of)" at RESPONSE_BODY. [id "970013"] [msg "Directory Listing"] [severity "WARNING"] [hostname "www.mysite1.co.uk"] [uri "/"] [unique_id "OgTG-MCoAWcAAA8chpoAAAD4"]
[Mon Sep 21 22:33:03 2009] [error] [client 127.0.0.1] File does not exist: C:/www/vhosts/localhost/favicon.ico, referer: http://www.mysite1.co.uk/
[Mon Sep 21 22:46:05 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Sep 21 22:46:05 2009] [notice] Child 3868: Exit event signaled. Child process is ending.
[Mon Sep 21 22:46:06 2009] [notice] Child 3868: Released the start mutex
[Mon Sep 21 22:46:07 2009] [notice] Child 3868: Waiting for 250 worker threads to exit.
[Mon Sep 21 22:46:07 2009] [notice] Child 3868: All worker threads have exited.
[Mon Sep 21 22:46:07 2009] [notice] Child 3868: Child process is exiting
[Mon Sep 21 22:46:07 2009] [notice] Parent: Child process exited successfully.

Note the mysite1.co.uk is a virtual host mapped using the HOSTS file.

Any idea how to fix this?
6  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Questions on using Web.Developer Server Suite 2.0 from Sourceforge
on: August 28, 2009, 06:42:07 PM
I recently re-installed this, and am fairly new to this, so any advice is appreciated!
If a folder with files is put in the localhost folder of vhosts, that means it can be accessed at http://localhost/myfolder/filename.html or whatever extension ?

Also, vhosts is for httpd.conf?

Sorry if I'm asking too many questions... I'm trying to refresh my knowledge of this!
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!