DeveloperSide.NET Forums
October 20, 2019, 06:48:00 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
  Home Help Search Login Register  
  Show Posts
Pages: [1]
1  DeveloperSide.NET / Building a Web Server, for Linux / php4.4.2 and apache2.2? on: May 17, 2006, 11:13:12 AM
Hi
Ok, thanks, that worked out expected
Now how do I get apache2 to start up as a service upon boot?
Thanks
Jason
2  DeveloperSide.NET / Building a Web Server, for Linux / php4.4.2 and apache2.2? on: May 16, 2006, 08:04:02 AM
Hi
Thanks I will do that,
Also, how do I get apache2.2 to start on boot (as in a service/daemon)?
Thank would be nice too
Your support has been much appreciated
Once again, Thanks

Edit::
Im probably the biggest noob alive here, I was installing some PEAR modules for PHP and got the following:
Quote

Warning: main(Console/Getopt.php): failed to open stream: No such file or directory in System.php on line 27

Fatal error: main(): Failed opening required 'Console/Getopt.php' (include_path='/usr/local/lib/php') in /usr/local/lib/php/System.php on line 27


The file listed obviously does not exist and I found during make that it came up with this:
Quote
[PEAR] Archive_Tar: bad md5sum for file tar.php

or something along those lines
This error repeats itself for the tar module, console:getopt module and the HTMLTemplateIT module.

Is there anyway of fixing it? Thanks
3  DeveloperSide.NET / Building a Web Server, for Linux / php4.4.2 and apache2.2? on: May 15, 2006, 04:32:53 AM
Hi
I actually went playing with the chmod and changed file to 777(havent tried other settings yet) and it works if it is only on THE file (im used to windows where changing a folder, you can change its subdirs as well) so Im thinking, is there someway of granting php/apache whichever is appropriate access to the files by assigning it to a user? Thanks
4  DeveloperSide.NET / Building a Web Server, for Linux / php4.4.2 and apache2.2? on: May 13, 2006, 11:39:46 PM
Changing to 777 the /usr/local/apache2, /usr/local/lib/php, /usr/local/include/php still has the problem. Also, I changed ti 32bit so I think this problem is realted to misconfiguration.

It also gives the same error on Apache 2.0.58 as well as Apache 2.2
The php works perfectly from the command line though, just not from Apache


So I am still lost here
5  DeveloperSide.NET / Building a Web Server, for Linux / php4.4.2 and apache2.2? on: May 12, 2006, 11:10:37 AM
Hi
Thanks for the help but it doesnt seem to work for me.
changing to 777 and chown to root, well its already under root ownership.
It does not work.
It still gives the same error
any more suggestions?
thanks
Jason
6  DeveloperSide.NET / Building a Web Server, for Linux / php4.4.2 and apache2.2? on: May 11, 2006, 03:00:22 AM
oh, yes.
I forgot to mention, Fedora Core 5, x86-64

edit: I should also mention, it does it on Apache 2.0.54 as well

Thanks
Jason
7  DeveloperSide.NET / Building a Web Server, for Linux / php4.4.2 and apache2.2? on: May 10, 2006, 10:50:59 AM
Hi
Im having problems with the two parts.
The Apache2.2, does it have compatibility support for PHP4.4.2? or vice versa?

I get a horrendeus error when running phpinfo() being

    PHP Warning:  Unknown(/usr/local/apache2/htdocs/php/phpinfo.php): failed to open stream: Permission denied in Unknown on line 0, referer:
http://localhost/php/
[/list]
    PHP Warning:  (null)(): Failed opening '/usr/local/apache2/htdocs/php/phpinfo.php' for inclusion (include_path='.:/usr/local/php/lib/php') in Unknown on line 0, referer:
http://localhost/php/[/list]

Is there anyway to overcome this? Thanks in advance, Jason
8  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Apache 2.2 and mod_perl compile
on: January 06, 2006, 08:17:07 PM
Ok, thanks
Ill head over there and take a look.
9  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Apache 2.2 and mod_perl compile
on: January 05, 2006, 10:25:10 PM
Hi
I have set the php dir in path and both files are in the same php root directory.
10  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Apache 2.2 and mod_perl compile
on: January 05, 2006, 06:21:06 AM
OK, I have got it fixed, it was my fault, I forgot to compile the libwin
but now i have another problem which is related to php 5.1.1

With LoadModule php5_module C:/inetpub/server/php/php5apache2.dll
PHPIniDir C:/inetpub/server/php
and the AddTypes

Now Apache2.2 cant start up when doing httpd.exe -k start it shows the following

httpd: Syntax error on line 117 of C:/Inetpub/server/Apache2/conf/httpd.conf: Cannot load C:/Inetpub
/server/php/php5apache2.dll into server: The specified module could not be found.

I manually checked the files existed can I ask what the problem may be?
11  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Apache 2.2 and mod_perl compile
on: January 04, 2006, 10:35:24 AM
Quote from: "Jorge"
Ah finaly something i can anwser :)

Look under the httpd 2.2.0 dir (i think in slash include, sub dir might varie... can't check atm... pasting form PDA).

And copy libapr-1.lib (and its friends) and rename the copy to libapr.lib...

Works fine


Hi
I did that(last time, I forgot the other files) and I still get the same error as above during the test however

Anyways, if I try to ignore that, I cant as after running nmake, I cannot get mod_perl.so compiled

Thanks
Jason
12  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Apache 2.2 and mod_perl compile
on: January 04, 2006, 07:31:33 AM
Hi
Thanks for the reply
After download apr and compiling the only *.lib file I get is libapr-1.lib
That is not the file required but would copying and renaming it to libapr.lib be safe if it works?

Thanks
Jason

--EDIT---------------------------------------

I have just tried the above and it does not work
with

Can't locate Win32/Process.pm in @INC (@INC contains: F:\mod_perl-2.0.2\Apache-Test F:\mod_perl-2.0.
2\blib\lib F:\mod_perl-2.0.2\blib\arch F:\mod_perl-2.0.2 F:\mod_perl-2.0.2\lib F:\mod_perl-2.0.2\Apa
che-Test\lib F:\mod_perl-2.0.2\t\lib blib\arch blib\lib C:/Inetpub/server/perl/lib C:/Inetpub/server
/perl/site/lib .) at F:\mod_perl-2.0.2\Apache-Test\lib/Apache/TestServer.pm line 380.
NMAKE : fatal error U1077: 'C:\Inetpub\server\perl\bin\perl.exe' : return code '0x2'
Stop.
13  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Apache 2.2 and mod_perl compile
on: January 04, 2006, 04:50:42 AM
Hi
I am having problems trying to compile mod_perl 2.0.2 for apache2.2, the problem i get is when i use nmake for mod_perl 2.0.2

I have apache 2.2.0
perl 5.8.7
mod_perl 2.0.2

It states it cannot read input file C:\inetpub\server\apache2/lib/libapr.lib
I have manually checked and confirmed that this file does not exist

I would like to ask if anyone can help with me to compile mod_perl 2.0.2

Thanks
Jason
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!