DeveloperSide.NET Forums
December 11, 2019, 01:44:06 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
  Home Help Search Login Register  
  Show Posts
Pages: [1]
1  DeveloperSide.NET / Anything else goes here / Re: Mysql query question on: May 29, 2007, 07:31:09 AM
Answered my own question:

Use a FULLTEXT search (Match ... Against)
2  DeveloperSide.NET / Anything else goes here / Mysql query question on: May 24, 2007, 10:44:23 AM
I'm querying a table that includes a field for Authors (strArtist) in which the data is stored as "Surname, FirstName" eg: "Bloggs, Joe". So if someone searches for "Joe Bloggs", they won't find anything.

My query criteria is built by
Code:
$criteria="WHERE (strDesc LIKE '%".$_POST['qSearchText']."%') OR (strArtist LIKE '%".$_POST['qSearchText']."%') OR (strItem = '".$_POST['qSearchText']."')";

What would I have to do to make "Joe Bloggs" find a match against "Bloggs, Joe"?
3  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ MySQL won't start
on: June 27, 2006, 02:11:03 AM
Quote from: "admin"
Make sure you do not have any C:\my, my.ini, my.cnf files and try commenting out line...
set_variable = old_passwords = 1


old_passwords did the trick.

Thanks very much!

Does that mean I did something wrong in that part of the downgrade?
4  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ MySQL won't start
on: June 27, 2006, 01:38:07 AM
Quote from: "admin"
Also run 'services.msc' and double click on the mysql service, make sure its comming from \www\mysql\bin

Path to executable - C:\www\mysql\bin\mysqld-nt MySQL
5  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ MySQL won't start
on: June 27, 2006, 01:35:20 AM
Hmmm

The MySQL service could not be started
A system error has occurred
System error 1067 has occured
The process terminated unexpectedly


Here's my c:\windows\my.ini (minus some comments) if it helps:
Quote from: "my.ini"
# Example MySQL config file for medium systems.
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /usr/local/var) or
# ~/.my.cnf to set user-specific options.
#
# The following options will be passed to all MySQL clients
[client]
#password   = your_password
port      = 3306
socket      = C:/www/tmp/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
set_variable = old_passwords = 1
#bind-address   = 127.0.0.1
port      = 3306
socket      = C:/www/tmp/mysql.sock
basedir      = C:/www/mysql/
datadir      = C:/www/mysql/data/
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M

log-bin=mysql-bin

server-id   = 1

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

I'm not that familiar with MySQL. Should I uncomment 'safe-updates'?
6  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ MySQL won't start
on: June 26, 2006, 04:56:56 PM
ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)

I think it was after 11:53 that I did the downgrade.

*
The pages I was testing have some includes which weren't getting parsed by php. I'm using Opera and didn't get an error message, only the static page text.
After downgrading (and the same response from Opera), I tried IE and got 'Unable to connect to SQL server'.
After pondering the mysql_pconnect string I realised that MySQL wasn't running.

*
Though now Opera is giving me the same error. I'm sure it wasn't before.
7  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ MySQL won't start
on: June 26, 2006, 04:16:19 PM
Quote from: "AJM.err"
InnoDB: The first specified data file .\ibdata1 did not exist:
InnoDB: a new database to be created!
060625 22:52:55  InnoDB: Setting file .\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
060625 22:52:55  InnoDB: Log file .\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
060625 22:52:55  InnoDB: Log file .\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
060625 22:52:58  InnoDB: Started; log sequence number 0 0
060625 22:52:59 [Note] MySQL: ready for connections.
Version: '5.0.18-nt-log'  socket: ''  port: 3306  MySQL Community Edition (GPL)
060625 22:53:26 [Note] MySQL: Normal shutdown

060625 22:53:26  InnoDB: Starting shutdown...
060625 22:53:29  InnoDB: Shutdown completed; log sequence number 0 43655
060625 22:53:29 [Note] MySQL: Shutdown complete

060625 22:54:47  InnoDB: Started; log sequence number 0 43655
060625 22:54:51 [Note] MySQL: ready for connections.
Version: '5.0.18-nt-log'  socket: ''  port: 3306  MySQL Community Edition (GPL)
060626  0:01:10 [Note] MySQL: Normal shutdown

060626  0:01:10  InnoDB: Starting shutdown...
060626  0:01:11  InnoDB: Shutdown completed; log sequence number 0 43655
060626  0:01:11 [Note] MySQL: Shutdown complete

060626 11:53:38  InnoDB: Started; log sequence number 0 43655
060626 11:53:44 [Note] MySQL: ready for connections.
Version: '5.0.18-nt-log'  socket: ''  port: 3306  MySQL Community Edition (GPL)
060626 14:15:23 [Note] MySQL: Normal shutdown

060626 14:15:23  InnoDB: Starting shutdown...
060626 14:15:24  InnoDB: Shutdown completed; log sequence number 0 43655
060626 14:15:24 [Note] MySQL: Shutdown complete
8  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ MySQL won't start
on: June 26, 2006, 09:07:50 AM
I got a new laptop and downloaded the latest suite yesterday (June 25th) then I followed the instructions to downgrad PHP5 to PHP4.

Now MySQL won't start. If I try to start it manually I get:
'Could not start the MySQL service on Local Computer.
Error 1067: The process terminated unexpectedly.'

I may have made a cockup of this part:
Quote from: "admin"
Login to the MySQL shell with user 'root'
mysql -u root -p
(if asked, enter password for root -- by default it is not set)

Code:

mysql> SET PASSWORD FOR 'root'@'localhost' = OLD_PASSWORD('your-current-passowrd-for-root');

mysql> SET PASSWORD FOR 'pma'@'localhost' = OLD_PASSWORD('your-current-password-for-pma');

(the default password for user 'pma' is 'pmapass' -- unless you have changed it)

when I first typed that in, I wasn't using semicolon at the end (I am a n00b in many senses of the word).

Apologies if this has been answered before. I searched but couldn't find anything.
9  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ No images display on localhost
on: January 09, 2006, 08:24:31 AM
Thanks
10  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ No images display on localhost
on: January 09, 2006, 04:27:20 AM
Quote from: "admin"
as for the extra directive, check the thread at the top (about problems) which also covers this in some more detail.


Which thread?
11  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ No images display on localhost
on: January 08, 2006, 06:47:49 AM
BigRat from experts exchange solved it for me:

Quote from: "BigRat"
It looks like you've got a broken WinSock dll on the machine. You'll need to put the directive "EnableSendfile Off" for the directory where the images come from in the Apache httpd.conf file. This happens often when something else gets installed and overwrites winsock2.dll


For the record:

http://127.0.0.1/IFC/images/NoImage.jpg  didn't work

No images of localhost would work regardless of their hierarchy.

Anyway, thanks for the help and here are those videos I promised :)
http://www.dailyhaha.com/_vids/pamela_Anderson.htm
http://www.dailyhaha.com/_vids/weirddogsounds.htm
http://www.dailyhaha.com/_vids/crazydog.htm
http://www.dailyhaha.com/_vids/Creative_Drummer.htm
12  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ No images display on localhost
on: January 06, 2006, 06:05:08 AM
Hi all, first time poster here...

I can't get images to display on localhost pages.

If I provide an absolute path (G:/www/webroot/ifc/images/NoImage.jpg) everything's fine, but when I provide path relative to the document I get no love (ie ).

I gave a copy of the folders to a friend who installed an EasyPHP implementation (also using Apache but don't know which version) and the images work fine on his computer.

If I look at the broken image properties, the path is right (http://localhost/IFC/images/NoImage.jpg) but if I enter this url in the address bar, I get a 'page cannot be displayed' error.
I've tried jpg, gif and bmp with the same result. The capitalisation was correct.

If I link to the image and try to Save As, I get 'IE cannot download NoImage.jpg from localhost. The connection to the server was reset'.

I linked to other file types (doc, xls, pdf, zip). When I Save As, I get either 'connection to the server was reset' or 'server returned an invalid or unrecognized response' or 'requested site is either unavailable or cannot be found'. Which message I get seems to be random.

I'm using IE6 running on W2K Pro and Apache 2.0.50

I've tried it with Opera. The images don't display but I don't get an error message when saving a file (but the save doesn't work anyway).

I've looked long and hard but can't find any answers.
If any of you can help me, I'd be very grateful and I'll send you some funny videos.

This is my httpd.conf:
Code:
###*********************************************************
###*  DeveloperSide.NET                                    *
###*  http://www.devside.net                               *
###*  admin@devside.net                                    *
###*  v1.12                                                *
###*********************************************************


Listen 80
ServerRoot "/www/Apache2"
DocumentRoot "/www/webroot"

ServerName localhost:80
ServerAdmin admin@localhost

ServerSignature On
ServerTokens Full

DefaultType text/plain
AddDefaultCharset ISO-8859-1

UseCanonicalName Off

HostnameLookups Off

ErrorLog logs/error.log
LogLevel error

PidFile logs/httpd.pid

Timeout 300

KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15


<IfModule mpm_winnt.c>
ThreadsPerChild 250
MaxRequestsPerChild 0
</IfModule>


LoadModule access_module modules/mod_access.so
#LoadModule actions_module modules/mod_actions.so
LoadModule alias_module modules/mod_alias.so
#LoadModule asis_module modules/mod_asis.so
LoadModule auth_module modules/mod_auth.so
#LoadModule auth_anon_module modules/mod_auth_anon.so
#LoadModule auth_dbm_module modules/mod_auth_dbm.so
#LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule autoindex_module modules/mod_autoindex.so
#LoadModule cern_meta_module modules/mod_cern_meta.so
LoadModule cgi_module modules/mod_cgi.so
#LoadModule dav_module modules/mod_dav.so
#LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule dir_module modules/mod_dir.so
#LoadModule env_module modules/mod_env.so
#LoadModule expires_module modules/mod_expires.so
#LoadModule file_cache_module modules/mod_file_cache.so
LoadModule headers_module modules/mod_headers.so
#LoadModule imap_module modules/mod_imap.so
#LoadModule include_module modules/mod_include.so
LoadModule info_module modules/mod_info.so
#LoadModule isapi_module modules/mod_isapi.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule mime_module modules/mod_mime.so
#LoadModule mime_magic_module modules/mod_mime_magic.so
#LoadModule proxy_module modules/mod_proxy.so
#LoadModule proxy_connect_module modules/mod_proxy_connect.so
#LoadModule proxy_http_module modules/mod_proxy_http.so
#LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
#LoadModule negotiation_module modules/mod_negotiation.so
#LoadModule rewrite_module modules/mod_rewrite.so
LoadModule setenvif_module modules/mod_setenvif.so
#LoadModule speling_module modules/mod_speling.so
LoadModule status_module modules/mod_status.so
#LoadModule unique_id_module modules/mod_unique_id.so
#LoadModule userdir_module modules/mod_userdir.so
#LoadModule usertrack_module modules/mod_usertrack.so
#LoadModule vhost_alias_module modules/mod_vhost_alias.so
<IfDefine SSL>
LoadModule ssl_module modules/mod_ssl.so
</IfDefine>
LoadModule logio_module modules/mod_logio.so
LoadModule deflate_module modules/mod_deflate.so

LoadFile "/www/perl/bin/perl58.dll"
LoadModule perl_module modules/mod_perl.so
PerlRequire "/www/Apache2/conf/extra.pl"

LoadFile "/www/php/php4ts.dll"
LoadModule php4_module /www/php/php4apache2.dll


<Location />
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE text/html text/plain text/css
<IfModule mod_headers.c>
Header append Vary User-Agent
</IfModule>
</IfModule>
</Location>


<Directory />
Options None
AllowOverride None
Order allow,deny
Deny from all
</Directory>


<Directory "/www/webroot">
Order allow,deny
Allow from all
</Directory>


<IfModule mod_auth.c>
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>

Alias /private "/www/private"

<Directory "/www/private">
<IfModule mod_autoindex.c>
Options Indexes
</IfModule>

Order allow,deny
Allow from all

AuthType Basic
AuthName "Private Access"
AuthUserFile "/www/private/.htpasswd"
require valid-user
</Directory>
</IfModule>


<IfModule mod_cgi.c>
ScriptAlias /cgi-bin/ "/www/cgi-bin/"

<Directory "/www/cgi-bin">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>
</IfModule>


Alias /phpMyAdmin "/www/phpMyAdmin"

<Directory "/www/phpMyAdmin">
Options None
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Directory>


<Directory "/www/webroot/stats">
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Directory>


<IfModule mod_log_config.c>
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-agent}i\"" combined
CustomLog logs/access.log combined
<IfModule mod_deflate.c>
DeflateFilterNote Input instream
DeflateFilterNote Output outstream
DeflateFilterNote Ratio ratio
LogFormat '"%r" %{outstream}n/%{instream}n (%{ratio}n%%)' deflate
CustomLog logs/deflate.log deflate
</IfModule>
</IfModule>


<IfModule mod_dir.c>
DirectoryIndex index.html index.php
</IfModule>


<IfModule mod_mime.c>
TypesConfig conf/mime.types
AddType application/x-compress .Z
AddType application/x-gzip .gz .tgz
AddType application/x-rar-compressed .rar
<IfModule sapi_apache2.c>
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
</IfModule>
</IfModule>


<IfModule mod_setenvif.c>
BrowserMatch "Mozilla/2" nokeepalive
BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
BrowserMatch "RealPlayer 4\.0" force-response-1.0
BrowserMatch "Java/1\.0" force-response-1.0
BrowserMatch "JDK/1\.0" force-response-1.0
BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
BrowserMatch "^WebDrive" redirect-carefully
BrowserMatch "^WebDAVFS/1.[012]" redirect-carefully
BrowserMatch "^gnome-vfs" redirect-carefully
<IfModule mod_deflate.c>
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
</IfModule>
</IfModule>


<IfModule mod_status.c>
ExtendedStatus On
<Location /server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Location>
</IfModule>


<IfModule mod_info.c>
<Location /server-info>
SetHandler server-info
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Location>
</IfModule>


<IfModule mod_perl.c>
PerlModule Apache::Status
<Location /perl-status>
SetHandler perl-script
PerlResponseHandler Apache::Status
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Location>
</IfModule>


<IfModule mod_ssl.c>
Include conf/ssl.conf
</IfModule>


##### Start -- mod_perl Hello example, \www\perl\site\lib\Apache\Hello.pm
#
<IfModule mod_perl.c>
PerlModule Apache::Hello
<Location /hello>
SetHandler modperl
PerlResponseHandler Apache::Hello
</Location>
</IfModule>
#
##### End -- mod_perl Hello example


and my mime.types includes:
Code:
# MIME type Extensions
application/msword doc
application/pdf pdf
application/vnd.ms-excel xls
application/zip zip
image/bmp bmp
image/cgm cgm
image/g3fax
image/gif gif
image/ief ief
image/jpeg jpeg jpg jpe
image/naplps
image/png png
image/prs.btif
image/prs.pti
image/svg+xml svg
image/t38
image/tiff tiff tif
image/tiff-fx
text/calendar ics ifb
text/css css
text/directory
text/enriched
text/html html htm
text/parityfec
text/plain asc txt
text/prs.lines.tag
text/rfc822-headers
text/richtext rtx
text/rtf rtf
text/sgml sgml sgm
text/t140
video/jpeg
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!