DeveloperSide.NET Forums
July 13, 2020, 10:24:07 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
  Home Help Search Login Register  
  Show Posts
Pages: [1] 2
1  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Proxy HTTPS and HTTP
on: March 26, 2006, 04:47:19 AM
With Apache running as a forward proxy server whenever I go to an HTTPS webpage I get a denied acess page, how can I enable the proxy to work with HTTPS along with HTTP.
2  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Apache Filter Request Config
on: March 25, 2006, 09:36:11 PM
How would I set my configuration file settings to filter request comming from the client going to the server. With Apache set as a forward proxy sever. I want to filter the client context before it is posted to the targeted server.
3  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Reverse Proxy
on: March 22, 2006, 03:28:38 PM
Hi

   How do I configure Apache to use a filter module for reverse proxy and are there any examples of a reverse proxy filter module
4  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Using OutPut Filter
on: March 22, 2006, 06:07:59 AM
Hi

 I have Apache running on my computer as a Proxy server using the directive ProxyRequest On. I created a module as an Output filter for .html, .txt, .css and .js files. I have configured my browser to use the Apache Proxy server running on my computer. When I surf the internet the Apche HTTP proxy module is getting triggered so, I know that the request are going through Apache. I have added the AddOutputFilter directive so that I can use my Output filter module. The problem is when I open a web page typing in an url (i.e. ww.msn.com) in my browser. my output filter module is not being triggered, I cannot filter the response from the orgin server. If I type http://localhost I get a blank page which I should but, my output filter module gets triggered. How should I be setup so that I can filter the http response context before it is displayed in my web browser.
5  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Looking For a Smart Filter Module
on: March 17, 2006, 04:03:07 PM
HI

 I am using Apache as a Proxy server and I am looking for an output filter module or code example of a filter that acts as a smart filter and replaces or erases context. I want to use a trainable filter functionality simular to a Bayesian filter. Can any one point me in the right direction or to a more apropriate form. Thanks
6  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Proxy Server Using Apache
on: March 16, 2006, 04:37:05 PM
I have sloved my problem I needed to place the request proxy directive into the conf file inorder to get Apache to act as a forward proxy server. Now all my request go through the Apache server before going to their destination.
7  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Testing Loaded Module
on: March 15, 2006, 03:46:42 PM
Hi

 How can I test my loaded custom module. I am having trouble getting it to trigger. I designed it simular to module mod_asis the only difference is that I don't have the same code in my handler function. I just open a new file and place the modules name in the file and the close the file. Also in my assign handler function ap_hook_handler I use APR_HOOK_LAST. I put my module entry into the conf file and varifed on Apache start up that it was loaded. I open a browser and type in http://localhost/ and the Apache start up page appears, however my handler function in my custom module never gets triggered. I added the same code to open a new file and place the modules name in the file and the close the file at the begining of the mod_asis handler functions code and it doesn't get triggered there either. The new files never get created. I am only creating these files as a way to see if the code is triggered. What should I do to trigger my module. Thanks
8  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Proxy Server Using Apache
on: March 13, 2006, 10:13:16 PM
Does anyone know what the default port is for Apache when using it as a proxy server or do I need to configure it for a certain port. Also in my IE is the proxy server settings the only thing I need to configure.
9  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Proxy Server Using Apache
on: March 13, 2006, 05:21:44 PM
Hi

 Question can Apache be set up to act like a Proxy Server?   And if so then how?
10  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Getting Past Apache Start Browser
on: March 13, 2006, 04:52:51 PM
I tried to use my address bar and typed in www.msn.com ,but it brought me back to the Apache Server Index page.
11  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Getting Past Apache Start Browser
on: March 13, 2006, 03:36:47 PM
HI

 I have download the windows source code compiled it, installed it and started the Apache2 service. Then I went to my Internet explorer and set up my Lan connection. Once I restarted my Web browser an Apache web page was displayed to let me know that I was successfully connected to the Apache2 service. My problem is how do I get past this page so that I can surface the internet and use my custom module that was loaded to filter Http request. I am using port 80
12  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Compiling Apache Source Code
on: March 03, 2006, 04:24:26 AM
I have set the envirnoment by running the VCVARS.bat file and setting the system path. Now I am getting a lot of build errors and they are all simular they only difference is they are for each *.mak file. Then there are other errors further down for Bad command or file name (i.e. pcre.mak)

Example:

NMake -nologo -apr.mak   CFG="apr - Win32 Release" RECURSE=0

 cl.exe/nologo /MD /W3 /Zi /O2 /I "/include" /I "./include/arch" /I "./
include/arch/win32" /I "./include/arch" /I "./include/arch/unix" /D "APR_DECLARE_STATIC" /D "WIN32" /D "_WINDOWS" /Fo".\Libr\\" /FD".\LibR|apr_src" /FD /c .\dso\win32\dso.c
NMAKE : fatal error U1045: spawn failed : Invalid argument
13  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Compiling Apache Source Code
on: March 01, 2006, 06:34:03 PM
Hi again I am sorry I seem so Inexperienced but, I do appreciate your help.

The command line example is not quite clear to me.

\httpd-2.0.55> nmake /f Makefile.win SERVERNAME="localhost" PORT=80 INSTDIR="C:\www\Apache2" installr

This is how my command prompt looks is it correct?

C:\Program Files\Microsoft Visual Studio\VC98\Common\Bin> msdev C:\build\httpd-2.0.55\Apache.dsw nmake /f Makefile.win SERVERNAME="localhost" PORT=80 INSTDIR="C:\www\Apache2" installr
14  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Compiling Apache Source Code
on: March 01, 2006, 06:03:47 PM
When you say set the environment are you refering to setting she System PATH to the path of the build tools. I already did that as the instructions stated.
15  DeveloperSide.NET / Web.Developer Server Suite Community Edition,
Public Support Forum
/ Compiling Apache Source Code
on: March 01, 2006, 03:53:05 PM
Can you tell me what I should do to check and resolve this Platform SDK problem?
Pages: [1] 2
Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!