DeveloperSide.NET Forums
July 09, 2020, 02:01:09 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Actinic setup - CGI-BIN problem  (Read 5391 times)
0 Members and 1 Guest are viewing this topic.
gray
Member
*
Posts: 27


View Profile
« on: May 23, 2006, 06:26:57 PM »

How easy is it to change the cgi-bin path.

At the moment the cgi-bin is outside of the webroot.

But in trying to get Actinic to run, it requires the cgi-bin to be inside of the webroot.

Any ideas plz.
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: May 23, 2006, 08:49:08 PM »

Edit \www\Apache2\conf\httpd.conf...
Here is how its handled right now -- \www\cgi-bin being scriptaliased...
Code:

<IfModule mod_cgi.c>
ScriptAlias /cgi-bin/ "/www/cgi-bin/"

<Directory "/www/cgi-bin">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>
</IfModule>


I assume you just need to run .cgi files under the \www\webroot\ structure -- as otherwise what you are asking for makes no sense -- it does not matter where cgi-bin is as long as its scriptaliased...

Find this part...
Code:

<Directory "/www/webroot">
Options Indexes
AllowOverride All
Order allow,deny
Allow from all
</Directory>


Change to...
Code:

<Directory "/www/webroot">
Options Indexes ExecCGI
AllowOverride All
Order allow,deny
Allow from all

AddHandler cgi-script .cgi .pl
</Directory>


Save file. Restart Apache.

http://httpd.apache.org/docs/2.0/howto/cgi.html

Also make sure that you know what a 'shebang' line is...
http://www.devside.net/web/config/cgi
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!