DeveloperSide.NET Forums
January 24, 2020, 07:37:51 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Apache SSL Service slow to start on Win32  (Read 24364 times)
0 Members and 1 Guest are viewing this topic.
DaveP
Guest
« on: November 30, 2003, 01:09:45 AM »

I've just installed the SSL version of Apache, replacing my old Foxserv (non-SSL) installation.  It appears to work just fine, but starting the service is *really* slow - like 3-5 minutes!   Is this a known issue? Is there anything I can do to speed this up?

Thanks,
Dave
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: November 30, 2003, 03:35:45 AM »

This is an issue for a few people, for some reason...

On my old P3 system, Apache2 starts within 10 seconds.

Here is the other post...
http://forums.devside.net/viewtopic.php?t=103

Try downloading the entire MS .NET 1.0 framework (instead of just using MSVCR70.dll)...
http://www.microsoft.com/downloads/details.aspx?FamilyID=d7158dee-a83f-4e21-b05a-009d06457787&DisplayLang=en

Let us know if this fixes the problem.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
DaveP
Guest
« Reply #2 on: November 30, 2003, 10:08:21 PM »

Installing the full .NET framework didn't have any effect on the startup time.  Any other suggestions?

Thanks,
Dave
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #3 on: December 01, 2003, 04:19:55 PM »

Try replacing under \www\Apache2\conf\httpd.conf and ssl.conf "Listen 80" and "Listen 443", respectively, to "Listen 127.0.0.1:80" and "Listen 127.0.0.1:443"

That way, instead of listening on "all interfaces", and figuring out what those "interfaces" are, Apache will know to just use 127.0.0.1
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #4 on: December 01, 2003, 06:21:39 PM »

If that does nothing, under httpd.conf edit "LogLevel error" to "LogLevel emerg"

This is the highest level.  And post the output of error.log

Maybe that will give us a clue.

It sounds to me that something is timing out.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
DaveP
Guest
« Reply #5 on: December 10, 2003, 01:20:28 AM »

Still no joy.  I've made the changes you suggested and there is no difference in the startup time.  Output of the error.log file is below.

[Tue Dec 09 20:09:02 2003] [notice] Parent: Created child process 1392
[Tue Dec 09 20:10:31 2003] [notice] Child 1392: Child process is running
[Tue Dec 09 20:10:31 2003] [notice] Child 1392: Acquired the start mutex.
[Tue Dec 09 20:10:31 2003] [notice] Child 1392: Starting 250 worker threads.


One other test I made was to comment out the line:

LoadModule ssl_module modules/mod_ssl.so

in http.conf.  This change resulted in a very fast startup.


Still wondering...
Dave
Logged
fantasydreaming
Guest
« Reply #6 on: June 11, 2004, 12:54:33 AM »

mine takes ~8 seconds to start, which I find odd.  Perhaps it is related to this earlier post, perhaps not.

I find myself having to restart the web service alot to get y configuarion right.

no big deal, just thought i'd mention it :)

[Thu Jun 10 17:37:36 2004] [notice] Child 2476: Exit event signaled. Child process is ending.
[Thu Jun 10 17:37:37 2004] [notice] Child 2476: Released the start mutex
[Thu Jun 10 17:37:38 2004] [notice] Child 2476: Waiting for 10 worker threads to exit.
[Thu Jun 10 17:37:38 2004] [notice] Child 2476: All worker threads have exited.
[Thu Jun 10 17:37:38 2004] [notice] Child 2476: Child process is exiting
[Thu Jun 10 17:37:41 2004] [notice] Parent: Created child process 2800
### notice 7 second  ####
[Thu Jun 10 17:37:48 2004] [notice] Child 2800: Child process is running
[Thu Jun 10 17:37:48 2004] [notice] Child 2800: Acquired the start mutex.
[Thu Jun 10 17:37:48 2004] [notice] Child 2800: Starting 10 worker threads.
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #7 on: June 11, 2004, 01:02:30 AM »

Quote

mine takes ~8 seconds to start, which I find odd.


As far as the time to start issue, 8 seconds is perfectly normal; this is not a simple program: libs/dlls have to be loaded, threads/processes have to be created and started, components have to be enabled, sockets/ports are bonded to, checks performed, and much much more...

On times of 3-5 minutes, clearly something else is going on the user's system, like a poorly functioning firewall/anti-virus program, broken interfaces, or any other number of things.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
japreja
Member
*
Posts: 10


View Profile WWW
« Reply #8 on: July 20, 2004, 11:35:20 PM »

I have the same 2 to 3 minute issue ad DaveP, I also notice that at random Apache2 will not start at system startup and needs to be started manualy!

I have
    1. Win XP SP1 (with some manual SP2 updates)
    2. HP Pavillion 533w (Trigem Glendale Board!(specs at
http://h10025.www1.hp.com/ewfrf/wc/prodinfoCategory?product=90862&sw_lang=8&lc=en&cc=us&dest_page=softwareCategory&dlc=en&tool=softwareCategory& ))
3. DeveloperSide.NET Web-Server Suite, v1.12 standard
4. QoS installed but service is not running at startup!
5. Cygwin install from nasa.gov mirrors on July 15 2004 all installs minus X and sources! I am in the process of getting all the sources for cygwin and recompiling everything for my system since most is compiled for i386 and not i686!
[/list]

I have tried countless time to download DeveloperSide.NET Web-Server Suite, v1.09s(b) SSL-enabled but I get the following error!

Quote
Authentication Failed
One of the following are true.

Your IP address does not appear to be of US origin.

You are being forwarded for.

Your ISP is AOL - we can not verify AOL users origin.

You are using a proxy.


I am in Buffalo NY,  I use www.bluefrog.com for my service provider not AOL and i am not behind a proxy!

Could you do a whois search and update your allowed IP addreses for this download? Bluefrog.com's Business # is 1-585-756-4593 and can be found on their website!  I am in the process of getting a static ip address and my sites will be using SSL when they are properly configured :shock: !

Could the 2 - 3 minute times have anything to do with using your default SSL cert's?  How can i make my own and not use any Pattented stuff!  I have OpenSSL installed which I downloaded from the Win32 link at http://www.openssl.org/related/binaries.html !  I installed it to a different Directory than your binaries! Should I have Installed overtop of your Distro?

Besides the 2 - 3 minute wait or manual startup, everything works fine for me!

I am running http://www.osCommerce.com , http://www.phpPBB.com, phpMyAdmin, http://classifieds.phpoutsourcing.com/ ! :lol:
Logged
japreja
Member
*
Posts: 10


View Profile WWW
« Reply #9 on: July 20, 2004, 11:42:24 PM »

One more thing I forgot to note, I have Cygate Personal Pirwall,  McAfee Internet Security Suite, and ClamWin AV from http://www.clamwin.com all running! :roll:
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #10 on: July 21, 2004, 12:45:10 AM »

Clearly something on your system is causing this 2-5 minute startup time, among the other problems that you have pointed out.  This is not the norm.

As far as the question about ssl certs causing this, no.  Like I said, most other people do not experience this lag.  (BTW, if you have openssl and mod_ssl installed, you do not need our SSL Suite)

The only way to find out the cause of this problem is to format your drive and do a clean install of your OS; after which you would install the Suite.  Only then, would you need to install your other programs to see which one(s) are causing all the problems (Sygate Personal Firewall, McAfee Internet Security Suite, or the AV software could be the cause)...

McAfee products have been known to cause problems for Apache.

You can create your own ssl certs by following the instructions in the win32 Apache2-SSL build guide.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
bmyers27
Member
*
Posts: 1


View Profile
« Reply #11 on: January 07, 2005, 10:58:24 PM »

I too am having a similar issue.  My server is a pure web server, no other services running that might be interfering with Apache.  It ran great on Apache 1.3 w/ Activeperl, I downloaded the Perl-5.8-win32-bin-0.7exe distro and installed it according to the instructions.  Since then, not only does it take a long time to start or re-start, it also seems to be serving graphics much slower than it did in Apache 1.3.  I've been reading speed optimizaiton articles for the last couple of hours and none of the suggestions seem to have made much of a difference.  It's not on the fastest PC around, an AMD XP1700 w/ 1GB RAM running Win2k, but it's not that high traffic of a site so it should be sufficient.  Let me know if you come up with any solutions cause I think we're in the same boat.

Thanks
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #12 on: January 08, 2005, 01:16:16 AM »

The distro we use here is our own...
http://www.devside.net

The latest version, 1.14, seems to start a bit faster than the previous versions... So it might have an effect on the select few that have startup delays in the minutes.  If I recall correctly, this entire matter has something to do with mod_perl (or perl related -- ex: like having something on your system left from ActiveState Perl that is interfering)
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #13 on: January 08, 2005, 10:39:29 AM »

Quote from: "admin"
The distro we use here is our own...
http://www.devside.net

The latest version, 1.14, seems to start a bit faster than the previous versions... So it might have an effect on the select few that have startup delays in the minutes.  If I recall correctly, this entire matter has something to do with mod_perl (or perl related -- ex: like having something on your system left from ActiveState Perl that is interfering)


I don't remember 100% but do you use a startup file for mod_perl?

if you remove it, apache will start +- 5sec faster for me
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!