DeveloperSide.NET Forums
January 24, 2020, 08:38:51 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1] 2
  Print  
Author Topic: Apache 2 Error  (Read 22903 times)
0 Members and 1 Guest are viewing this topic.
TurGe
Member
*
Posts: 10

turge24@hotmail.com
View Profile WWW
« on: August 22, 2006, 09:46:13 PM »

Hi All
Sorry for being a bit of a noob.
I cannot get Apache 2 to start
I have an isue in the log files.
[Tue Aug 22 22:44:14 2006] [error] Can't load Perl file: /www/Apache22/conf/Suite-extra/perl_extra.pl for server localhost:80, exiting...

I have just done a fresh install of devside onto windows 2003 server

I have had this working on a XP Machine previously with no issues but cannot get ot to work on 2003.

If any one can give me a pointer in te right direction it would be appreciated.

Cheers

mark
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: August 22, 2006, 09:48:12 PM »

Did you reboot after installation? This is required for the path changes to take effect system-wide -- and would cause a msg like this. That file should be there.

The only other thing I can think of is if you have ActiveState Perl installed on that system.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
TurGe
Member
*
Posts: 10

turge24@hotmail.com
View Profile WWW
« Reply #2 on: August 22, 2006, 09:51:23 PM »

Thanks for the quick response

Yup on more than one occasion, I have also uninstalled and reinstalled.

The file it cannot load is in the dir it mentions in the error, is there some setting on the server that needs to be set?

Is active perl installed as standard on a fresh 2k3 install?
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #3 on: August 22, 2006, 09:57:26 PM »

Quote
Is active perl istalled as standard on a fresh 2k3 install?


No. So I take it you did reboot? No need to reinstall...

Sometimes, for some reason, the path is not set. Check you path and make sure that everything is set -- AND that any older version Suite paths are removed.

http://www.devside.net/web/server/free/setup/instructions
Quote

(6) Go to 'Start' 'Settings' 'Control Panel'; Select 'System' - 'Advanced' - 'Environment Variables...'; Under 'System variables' select 'Path'
Add to Path:
<drive:>\www\openssl\bin;<drive:>\www\Apache22\bin;<drive:>\www\php5;<drive:>\www\mysql\bin;
<drive:>\www\perl\bin;<drive:>\www\tomcat5\bin
*NOTE that the individual locations are separated with a ";" and that you will need to place a ";" at the end of the original PATH, to separate it from the first appended location.


Replace '<drive:>' with drive letter.

Reboot.

Sometimes people do not install as Windows user 'administrator', and this happens. Also, make sure php.ini and my.ini are present under your C:\Windows or C:\Winnt dirs.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
TurGe
Member
*
Posts: 10

turge24@hotmail.com
View Profile WWW
« Reply #4 on: August 22, 2006, 10:12:04 PM »

Yes I did reboot, I have just gone and checked all the paths are correct and rebooted again.

PHP/my.ini are n the correct dir and have been edited to reflect the install drive letter.

Still get the same error when sarting the Apache service

I must be missing something here, install instructions are plain enough :-)
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #5 on: August 22, 2006, 10:17:59 PM »

Are you running any type of anti-vir or firewall software?
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #6 on: August 22, 2006, 10:19:06 PM »

Click on that file -- whats the type your system reports?
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
TurGe
Member
*
Posts: 10

turge24@hotmail.com
View Profile WWW
« Reply #7 on: August 22, 2006, 10:19:56 PM »

Yes Anti Virus, NOD32.

Should I turn this off and reinstall?
I have already tried starting apache with the service disabled and this did not make any difference.

thanks again for you help
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #8 on: August 22, 2006, 10:20:07 PM »

Are you running as 'administrator'?
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #9 on: August 22, 2006, 10:25:19 PM »

Try opening perl_extra.pl under wordpad or whatever text editor you use? Do you see any odd characters? The size should be 387 bytes.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
TurGe
Member
*
Posts: 10

turge24@hotmail.com
View Profile WWW
« Reply #10 on: August 22, 2006, 10:25:33 PM »

Yes I am logged into a remote session using windows remote desk top, logged in as the admin.
Logged
TurGe
Member
*
Posts: 10

turge24@hotmail.com
View Profile WWW
« Reply #11 on: August 22, 2006, 10:26:53 PM »

Quote from: "admin"
Try opening perl_extra.pl under wordpad or whatever text editor you use? Do you see any odd characters? The size should be 387 bytes.


contents

use ModPerl::Util ();
use Apache2::RequestRec ();
use Apache2::RequestIO ();
use Apache2::RequestUtil ();
use Apache2::ServerRec ();
use Apache2::ServerUtil ();
use Apache2::Connection ();
use Apache2::Log ();
use Apache2::Const -compile => ':common';
use APR::Const -compile => ':common';
use APR::Table ();
use Apache2::compat ();
use ModPerl::Registry ();
use CGI ();
1;
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #12 on: August 22, 2006, 10:31:49 PM »

Comment out...
Quote

PerlRequire "/www/Apache22/conf/Suite-extra/perl_extra.pl"


...under C:\www\Apache22\conf\Suite-extra\mod_perl.conf

See what happens. Load file errors are usually a result of Apache not being able to load the module, and not the file itself.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #13 on: August 22, 2006, 10:33:20 PM »

I assume you had no previous version of the Suite installed on that system. Sometimes, people install a new version right over the older one -- with some files under the perl dir being read-only set.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
TurGe
Member
*
Posts: 10

turge24@hotmail.com
View Profile WWW
« Reply #14 on: August 22, 2006, 10:38:35 PM »

No it was a fresh 2k3 install and a fresh Devside install using the following version setup-v1.17-apache-2.2.2-win32.exe self extracting self installing.

I think what I will do is complete uninstall, delete the paths and the services and do a manual install.

I need to get some sleep now as its almost midnight here, thanks for you help, if you have any other sugestions just post away and i will get them tomorrow

Thanks

Mark
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!