DeveloperSide.NET Forums
July 09, 2020, 01:27:38 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: AddHandler cgi-script not working  (Read 8193 times)
0 Members and 1 Guest are viewing this topic.
hmag
Member
*
Posts: 17


View Profile
« on: August 30, 2006, 10:11:41 PM »

Hi again,
 As mentioned in a previous post, I have dopwnloaded & installed the most current version of the devside suite - things work fine, however, I cannot seem to get the AddHandler flag working properly.

 I have the following set:

AddHandler cgi-script .exe

 I have tried setting that in httpd.conf as well as \Suite-extra\cgi-bin.conf but when the page I am testing calls the script, Apache tries to serve the .exe file, with the browser issuing a download prompt, instead of executing. Can anyone tell me what I am doing wrong here - I have been issuing httpd -k restart to reload the config after each change.

 Under the Apache 2.0.59 install I was working on previously, I simply added that AddHandler line in & reloaded the file - any assistance is much appreciated.

Again, thanks for any help - Terry
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: August 31, 2006, 01:08:49 AM »

Quote

AddHandler cgi-script .exe


This needs to be placed in whatever dir block that you want to run cgi...

Under this Suite, cgi-bin, is defined under conf\Suite-extra\cgi-bin.conf

You also need to add...
Options +ExecCGI
...under that dir block.

And those exe files would be placed under C:\www\cgi-bin\
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #2 on: August 31, 2006, 01:14:23 AM »

You have read the Guide and uncommented line...
'#Include conf/Suite-extra/cgi-bin.conf'
...under conf\httpd.conf ?

http://www.devside.net/web/server/free/setup/instructions
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
hmag
Member
*
Posts: 17


View Profile
« Reply #3 on: August 31, 2006, 08:40:22 AM »

Quote from: "admin"
You have read the Guide and uncommented line...
'#Include conf/Suite-extra/cgi-bin.conf'
...under conf\httpd.conf ?

http://www.devside.net/web/server/free/setup/instructions

Hi again,
 Indeed, that was where I first headed to try & troubleshoot. After placing a different .exe file into the directory, it worked fine. Turns out the problem was actually a corrupt .exe file. Replaciong it with another file fixed the problem - many thanks for your reply.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!