DeveloperSide.NET Forums
December 07, 2019, 05:16:47 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Downgrade php  (Read 9032 times)
0 Members and 1 Guest are viewing this topic.
blobby
Member
*
Posts: 21


View Profile
« on: January 16, 2007, 04:11:14 PM »

dont laugh admin!!!

Yes it's true, I now need to down grade php to ver 4.3.11.  my host doesnt support ver 5.  this means i cannot see my php pages!!

I've no idea how to do this.  Can anyone help please?
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: January 16, 2007, 04:16:55 PM »

Just don't use any php5 specific features of the language?
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
blobby
Member
*
Posts: 21


View Profile
« Reply #2 on: January 16, 2007, 04:26:43 PM »

ah right.

Well i cant see my pages online so i've obviously used some ver 5.

how do i know which is which, is there a setting somewhere which i can change?

Or do i have to look at the code and compare that to a chart acceptable features or something?

Please bare in mind that I'm quite new to all this.

Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #3 on: January 16, 2007, 05:57:46 PM »

Check the Apache error.log for the first occurrence of a php problem. Usually thats where the errors go, but your host might have changed that. Try a simple phpinfo() script to make sure you are at least getting this right...
<?php
phpinfo();
?>
« Last Edit: January 17, 2007, 02:56:30 PM by admin » Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
blobby
Member
*
Posts: 21


View Profile
« Reply #4 on: January 17, 2007, 11:57:54 AM »

thanks admin.

If this is the only way around my problem i will do it but, I am very impressed with WAMP and I would like to have an installation that works with my host without any 'tampering' with code etc.

Is there a version of WAMP which uses php 4.3.11 and mysql 4.1.12 which i can install anstead of WAMP5?  Or even if it doesnt use mysql 4.1.12 it doesnt matter so much.
Logged
portland
Jr. Member
**
Posts: 32


View Profile
« Reply #5 on: February 28, 2007, 04:12:34 PM »

There is EasyPHP, which is php 4.x with MySQL 4.x.  Google it up.  They are kinda sluggish in upgrading the package but it works.

I just started using DevSide WAMP because it is wonderfully up to date...
Logged
portland
Jr. Member
**
Posts: 32


View Profile
« Reply #6 on: March 01, 2007, 10:34:38 AM »

... and the latest DevSide version has a file PHP4Downgrade.txt which describes the whole process.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!