DeveloperSide.NET Forums
December 10, 2019, 03:35:23 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: White screen  (Read 9596 times)
0 Members and 1 Guest are viewing this topic.
blobby
Member
*
Posts: 21


View Profile
« on: January 22, 2007, 12:04:37 PM »

Hi'guys,

WAMP was working fine using DW.  However, after uploading my site to my host (using DW), it hasn't worked since.

When I tried to use the DW 'preview in browser' function, all i got was a white screen.  There seemed to be no connection to the server.  If i went to the server itself and viewed a page on there, it worked ok.

I have uninstalled WAMP and reinstalled, and now I cant even get into phpadmin (white screen again).  I cant remember if i have been into phpadmin since it went wrong before the reinstall.

Also, when i try to see phpadmin i get a service running called 'http.exe' and it uses ALL of my resources untill i stop it using task manager.

Can anyone help please....

« Last Edit: January 22, 2007, 12:18:47 PM by blobby » Logged
blobby
Member
*
Posts: 21


View Profile
« Reply #1 on: January 22, 2007, 01:08:01 PM »

ok, i 'restored' my computer to a week ago and reinstalled WAMP and it now works.

No idea what i did wrong.
Logged
blobby
Member
*
Posts: 21


View Profile
« Reply #2 on: January 28, 2007, 06:11:00 PM »

Aaaaaarrrrrrggghhhhh!!!!!!!!!!!!!!

This has happened again.

After uploading my site using the hosts ftp software, i can no longer connect to localhost (phpadmin or any files on there).

Please can someone help me here.  I dont want to go through reinstalling every time i upload a site.

Many thanks
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #3 on: January 28, 2007, 07:28:50 PM »

Can you confirm that Apache is running?

Can you access http://127.0.0.1 ?
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
yfastud
Customer, Basic Support
Jr. Member
*****
Posts: 36


View Profile
« Reply #4 on: January 29, 2007, 07:11:59 PM »

When coding form and save as php, I've got white screen if using IE but it works fine w/ Firefox. Not sure if you've got same problem.
Logged
blobby
Member
*
Posts: 21


View Profile
« Reply #5 on: January 31, 2007, 07:49:08 PM »

sorry for delay in replying.

i cannot connect to any page on the server, including phpadmin.

I installed WAMP5 and all was well untill i uploaded my site to my host using dreamweavers built in ftp client.

After that I could not view any pages on localhost, it tried to open a page for ages (using all of the cpu usage) but just returned nothing (including phpadmin).

I re installed WAMP5 and all was well again.

However, i uploaded my site again using my hosts ftp client,  and the same thing has happened!!

I have tried to view my error log but it's too large to open!! it's 801,814kb.

Sometimes i get the usual 'page cannot be displayed' message.  Mostly tho the page just stays blank (white) untill it times out or i get fed up of waiting!

I have moved the original error file and it put a new one there all by itself.  It has the following errors logged:-

[Sun Jan 28 18:59:02 2007] [notice] ModSecurity for Apache 2.0.4 configured
[Sun Jan 28 18:59:05 2007] [notice] Apache/2.2.3 (Win32) mod_ssl/2.2.3 OpenSSL/0.9.8d PHP/5.2.0 mod_perl/2.0.3-dev Perl/v5.8.8 configured -- resuming normal operations
[Sun Jan 28 18:59:05 2007] [notice] Server built: Nov 15 2006 21:34:51
[Sun Jan 28 18:59:05 2007] [notice] Parent: Created child process 3092
[Sun Jan 28 18:59:08 2007] [notice] ModSecurity for Apache 2.0.4 configured
[Sun Jan 28 18:59:10 2007] [notice] Child 3092: Child process is running
[Sun Jan 28 18:59:10 2007] [notice] Child 3092: Acquired the start mutex.
[Sun Jan 28 18:59:10 2007] [notice] Child 3092: Starting 250 worker threads.
[Sun Jan 28 18:59:10 2007] [notice] Child 3092: Starting thread to listen on port 443.
[Sun Jan 28 18:59:10 2007] [notice] Child 3092: Starting thread to listen on port 80.
[Sun Jan 28 18:59:10 2007] [error] (OS 10038)An operation was attempted on something that is not a socket.  : Child 3092: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.


that is at the start of the log, but then this line appears thousands of times :-

[Sun Jan 28 18:59:10 2007] [error] (OS 10038)An operation was attempted on something that is not a socket.  : Child 3092: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.

Then this lot:-

[Sun Jan 28 18:59:29 2007] [notice] Parent: child process exited with status 1 -- Restarting.
[Sun Jan 28 18:59:32 2007] [notice] Apache/2.2.3 (Win32) mod_ssl/2.2.3 OpenSSL/0.9.8d PHP/5.2.0 mod_perl/2.0.3-dev Perl/v5.8.8 configured -- resuming normal operations
[Sun Jan 28 18:59:32 2007] [notice] Server built: Nov 15 2006 21:34:51
[Sun Jan 28 18:59:32 2007] [notice] Parent: Created child process 1704
[Sun Jan 28 18:59:34 2007] [notice] ModSecurity for Apache 2.0.4 configured
[Sun Jan 28 18:59:36 2007] [notice] Child 1704: Child process is running
[Sun Jan 28 18:59:36 2007] [crit] (OS 109)The pipe has been ended.  : setup_inherited_listeners: Unable to read socket data from parent
[Mon Jan 29 17:32:50 2007] [notice] ModSecurity for Apache 2.0.4 configured
[Mon Jan 29 17:32:53 2007] [notice] Apache/2.2.3 (Win32) mod_ssl/2.2.3 OpenSSL/0.9.8d PHP/5.2.0 mod_perl/2.0.3-dev Perl/v5.8.8 configured -- resuming normal operations
[Mon Jan 29 17:32:53 2007] [notice] Server built: Nov 15 2006 21:34:51
[Mon Jan 29 17:32:53 2007] [notice] Parent: Created child process 2192
[Mon Jan 29 17:32:56 2007] [notice] ModSecurity for Apache 2.0.4 configured
[Mon Jan 29 17:32:59 2007] [notice] Child 2192: Child process is running
[Mon Jan 29 17:32:59 2007] [notice] Child 2192: Acquired the start mutex.
[Mon Jan 29 17:32:59 2007] [notice] Child 2192: Starting 250 worker threads.
[Mon Jan 29 17:32:59 2007] [notice] Child 2192: Starting thread to listen on port 443.
[Mon Jan 29 17:32:59 2007] [notice] Child 2192: Starting thread to listen on port 80.

then this line thousands on times:-

[Mon Jan 29 17:32:59 2007] [error] (OS 10038)An operation was attempted on something that is not a socket.  : Child 2192: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.

the 2 lines that have been repeated lots of times make up alomost all of the the 801,814kb file.

  I think that the new log is being continously written to.

hope this helps a bit.


Can anyone help me please?

Thanks in advance

also,

Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #6 on: January 31, 2007, 08:26:55 PM »

You could edit httpd.conf, add line 'Win32DisableAcceptEx', save, and restart Apache too see if that helps.

Otherwise, the only solution is to not use the built-in DW ftp client as it seems to be doing something very odd to your system.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!