DeveloperSide.NET Forums
December 12, 2019, 08:12:51 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Standard cgi ruby scripts on WAMP5?  (Read 4792 times)
0 Members and 1 Guest are viewing this topic.
Jon
Member
*
Posts: 1


View Profile Email
« on: February 16, 2007, 03:59:24 PM »

Hi there,

I've been looking for a fair old while now and there seems to be a lot of solutions that appear to do what I need but just turn out to not be the solution afterall.  It would seem straightforward, and I am new to server configuration, cgi and ruby, but I am just trying to get WAMP5 to be able to run standard .cgi ruby scripts as opposed to fastcgi.  I have followed this following tutorial:

http://forum.stylegala.com/viewtopic.php?t=3964

which was very helpful and allowed me to set up, trouble free, WAMP5 to be able to execute fastcgi ruby scripts.  However, initially I thought this would also allow me to execute regular ruby cgi scripts not realising there was more than a subtle difference between the cgi and fastcgi scripting format.  I have read up a fair amount on the possibility of converting the script to fastcgi, but I do not want to do this as it was not written by me and I do not also have the knowhow for the conversion.  So, what I need to do is install a standard cgi ruby interpreter, something which despite very extensive searching has eluded me so far.  Theres plenty to enable you to execute a fastcgi script using a cgi interpreter but not the other way around.  Any pointers on how I might be able to go about doing this is much appreciated as I really am at a dead end currently.

Thanks in advance

Jon
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!