DeveloperSide.NET Forums
December 07, 2019, 03:52:53 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1] 2
  Print  
Author Topic: Cannot get anything to work localhost  (Read 23899 times)
0 Members and 1 Guest are viewing this topic.
StarUK
Member
*
Posts: 12



View Profile
« on: May 29, 2007, 11:48:06 PM »

I have downloaded and followed the default installation. nothing happens when I try to access localhost

I have unistalled it using the uninstall file then done a fresh install still the same

I am using windows Vista Ultimate

I tried to install this on my old comp windows XP (sp2) and I get to the Web-Developer Contorller and it says :- 

Srevice                 Status               Setup Type
Apache2.2           Error(1)              Automatic

how can I get this to work please.
Logged

If at first you don't succeed give up was it worth it!!!
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: May 29, 2007, 11:49:34 PM »

The contents of \www\Apache22\logs\error.log would be helpful.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
StarUK
Member
*
Posts: 12



View Profile
« Reply #2 on: May 29, 2007, 11:51:28 PM »

Content empty I looked there on both machines
Logged

If at first you don't succeed give up was it worth it!!!
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #3 on: May 30, 2007, 12:20:54 AM »

Run cmd.exe, and type in...
httpd -t
net start Apache2.2

What does it return?
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
StarUK
Member
*
Posts: 12



View Profile
« Reply #4 on: May 30, 2007, 03:14:48 AM »

net star Apache2.2 returns the following

System error 5has occurred

Access is denied
Logged

If at first you don't succeed give up was it worth it!!!
StarUK
Member
*
Posts: 12



View Profile
« Reply #5 on: May 30, 2007, 03:32:24 AM »



Here is my screen shot

I know they are all installed as I followed your installation program. I have even down loaded another Web-Developer Suite Command box that was suggested in another post?
« Last Edit: May 30, 2007, 03:34:21 AM by StarUK » Logged

If at first you don't succeed give up was it worth it!!!
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #6 on: May 30, 2007, 01:37:33 PM »

Sounds like a conflict with your system. Are you log in as administrator? Do you have anti-virus or firewall s/w installed?
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
StarUK
Member
*
Posts: 12



View Profile
« Reply #7 on: June 12, 2007, 07:32:47 PM »

I am the only user on this computer so I am admin and my firewall is configured to accept Web_Dev Contoller and all the programs used by it. Still cannot get it to run
Logged

If at first you don't succeed give up was it worth it!!!
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #8 on: June 12, 2007, 09:17:07 PM »

See if anything is listening on port 80... netstat -an
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
StarUK
Member
*
Posts: 12



View Profile
« Reply #9 on: June 12, 2007, 10:27:23 PM »

Yes it seems to be listening to port 80 but I am not too sure as I am only just starting to learn php and CS3 Dreamweaver
Logged

If at first you don't succeed give up was it worth it!!!
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #10 on: June 13, 2007, 01:20:04 AM »

If Apache is not running, and something is listening on port 80, than that is the problem... You already have IIS, or some other instance of Apache installed.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
StarUK
Member
*
Posts: 12



View Profile
« Reply #11 on: June 13, 2007, 03:10:25 AM »

Apache is running I get the apache installed successfully page and can see info.php page but I cannot get anything else to work and the web-dev controller still says nothing is installed.

I have even unplug the internet so I could turn off my firewall and still nothing
Logged

If at first you don't succeed give up was it worth it!!!
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #12 on: June 13, 2007, 01:34:00 PM »

I thought you said nothing works and apache does not start?

BTW, there is no Apache installed successfully page with our setup... You are running another instance of Apache that is not ours. Check 'services.msc' for the Apache service name and see where its pointing.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
darxx
Member
*
Posts: 3


View Profile
« Reply #13 on: August 02, 2007, 09:51:12 AM »

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\darxx>httpd -t
Syntax OK

C:\Documents and Settings\darxx>net start Apache2.2
The Apache2.2 service is starting.
The Apache2.2 service could not be started.

A service specific error occurred: 1.

More help is available by typing NET HELPMSG 3547.


C:\Documents and Settings\darxx>
Logged
darxx
Member
*
Posts: 3


View Profile
« Reply #14 on: August 02, 2007, 10:01:37 AM »

C:\www\Apache22\bin>Apache -k install
'Apache' is not recognized as an internal or external command,
operable program or batch file.

C:\www\Apache22\bin>httpd.exe -k install
[Thu Aug 02 13:00:44 2007] [error] Apache2.2: Service is already installed.

C:\www\Apache22\bin>httpd.exe -k start
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted.  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

C:\www\Apache22\bin>
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!