DeveloperSide.NET Forums
May 23, 2019, 06:53:11 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Wordpress Installation Troublems - details inside  (Read 17772 times)
0 Members and 1 Guest are viewing this topic.
papicek
Member
*
Posts: 3


View Profile Email
« on: July 04, 2007, 05:28:44 AM »

Hello, I'm new to this.
I'm having trouble installing Wordpress (nothing is happening at all) and here are the details:

OS:  winXP pro SP2
Web-Developer Server Suite 2.0 including:
Apache 2.2.4
php5
mysql5

phpMyAdmin for MySQL works fine.

my ISP blocks port 80 so Apache is set to listen on port 8080
port forwarding in my router is done, and my test page is visible everywhere

hosts file has the following:  "127.0.0.1:8080    localhost"  (without which phpMyAdmin does not work)

Yes.  I read the new wordpress installation guide here in forums (thank god for search, I say)

In the Suite-extras/webapps/wordpress.conf file I've tried "127.0.0.1", "127.0.0.1:8080", as well as "localhost" (got me nowhere)

the Apache server configuration data for Wordpress is as follows:

In file: C:/www/Apache22/conf/Suite-extra/webapps/wordpress.conf
   5: AccessFileName .htaccess
   6: <Files ~ "^\.htaccess$">
   7:   order allow,deny
   8:   deny from all
    : </Files>
  11: Alias /wordpress "C:/www/webapps/wordpress"
  13: <Directory "C:/www/webapps/wordpress">
  14:   Options FollowSymLinks
  15:   AllowOverride FileInfo
  17:   order allow,deny
  18:   allow from localhost
  21:   AddType text/html .php
  22:   AddHandler application/x-httpd-php .php
    : </Directory>

I created a user for the wordpress db in MySQL and granted all privileges, using both SQL and going into the table itself and clicking on every "Y" radio button offered....  Then FLUSHED, of course.

Finally my wp-config.php:

<?php
// ** MySQL settings ** //
define('DB_NAME', 'wordpress');    // The name of the database
define('DB_USER', 'zzzzzzzz');     // Your MySQL username
define('DB_PASSWORD', 'xxxxxxx'); // ...and password
define('DB_HOST', 'localhost');    // 99% chance you won't need to change
this value

// You can have multiple installations in one database if you give each a
unique prefix
$table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!

// Change this to localize WordPress.  A corresponding MO file for the
// chosen language must be installed to wp-includes/languages.
// For example, install de.mo to wp-includes/languages and set WPLANG to
'de'
// to enable German language support.
define ('WPLANG', '');

/* That's all, stop editing! Happy blogging. */

define('ABSPATH', dirname(__FILE__).'/');
require_once(ABSPATH.'wp-settings.php');
?>

(user and password are, of course, totally different)

The behavior thus far is this:  pointing to http://localhost/wordpress/wp-admin/install.php in IE6 simply won't load.  I get an unending pointer/hourglass cursor. The blog login page I hoped to load simply never shows up and the database tables aren't created.

I've spent hours debugging here.

ANY help would be most gratefully appreciated.

Thanks in advance...I really want to install this.  People who say their thing is a labor of love, like they have about wordpress...well, that particular condition resonates with me.  (Though that 5 minute installation thing really sticks in my craw at this point....)
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: July 04, 2007, 01:27:42 PM »

1) Leave Apache listening to port 80, and just port forward port 8080 WAN to port 80 LAN under router.

2) WordPress already come setup under the Suite, all you have to do is go to localhost/wordpress to finish the installation.

3) Don't worry about getting it to work from the outside, or for your specifics, just make sure it works locally first.

4) The Windows HOST file should not have ports in it... Just 127.0.0.1 localhost

5) Use an IP, like 127.0.0.1, under those 'allow from ...' lines.

6) Check file \www\Apache22\logs\error.log to see if Apache is logging any errors about your problem.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
papicek
Member
*
Posts: 3


View Profile Email
« Reply #2 on: July 04, 2007, 03:27:20 PM »

Very sweet.

I want to thank you for replying...this is the 4th of July, isn't it?  I was certain I'd have to wait.  Go have a beer and grill some burgers, please.

Did everything as you said.  Uninstalled everything and found I had another implementation of php installed.  I have no idea if it was running or not.  The port forwarding thing was a cinch (an aging BEFW11S4, but it's a trooper....).

phpMyAdmin comes up fine on port 80, and the wordpress install went smooth as silk.  My index page is visible, and the link to wordpress kinda works...I get a page without any design or graphics to it; and all the elements are aligned on the left hand side (on an IE7 browser), though on the localhost (IE6), it works fine.  Any thoughts on this?

Again, thanks.
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #3 on: July 04, 2007, 08:01:04 PM »

Quote
My index page is visible, and the link to wordpress kinda works...I get a page without any design or graphics to it; and all the elements are aligned on the left hand side (on an IE7 browser), though on the localhost (IE6), it works fine.  Any thoughts on this?

Sounds like a classic domain/IP link CSS issue. Is this viewing from outside the system the Suite is install on? Just check the source code of the page, you will see everything is still pointing to 'localhost' or '127.0.0.1'. You'll need to change that to your LAN IP, or domain name. Use the local system, enter wordpress, and look for a domain/url field... Change to LAN IP.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
papicek
Member
*
Posts: 3


View Profile Email
« Reply #4 on: July 04, 2007, 08:53:44 PM »

The Apache error.log shows nothing, and really hasn't shown anything but successful service starts and stops.

I just found the error_ssl.log and OMG.  I'll get back to you, I'm sure....

Btw, thanks again. Now go enjoy your holiday!
Logged
rkhire
Member
*
Posts: 3


View Profile
« Reply #5 on: February 04, 2009, 08:18:07 AM »

Quote
Sounds like a classic domain/IP link CSS issue. Is this viewing from outside the system the Suite is install on? Just check the source code of the page, you will see everything is still pointing to 'localhost' or '127.0.0.1'. You'll need to change that to your LAN IP, or domain name. Use the local system, enter wordpress, and look for a domain/url field... Change to LAN IP.

Here do you mean the Wordpress Address (URL) that is there in the Wordpress->General Settings or is some other? Coz once when I had done that I could not log on to wordpress..(it gave me some invalid source error)
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!