DeveloperSide.NET Forums
July 13, 2020, 04:02:33 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: how can I solve a URL problem.  (Read 7406 times)
0 Members and 1 Guest are viewing this topic.
Wilz
Member
*
Posts: 26


View Profile
« on: July 19, 2007, 11:37:31 AM »

Hi was wandering how I could solve a problem of, not having to include my website folder name (arcade) in the URL, when typing the url. For example if I type in http://gamesgalore.servegame.org, I will get a page displaying all my different websites, which means that I have to type in http://gamesgalore.servegame.org/arcade in order for my arcade website to come up. So when I put my website on the internet I would like people to just type in the URL, http://gamesgalore.servegame.org and not have to include the folder name (arcade) in case they forget to type the whole url end up seeing a page that displays all my other website folders.
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: July 19, 2007, 11:54:24 AM »

Use Virtual Hosting.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Wilz
Member
*
Posts: 26


View Profile
« Reply #2 on: July 19, 2007, 12:10:40 PM »

Sheesh that was a fast reply "AWSOME" ok, yea I using virtual hosting but like I was saying I have to type the URL + a forward slash and folder name. I only want to type in just, http://gamesgalore.servegame.org, URL and not have to include a folder name after a forward slash. It's just in case people forget to add the, /arcade when typing the URL. I did try to use, ServerAlias in the vhost directive, which I thought might help but to no avail.
Logged
Wilz
Member
*
Posts: 26


View Profile
« Reply #3 on: July 19, 2007, 12:16:18 PM »

Here's a copy of my vhost config file.

<VirtualHost *:80>
    ServerAdmin admin@gamesgalore.servegame.org
    DocumentRoot /www/webroot/arcade
    ServerName gamesgalore.servegame.org/arcade
    ErrorLog logs/arcade-error_log
    CustomLog logs/arcade-access_log common
    <Directory "/www/webroot/arcade">
         Options Indexes FollowSymlinks
         AllowOverride All
         Order allow,deny
         Allow from all
    </Directory>
</VirtualHost>
AccessFileName .htaccess

<Files ~ "^\.htaccess$">
   order allow,deny
   deny from all
</Files>


<VirtualHost *:80>
    ServerAdmin admin@findafriend.shacknet.nu
    DocumentRoot /www/webroot/random
    ServerName findafriend.shacknet.nu
    ErrorLog logs/random-error_log
    CustomLog logs/random-access_log common
    <Directory "/www/webroot/random">
         Options Indexes FollowSymLinks
         AllowOverride None
         Order allow, deny
         Allow from all
    </Directory>
</VirtualHost>
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #4 on: July 19, 2007, 01:33:37 PM »

Change this line... ServerName gamesgalore.servegame.org/arcade
To... ServerName gamesgalore.servegame.org

Save file, and restart Apache. That's the only thing I can think of, of why your URLs are happening the way they are... As everything else looks good.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!