DeveloperSide.NET Forums
July 07, 2020, 05:43:37 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: 1 [2]
  Print  
Author Topic: mod_security and upload script  (Read 21306 times)
0 Members and 1 Guest are viewing this topic.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #15 on: October 02, 2007, 02:30:14 PM »

You could try this link and see if anything shows up out-of-place...
http://localhost/server-info#mod_security2.c
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
jeffshead
Member
*
Posts: 24



View Profile
« Reply #16 on: October 05, 2007, 02:13:30 PM »

You could try this link and see if anything shows up out-of-place...
http://localhost/server-info#mod_security2.c

I did not see anything out of place.

I have been communicating via the ModSecurity mailing list and have tried a few things.

The latest, I cannot get to work and I don't know why. I added a new rule as per Ryan Barnett's instructions:

'www\Apache22\conf\Suite-extra\security_rules\modsecurity_crs_15_customrules.conf'

The only line I have in this file is:

Code:
SecRule REQUEST_URI "^/cgi-bin/xuploadpro/upload\.cgi$" \ "phase:1,nolog,pass,ctl:requestBodyAccess=Off"

All of my includes in the config files are correct, but the server will not restart unless I comment out the code above.

Ryan said it should work.

I have individual error logs for each vhost. There are no entries in them for the time of my attempted restart.

In the main 'error.log', I have the following entries:

Code:
[Wed Oct 03 12:46:52 2007] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Wed Oct 03 12:46:52 2007] [notice] Child 2036: Exit event signaled. Child process is ending.
[Wed Oct 03 12:46:53 2007] [notice] Child 2036: Released the start mutex [Wed Oct 03 12:46:54 2007] [notice] Child 2036: Waiting for 250 worker threads to exit.
[Wed Oct 03 12:46:54 2007] [notice] Child 2036: All worker threads have exited.
[Wed Oct 03 12:46:55 2007] [notice] Child 2036: Child process is exiting [Wed Oct 03 12:46:55 2007] [notice] Parent: Child process exited successfully.

Do you have any ideas as to why the server will not restart?
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #17 on: October 05, 2007, 04:12:47 PM »

Try running: 'httpd -t' for a syntax check. Other then that, you could try getting the most up-to-date version of mod_security2.dll.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
jeffshead
Member
*
Posts: 24



View Profile
« Reply #18 on: October 06, 2007, 02:25:09 PM »

Try running: 'httpd -t' for a syntax check. Other then that, you could try getting the most up-to-date version of mod_security2.dll.

This is what I get in the command line window:

Code:
C:\www\Apache22\bin>httpd -t
Syntax error on line 1 of C:/www/Apache22/conf/Suite-extra/security_rules/modsec
urity_crs_15_customrules.conf:
SecRule takes two or three arguments,

C:\www\Apache22\bin>
« Last Edit: October 06, 2007, 02:27:25 PM by jeffshead » Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!