DeveloperSide.NET Forums
March 25, 2019, 06:01:54 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Simple Solutions to most problems  (Read 9890 times)
0 Members and 1 Guest are viewing this topic.
Livingstone
Member
*
Posts: 8


View Profile
« on: November 14, 2007, 09:39:00 AM »

Hi Every one,

as you can tell from the number of posts, i am new to this server but have been working on others for quite some time. I am a php programmer and what i love which i assume you love tool is to get the best out of any tool we use whatsoever to enhance on productivity while reducing the amount of time we actually spend working on why nots and how to and errors and this and that. well i just felt it will be useful to write out a few simple things which i found out with this wonderful tool on windows vista.

Where the problem lies

Now if you are using windows vista, the problem is not the tool, the problem is the rather random ideology of your vista operating system. I am not part of the development team for this server, but i assume it was intentionally or is a multi-user, multi terminal oriented kind of thing. Vista is a network on its own, thus like every other network, you have an administrator with its 'root' terminal and other users with respective privileges assigned to.

What you should do

When i just got the server, i was killing myself with questions, why i could not connect to phpmyadmin using the root credentials, why my  WD-controller, does not show what modules have started and are running, why in my php aps using a simple class to connect to a database using the root credentials will not work, why dream weaver returns a 'failure to connect to database', why all my MySQL GUI tools wont connect to my database even though i am logged onto my computer as administrator. for the first few weeks i was furious about how such a should be great tools, rather slows down my productivity, but just this week i found out something which i think this article is worth writing. So what did i do (Assuming your using windows vista)

1. Starting your services: As some of you might have notice Vista has this stupid account control thing, (i don't know what they were thinking) even though you are logged on as administrator, you must verify your privileges before performing certain tasks, (Worst thing to do is to disable this. Likely consequences are you will not be able to do vital task, like say copy to certain directories, or worst still to use any feature of this server) The first thing to do, is if you have your services running as automatic, go to your services (click start-up and type 'services' in the search filed, don't forget to right click then run as administrator) and stop all of them. Now go to start up again, right click on web developer controller and click run as administrator, and start the services from there. you should now be able to see what is on and running

2. Connecting to phpmyadmin Oops, i bet if you search for this on the forums you will be overwhelmed by the number of results you'll get. well everything is down to earth vista, like the previous example, you MUST start your browser as an administrator, if not, don't ever dream of connecting with your root credentials, you'll "get this annoying popup window that does not say whether its an error message or not" - (an excerpt from a post). Another thing which i am not sure of put it worked for me (Hey check my disclaimer below before reading further) is that i did a dns flush once, and it appeared that even without starting my firefox browser without administrative privileges it still works. many other things worked painlessly. This NEVER worked so before (thus confirmation of my null hypothesis). have not been using safari, IE7, Netscape, Opera for a while, but will check those as well and edit accordingly. Find out how to do a dns search using goggle if you dont know, but please remember this was trial against error,and i did this because a newly registered domain name which i just grabbed was pointing to localhost/phpmyadmin on my local computer even though on others it was pointing to the site. However it solved a secondary porblem i assume. DISCLAIMER: you hold full responsibility for doing any of this, i am no microsoft specialist, and haved not paid great detail to verify results obtained here, statements are based on observations being consistent. Check out whatever you do with a relevant specialist before you mug your machine and put your hand on your head

3. Anything else To the developer i will say, Run everything, from your browser, to dream weaver to even the server as an administrator and you'll enjoy the amazing features of this server and how your productivity is greatly enhanced. Personally i have NOT found a better cost effective tool.

Well thats it, and i now live peacefully and happily
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: November 14, 2007, 12:18:14 PM »

Good post. Sorry to hear about all the problems Vista has caused you. SP1 should fix a few things when it comes out.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Livingstone
Member
*
Posts: 8


View Profile
« Reply #2 on: November 17, 2007, 04:14:14 PM »

Upgrading to Version 2.0, dont be scared, it works fine

well after the previous post, just realized version 2.0 had been released! and following the fear that arose when its predecessor was announced , that is upgrading, i just felt ill give it a try on vista. and just felt ill put a note here to say it alls goes well! this is my dummies approach in writing up instructions . I am sorry if its extremely 'dummy'

What i did

1. I did not back up my files and i lost lots of hours of work :(. So BACK UP YOUR FILES. Back up all your work, and take then off the C:\, lets say store them to a CD, very very important, i lost my files and was really mad last night cause i had to do some again. my negligence, but dont do same

2. I Downloaded version 2.0,

3. I then un installed the current 1.95 version from the control panel, (Oops just a note, stop all running services before doing this. this is just not to give the annoying vista another nice story )

4. I then installed  the version 2.00, providing administrative permission were necessary (Like i said earlier, there is no point in trying to disable windows Account control, cause you'll rather end up with lots of trouble) so just accept the time wasting dialog permission request and proceed)

5. I restarted my computer.

Testing that it works fine

6. I started my browser  and went (not using a car :-] nor walking) to http://localhost/docs/suite-guide/, and while sipping some of cappuccino, i read through the instructions. and there are lots of changed stuff i must say, but still very very productive and good changes (check the change log)

7. I then made sure that i could access phpmyadmin. i typed in http://localhost/phpmyadmin and yes the popup asking for credentials, i gave him the credentials which i had read from the previous step, and again it wouldn't let me in. I tried again but did not work! then i realized i had not started my browser with administrative rights. I closed it down, and restarted it as administrator, redirect to php my admin, entered the credentials and voilą, i was in, (some people complain of being able to access this just once and cannot later) i closed every thing down and opened again and again till i was satisfied that it worked. Again there tables in there were slightly different to the previous, but like before good changes, and still very productive,

8. I opened all my MySQL GUI tools, browser, query kits, and so on using administrative permission, and they worked fine!

9. I installed, the various CMSs i work with and the worked well. the folder is still webapps., including mine, (oops again some change (good change), you'll like to note, is that if you uninstalled just as i have done, your webroot folder might not have been deleted from C:\www. however this has changed and now there is vhost\localhost. so if you are starting a new project or site in dreamweaver of PHP designer which i use, point to the appropriate document folder, or else youll get this annoying message all the time saying file could not be found although its there but you've put it in the wrong place. what i mean is webroot no longer exists.)

10. I made another cup of cappuccino, and enjoyed the rest of the night doing the easy bit, writing up the code and hmmmmmmm its nice.

hope i was dumm enough!, as off now, no errors, i have not come accross issues yet, everything seems to smile. (Sue me if any of this is wrong, and youll end up paying the cheque :-)    )
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!