DeveloperSide.NET Forums
July 21, 2019, 06:28:33 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: sigterm  (Read 11685 times)
0 Members and 1 Guest are viewing this topic.
natcolley
Customer, Basic Support
Jr. Member
*****
Posts: 69


View Profile WWW
« on: February 12, 2008, 02:28:41 AM »

I wanted to run a web based crm called Sugar on my laptop. I had earlier tried a different crm called vtiger which came with it's own stack because it didn't run with php 5.2. However, after it supposedly installed I got nothing and no help from the website so I uninstalled. I suspect it did something to php.ini even though they were supposedly in separate directories. So tonight I re-installed 1.95 in order to put Sugar on, but the WD controller tells me Apache has an error[1]. The logs look fine until the last line
Code:
[Mon Feb 11 19:43:13 2008] [notice] ModSecurity for Apache 2.1.0 configured
[Mon Feb 11 19:43:28 2008] [notice] Apache/2.2.4 (Win32) mod_ssl/2.2.4 OpenSSL/0.9.8e mod_fastcgi/mod_fastcgi-SNAP-0404142202 PHP/5.2.1 mod_perl/2.0.3 Perl/v5.8.8 configured -- resuming normal operations
[Mon Feb 11 19:43:28 2008] [notice] Server built: Mar 20 2007 13:02:00
[Mon Feb 11 19:43:28 2008] [notice] Parent: Created child process 2080
[Mon Feb 11 19:43:31 2008] [notice] ModSecurity for Apache 2.1.0 configured
[Mon Feb 11 19:43:33 2008] [notice] Child 2080: Child process is running
[Mon Feb 11 19:43:33 2008] [notice] Child 2080: Acquired the start mutex.
[Mon Feb 11 19:43:33 2008] [notice] Child 2080: Starting 250 worker threads.
[Mon Feb 11 19:43:33 2008] [notice] FastCGI: process manager initialized
[Mon Feb 11 19:43:33 2008] [notice] Child 2080: Starting thread to listen on port 443.
[Mon Feb 11 19:43:33 2008] [notice] Child 2080: Starting thread to listen on port 80.
Terminating on signal SIGTERM(15)

Ideas? Thx.
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: February 12, 2008, 03:14:09 PM »

I checked their website and it does look like vtiger comes with the entire Apache/PHP/MySQL stack.

Something was probably not removed/undone with the un-installation.

Check the System PATH... Make sure there is nothing there pointing to vtiger.

You will probably also need to remove the Suite, remove php.ini and my.ini from C:\Windows, and reinstall. Make sure C:\my or my.cnf does not exist.

Aside from that, there are registry settings that could have been modified to point to different php.ini/my.ini locations. Check the most common problems thread in the public forum.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
natcolley
Customer, Basic Support
Jr. Member
*****
Posts: 69


View Profile WWW
« Reply #2 on: February 12, 2008, 06:58:14 PM »

Thx. Even more reason not to use them.... :-(
Logged
natcolley
Customer, Basic Support
Jr. Member
*****
Posts: 69


View Profile WWW
« Reply #3 on: February 12, 2008, 11:27:22 PM »

I have Apache running, at least for now, and joomla and wordpress come up as they should, but for SugarCRM I get 'not found'. It is on the webapps folder with all the others. I'm sorry to bother you with this again. I'm sure it's something simple like .htaccess or a conf file, but I don't know which. I didn't have this problem when I added a program to the suite on my webserver. Ideas? Thx.
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #4 on: February 13, 2008, 03:08:43 PM »

Sounds like you might have not aliased the SugarCRM directory to a URL... Check any of the config files under...
C:\www\Apache22\conf\extra\vhosts\localhost\
...for examples.

Also note that making a new config file under this dir, will only apply it to localhost, and not to any other vhosts.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #5 on: February 13, 2008, 03:12:16 PM »

Looking over things again, the above only applies to suite v2.00, v1.95 used the old config structure... I think the configs for webapps were under C:\www\Apache22\conf\Suite-extra\ and included in from components.conf?
« Last Edit: February 13, 2008, 06:01:10 PM by admin » Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
natcolley
Customer, Basic Support
Jr. Member
*****
Posts: 69


View Profile WWW
« Reply #6 on: February 13, 2008, 04:07:38 PM »

Yes, of course, you're right. The reason I didn't have this problem on the web server is that I set up the new program as a subdirectory of an existing, known web app. So I have made the config file and added sugar to compenents.conf, and now it is 'forbidden', not 'not found'. I consider this progress! ;-). I'll keep poking around, starting with htaccess and report back, but if you see this and know the answer right away, feel free to save me the effort.
Logged
natcolley
Customer, Basic Support
Jr. Member
*****
Posts: 69


View Profile WWW
« Reply #7 on: February 13, 2008, 04:36:01 PM »

I guess my memory of htaccess is confused because of the way I set up the web server. There doesn't seem to be a relevant htaccess to change here. Here is my conf:
Code:
Alias /SugarCRM "/www/webapps/SugarCRM"

<Directory "/www/webapps/SugarCRM">
Options None
AllowOverride None

order allow,deny
allow from 127.0.0.1
# allow from all

AddType text/html .php
AddHandler application/x-httpd-php .php
</Directory>

allow from 127.0.0.1 should work on localhost, shouldn't it? But this is the error I got:

Code:
[Wed Feb 13 10:04:26 2008] [error] [client 127.0.0.1] Directory index forbidden by Options directive: C:/www/webapps/SugarCRM/install/

But I took the # off 'allow from all' restarted apache (do I need to keep restarting mysql too?) and it is still forbidden. So I'm confused. It must be in the option 'none', but that's the same option I copied over from joomla. What gives?
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #8 on: February 13, 2008, 06:04:14 PM »

It looks like /www/webapps/SugarCRM/ does not contain an index.html or index.php file...  So Apache is defaulting to displaying the "index" of that directory.. But that is forbbiden by Options None'.

Change to...
Options All
AllowOverride All

Restart Apache. See if that improves the situation.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!