DeveloperSide.NET Forums
December 06, 2019, 04:01:41 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: More Directory Blocks needed?  (Read 23895 times)
0 Members and 1 Guest are viewing this topic.
jamescarvin
Member
*
Posts: 17


View Profile Email
« on: April 16, 2008, 07:38:31 PM »

I am unable to get my extra drupal development sites working on my localhost.

I've got my extra development sites located at C:/www/webapps/drupal/sites/sitenames

I am getting a permission not granted error when going to http://SITENAMES

Do I have to add additional directory blocks onto C:/www/apache22/conf/httpd.config on top of the two directory blocks web developer already put in?

I'm really confused about file paths. Try to make this basic for me. I'm a new drupal user, new apache user, new php/mysql and not a sys administrator. I have windows xp home sp2.

Apache error log is giving me [Wed Apr 16 14:21:18 2008] [error] [client 127.0.0.1] client denied by server configuration: C:/www/webapps/drupal/sites/SITENAMES

(I've set up eight drupal sites as per http://drupal.org/node/120647 , and I get the same error for all eight so just replace SITENAMES with the actual names of each site.)

Included in my httpd.conf file is the following …

Quote
<VirtualHost *:80>
DocumentRoot /www/webapps/drupal/sites/SITENAME1
ServerName SITENAME1
</VirtualHost>

<VirtualHost *:80>
DocumentRoot /www/webapps/drupal/sites/SITENAME2
ServerName SITENAME2
</VirtualHost>

etc … for the eight sites I’ve created in drupal

That seems ok to me. But since I'm still getting errors, I figured maybe it that I needed another directory block, as per http://wiki.apache.org/httpd/ClientDeniedByServerConfiguration
which says
Quote
You need a <Directory> block for every folder outside of your DocumentRoot

Here is my current directory block info. web developer gave me two as it installed apache …

Quote
<Directory />
    Options FollowSymLinks
    AllowOverride All
    Order deny,allow
    Deny from all
    Satisfy all
</Directory>

<Directory /www/vhosts/localhost>
    Options Indexes FollowSymLinks
    Order allow,deny
    Allow from all
</Directory>

I really don't understand file paths. Do I need another directory block to cover the additional sitesnames?

Would you suspect my errors are being caused by something else?

Any help would be deeply appreciated!

Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: April 16, 2008, 08:02:54 PM »

Try adding...
Code:
<Directory /www/webapps/drupal>
    Options Indexes FollowSymLinks
    Order allow,deny
    Allow from all
</Directory>
...somewhere in httpd.conf. Restart Apache.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
jamescarvin
Member
*
Posts: 17


View Profile Email
« Reply #2 on: April 16, 2008, 09:05:04 PM »

That's interesting. I applied that and my error log message changed slightly to …
Quote
[error] [client 127.0.0.1] Directory index forbidden by Options directive: C:/www/webapps/drupal/sites/

That sparked some encouragement, so I tried some variations on the directory block. First …
Quote
<Directory /www/webapps
    Options Indexes FollowSymLinks
    Order allow,deny
    Allow from all
</Directory>

This resulted in …

Quote
[error] [client 127.0.0.1] client denied by server configuration: C:/www/webapps/drupal/sites/
This was the kind of error message I had been having before, only it was missing the SITENAME that usually came with it.

Curious, next I tried …
Quote
<Directory /www/webapps/drupal/sites>
    Options Indexes FollowSymLinks
    Order allow,deny
    Allow from all
</Directory>

This was the first time I had ever seen anything other than an error at http://SITENAME. (Whoohoo- after 5 weeks of attempts! - finally I got a development site to see!) Sort of. It listed the contents at the directory - not just the site I wanted when I typed in the site name I was looking for at http://SITENAME so lastly I tried …

Quote
<Directory /www/webapps/drupal/sites/*>
    Options Indexes FollowSymLinks
    Order allow,deny
    Allow from all
</Directory>

This produced the same exact results as the previous try. I suppose you can't use *nix paths on a windows system. Anyhoo - I think what I'm trying to see is s drupal log in page, but instead I'm getting the directory list for drupal/sites.

Boy, I sure wish there were some plain instructions for a plain old guy like me, just starting out. You were doing well. Do you happen to have any other ideas?
 
« Last Edit: April 16, 2008, 10:47:37 PM by jamescarvin » Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #3 on: April 17, 2008, 12:53:06 PM »

Try this, make sure to restart Apache.
Code:
<Directory /www/webapps/drupal>
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #4 on: April 17, 2008, 12:55:18 PM »

It also sounds like you have another similar directory block somewhere further down in your configuration that is overriding this one...
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
jamescarvin
Member
*
Posts: 17


View Profile Email
« Reply #5 on: April 17, 2008, 03:50:48 PM »

I'm not sure what the similar directory might be that is overriding so I'll give you a list of everything I've currently got.

At this point, having troubleshot extensively, I have in my C:/www/apache22/conf/httpd.conf

Quote
<Directory />
    Options FollowSymLinks
    AllowOverride All
    Order deny,allow
    Deny from all
    Satisfy all
</Directory>

<Directory /www/vhosts/localhost>
    Options Indexes FollowSymLinks
    Order allow,deny
    Allow from all
</Directory>

<Directory /www/webapps/drupal/sites>
    Options Indexes FollowSymLinks
    Order allow,deny
    Allow from all
</Directory>

Those are the directory blocks, and then there are the VirtualHost Blocks, which seem to be just as relevant. Currently I have …

Quote
<VirtualHost *:80>
DocumentRoot /www/webapps/drupal/sites/SITENAME1
ServerName SITENAME1
</VirtualHost>

<VirtualHost *:80>
DocumentRoot /www/webapps/drupal/sites/SITENAME2
ServerName SITENAME2
</VirtualHost>

In each case, the SITENAME is just the name of the directory where I keep all the files, including the settings.php file which is supposed to run it. I do not place www. before the SITENAME or ".tld" afterwards as shown in the examples I've seen. When I try any combination of this it results in "File Not Found" (yes, I've tried just about everything). So my current configuration at least gives me directory lists, which I think are pointing to the right files?

This same file also has an include file pointing to C:/www.apache22/conf/extra/httpd-vhosts.conf - upon which I also have VirtualHost blocks

Quote
Include conf/extra/httpd-vhosts.conf

So moving over to that file, I currently do not have any Directory Blocks there . No one has suggeted I add any. But I do have VirtualHost blocks there that say …

Quote
<VirtualHost *:80>
    DocumentRoot /www/webapps/drupal/sites/SITENAME1
    ServerName SITENAME1
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot /www/webapps/drupal/sites/SITENAME2
    ServerName SITENAME2
</VirtualHost>

And among the VirtualHost blocks I also have one in this extras file that came with the web developer suite preset as follows …

Quote
<VirtualHost *:80>
   DocumentRoot /www/vhosts/localhost/
   ServerName localhost
   Include conf/extra/vhosts/localhost/*.conf
</VirtualHost>

(And, of course, I've taken care of informing Windows at Windows/System32/Drivers/Etc/Hosts of the IP for each SITNAME).

That's what I've got at this point.

You (web developer Admin) suggested I try …

Quote
<Directory /www/webapps/drupal>
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>

1. Adding this to the C:/www/apache22/conf/httpd.conf file without replacing any other directory blocks results in the directory list for SITENAME showing up when trying http://SITENAME

2. Keeping it and replacing the current directory block …

Quote
<Directory /www/webapps/drupal/sites>
    Options Indexes FollowSymLinks
    Order allow,deny
    Allow from all
</Directory>

… results in same directory list showing up at http://SITENAME

Naturally, I'm turning apache off/on after every test.

Well, at least I'm not getting permission denial. This post pretty much lists everything relevant I can think of.

I suspect that I should not be pointing to /www/webapps/drupal/sites/SITENAME but just to www/webapps/drupal in all cases, but that results in permission not granted. That would be ok, if I had permission, which perhaps I am not getting because the settings.php file is either giving the wrong user name/password for the MySQL db or because it is pointing to the wrong db.

I won't post passwords on a public forum. But regarding that, I did have a successful drupal installation after my last installation of web developer. I played around with the root drupal site configuration until I had it the way I wanted it, and then I went to phpMyAdmin and copied the drupal db, creating duplicate dbs for all my site names with the following MySQL command…

Quote
GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, INDEX, ALTER, CREATE TEMPORARY TABLES, LOCK TABLES ON databasename.* TO 'admin'@'localhost' IDENTIFIED BY 'superpw';
FLUSH PRIVILEGES;

I replaced "databasename" with the name of the SITENAME db I was creating. And to keep things simple (I thought) I decided I would make all my SITENAMEs the same as my db names. I also used the same username and password - replacing "admin" with my user name and replacing "superpw" with my password.

It may be this last fact that has me locked out for some reason when using the standard /www/webapps/drupal pointer for both directory blocks and VirtualHost blocks.

Before testing new passwords, however, and going back to all VirtualHost pointers going to /www/webapps/drupal on both config files mentioned above, I now get what is almost an encouraging result:

Quote
<?php // $Id: index.php,v 1.91 2006/12/12 09:32:18 unconed Exp $ /** * @file * The PHP page that serves all page requests on a Drupal installation. * * The routines here dispatch control to the appropriate handler, which then * prints the appropriate page. */ require_once './includes/bootstrap.inc'; drupal_bootstrap(DRUPAL_BOOTSTRAP_FULL); $return = menu_execute_active_handler(); // Menu status constants are integers; page content is a string. if (is_int($return)) { switch ($return) { case MENU_NOT_FOUND: drupal_not_found(); break; case MENU_ACCESS_DENIED: drupal_access_denied(); break; case MENU_SITE_OFFLINE: drupal_site_offline(); break; } } elseif (isset($return)) { // Print any value (including an empty string) except NULL or undefined: print theme('page', $return); } drupal_page_footer();

It's about the weirdest looking page error I've seen in awhile.

Any thoughts?

« Last Edit: April 17, 2008, 05:31:55 PM by jamescarvin » Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #6 on: April 17, 2008, 09:28:29 PM »

1) Don't duplicate the Virtual Hosts block in both httpd.conf and httpd-vhosts.conf. They should only go into httpd-vhosts.conf.

2) After removing them from httpd.conf, also remove the same VH blocks from httpd-vhosts.conf and replace them with...
Code:
<VirtualHost *:80>
DocumentRoot /www/webapps/drupal/
ServerName SITENAME1
ServerAlias SITENAME2 SITENAME3 SITENAME4

<Directory /www/webapps/drupal>
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>

</VirtualHost>

Remove the other changes you have done.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
jamescarvin
Member
*
Posts: 17


View Profile Email
« Reply #7 on: April 17, 2008, 10:39:23 PM »

Thank you.
1. I have now deleted all VirtualHost blocks from apache22/conf/httpd.conf
2. I have now deleted all the duplicated VirtualHost blocks from apache22/conf/extra/httpd-vhost.conf
3. I have added in the snippet you gave …

Quote
<VirtualHost *:80>
DocumentRoot /www/webapps/drupal/
ServerName SITENAME1
ServerAlias SITENAME2 SITENAME3 SITENAME4

<Directory /www/webapps/drupal>
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>

</VirtualHost>

4. Stop/start apache

Result: I am getting the same weird browser message as before …

Quote
<?php // $Id: index.php,v 1.91 2006/12/12 09:32:18 unconed Exp $ /** * @file * The PHP page that serves all page requests on a Drupal installation. * * The routines here dispatch control to the appropriate handler, which then * prints the appropriate page. */ require_once './includes/bootstrap.inc'; drupal_bootstrap(DRUPAL_BOOTSTRAP_FULL); $return = menu_execute_active_handler(); // Menu status constants are integers; page content is a string. if (is_int($return)) { switch ($return) { case MENU_NOT_FOUND: drupal_not_found(); break; case MENU_ACCESS_DENIED: drupal_access_denied(); break; case MENU_SITE_OFFLINE: drupal_site_offline(); break; } } elseif (isset($return)) { // Print any value (including an empty string) except NULL or undefined: print theme('page', $return); } drupal_page_footer();

I should say here that I'm not sure I did the alias's right. But then, neither does the SITNAME I entered for SITENAME1 - which was not an alias, work quite right. For that, the gobbledy message looks about the same …

Quote
<?php // $Id: index.php,v 1.91 2006/12/12 09:32:18 unconed Exp $ /** * @file * The PHP page that serves all page requests on a Drupal installation. * * The routines here dispatch control to the appropriate handler, which then * prints the appropriate page. */ require_once './includes/bootstrap.inc'; drupal_bootstrap(DRUPAL_BOOTSTRAP_FULL); $return = menu_execute_active_handler(); // Menu status constants are integers; page content is a string. if (is_int($return)) { switch ($return) { case MENU_NOT_FOUND: drupal_not_found(); break; case MENU_ACCESS_DENIED: drupal_access_denied(); break; case MENU_SITE_OFFLINE: drupal_site_offline(); break; } } elseif (isset($return)) { // Print any value (including an empty string) except NULL or undefined: print theme('page', $return); } drupal_page_footer();

I will enter here a comment that I got from someone in the drupal groups multisites forum. (S)he said …

Quote
'all http requests to Drupal have to run through index.php' by Michael Hofmockel

Being able to index the sites directory is not good (not secure).


All http requests to Drupal have to run through index.php
Pointing your VirtualHost (directly or indirectly) to anything but
index.php is incorrect.


Did you create your sites as subdirectories?  I suspect you did.
If you created as subdirectories (example.com/site2), then you would
get an error if you have not created a symbolic link.  You can solve
that error by creating a symbolic link.  From line command (ln -s .
site2).  This is in the install instructions.


Did you create your sites as subdomains?
If you created as subdomains (site2.example.com), then you would also
get an error if you have not registered the subdomain.  Go register your
subdomain with your Domain Name Server provider (you can do this from
CPanel).

That's next on my to-do list. I'll come back and edit this post to let you know how it went.
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #8 on: April 17, 2008, 11:31:43 PM »

/www/webapps/drupal/ points to index.php so you are okay with that.

And the other problem is a problem with PHP not being active... The way the suite is set up is for PHP to be turned on for \www\vhosts\, not for \www\webapps\drupal... So just edit that VH block, and within the Dir block for /www/webapps/drupal/ add lines...
Code:
AddType text/html .php .phps
AddHandler application/x-httpd-php .php
AddHandler application/x-httpd-php-source .phps

That should fix things.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
jamescarvin
Member
*
Posts: 17


View Profile Email
« Reply #9 on: April 18, 2008, 03:57:05 AM »

Admin said …
Quote
The way the suite is set up is for PHP to be turned on for \www\vhosts\, not for \www\webapps\drupal... So just edit that VH block, and within the Dir block for /www/webapps/drupal/ add lines...

Code:
      AddType text/html .php .phps
      AddHandler application/x-httpd-php .php
      AddHandler application/x-httpd-php-source .phps

Maybe I'm just too blurry eyed to think at this point. I sense I'm almost there. But now I need you to disambiguate. When you say "Just edit that VH block" which VH block are you referring to? And edit it how? Are you saying change it from /www/vhosts to www/webapps/drupal?

or are you saying change it from www/webapps/drupal to /www/vhosts ?

And then you said …
Quote
and within the Dir block for /www/webapps/drupal/ add lines...

Code:
      AddType text/html .php .phps
      AddHandler application/x-httpd-php .php
      AddHandler application/x-httpd-php-source .phps

Which VH block are you referring to? The only VH block I have pointing to vhosts is …
Quote
<VirtualHost *:80>
   DocumentRoot /www/vhosts/localhost/
   ServerName localhost
   Include conf/extra/vhosts/localhost/*.conf
</VirtualHost>

So changing this to …
Quote
<VirtualHost *:80>
   DocumentRoot /www/webapps/drupal
   ServerName localhost
   Include conf/extra/vhosts/localhost/*.conf
</VirtualHost>

and changing

Quote
<VirtualHost *:80>
DocumentRoot /www/webapps/drupal/
ServerName jdc
ServerAlias remlm crn drabble ukrain elijah sanmiguel stmich

<Directory /www/webapps/drupal>
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>

</VirtualHost>



into this …
Quote
<VirtualHost *:80>
DocumentRoot /www/webapps/drupal/
ServerName jdc
ServerAlias remlm crn drabble ukrain elijah sanmiguel stmich

<Directory /www/webapps/drupal>
Options All
AllowOverride All
Order allow,deny
Allow from all
      AddType text/html .php .phps
      AddHandler application/x-httpd-php .php
      AddHandler application/x-httpd-php-source .phps
</Directory>

</VirtualHost>

That's how I read you. Maybe I shouldn't try this when I'm half asleep but apache stop/start and the result is …

"Welcome to your new Drupal Site!"


YEEEEEEEEEEEEEEEHAAAAAAAAAAAAWWWWWWWWWWWWW!!!!!

Only one problem. Soon as I click on any link on that page I get another error. So all my woes are not behind me. The new error is a 500 for which the error log says …


Quote
[Fri Apr 18 00:40:17 2008] [error] [client 127.0.0.1] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://SITENAME/
[Fri Apr 18 00:42:37 2008] [error] [client 127.0.0.1] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

I see a few google look ups discussing this type of recursion problem and various solutions that involve php coding. I suspect that I shouldn't have to change too much, since I never messed with any php files to begin with, but you'll certainly make a liar out of all those people who told me I didn't have to know php to do this, if you tell me I've got to modify the .htaccess file or something.

Now, by the way, the file http://localhost/drupal is working just fine. This error only happens at http://SITENAME (where SITENAME is one of my sites).
« Last Edit: April 18, 2008, 05:32:58 AM by jamescarvin » Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #10 on: April 18, 2008, 11:41:16 AM »

No. Don't edit the localhost VH [the one that points to /www/vhosts/localhost].

And those errors would usually be a result of a problem with an .htaccess file, or rewrite rules to be more specific.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
jamescarvin
Member
*
Posts: 17


View Profile Email
« Reply #11 on: April 18, 2008, 04:44:23 PM »

OK, I've changed back the www/vhosts/localhost to www/webapps/drupal and I still get the good result of "Welcome to your new druapl site!"

But I still have the recursive redirect error. So as to the .htacsss file - I wonder how it could be bad, when I've never touched it?

Is it possible that, as one googled post says, I should have a separate htaccess file for each of my local sites?

At this point, what I have is what came with web developer (I think). It is located in /www/webapps/drupal/

It reads …
Quote
#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch "\.(engine|inc|info|install|module|profile|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)$|^(code-style\.pl|Entries.*|Repository|Root|Tag|Template)$">
  Order allow,deny
</FilesMatch>

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Customized error messages.
ErrorDocument 404 /index.php

# Set the default handler.
DirectoryIndex index.php

# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1.
<IfModule mod_php4.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 4, Apache 2.
<IfModule sapi_apache2.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# Requires mod_expires to be enabled.
<IfModule mod_expires.c>
  # Enable expirations.
  ExpiresActive On
  # Cache all files for 2 weeks after access (A).
  ExpiresDefault A1209600
  # Do not cache dynamically generated pages.
  ExpiresByType text/html A1
</IfModule>

# Various rewrite rules.
<IfModule mod_rewrite.c>
  RewriteEngine on

  # If your site can be accessed both with and without the 'www.' prefix, you
  # can use one of the following settings to redirect users to your preferred
  # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
  #
  # To redirect all users to access the site WITH the 'www.' prefix,
  # (http://example.com/... will be redirected to http://www.example.com/...)
  # adapt and uncomment the following:
  # RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
  # RewriteRule ^(.*)$ http://www.example.com/$1 [L,R=301]
  #
  # To redirect all users to access the site WITHOUT the 'www.' prefix,
  # (http://www.example.com/... will be redirected to http://example.com/...)
  # adapt and uncomment the following:
  # RewriteCond %{HTTP_HOST} ^www\.example\.com$ [NC]
  # RewriteRule ^(.*)$ http://example.com/$1 [L,R=301]

  # Modify the RewriteBase if you are using Drupal in a subdirectory and
  # the rewrite rules are not working properly.
  RewriteBase /drupal

  # Rewrite old-style URLs of the form 'node.php?id=x'.
  #RewriteCond %{REQUEST_FILENAME} !-f
  #RewriteCond %{REQUEST_FILENAME} !-d
  #RewriteCond %{QUERY_STRING} ^id=([^&]+)$
  #RewriteRule node.php index.php?q=node/view/%1 [L]

  # Rewrite old-style URLs of the form 'module.php?mod=x'.
  #RewriteCond %{REQUEST_FILENAME} !-f
  #RewriteCond %{REQUEST_FILENAME} !-d
  #RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
  #RewriteRule module.php index.php?q=%1 [L]

  # Rewrite current-style URLs of the form 'index.php?q=x'.
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
</IfModule>

# $Id: .htaccess,v 1.81.2.3 2007/09/21 12:24:22 drumm Exp $
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #12 on: April 19, 2008, 03:32:20 AM »

Try commenting out line [add a # in the front]...
RewriteBase /drupal

Also, I think there is a suite-drupal.conf file somewhere under \www\Apache22\conf\extra [or one of the sub-directories], delete it. We are basically doing everything it did, and it could be messing something up.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
jamescarvin
Member
*
Posts: 17


View Profile Email
« Reply #13 on: April 19, 2008, 05:36:31 AM »

Tiny change. Huge difference …
RewriteBase /drupal
is now
 # RewriteBase /drupal

And the site no longer produces errors. Voilΰ!

Copiously predigious thanks and accolades to you for your patience with me in this, my friend!

James Carvin
561-459-5690 (o)
561-310-7990 (m)

P.S. I don't see the suite-drupal.conf file you are referring to. Not sure if I already deleted it. Thanks so much for your help!!
« Last Edit: April 19, 2008, 05:45:05 AM by jamescarvin » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!