DeveloperSide.NET Forums
May 25, 2020, 09:18:59 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Cgi-bin  (Read 19453 times)
0 Members and 1 Guest are viewing this topic.
Anonymous
Guest
« on: August 25, 2003, 06:50:51 PM »

Im curious where to put my cgi files, i installed the files to c:\www\
and all my docs are in c:\www\webroot but where do i stick my cgi files, and what would be the path thing for it (#!/usr/bin/perl) ??? sorry if im not making to much since.
                        thanks Kevin
Logged
Anonymous
Guest
« Reply #1 on: August 25, 2003, 08:17:08 PM »

Add this to /www/Apache2/conf/httpd.conf

ScriptAlias /cgi-bin/ "/www/cgi-bin/"

<Directory "/www/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>

And create the cgi-bin dir directly under /www/
Logged
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #2 on: August 26, 2003, 04:40:17 PM »

to be safe you can store them let say at c:\cgi-bin and chanche the path in the config
Logged

Anonymous
Guest
« Reply #3 on: August 27, 2003, 09:29:30 AM »

Add this to /www/Apache2/conf/httpd.conf

ScriptAlias /cgi-bin/ "/www/cgi-bin/"

<Directory "/www/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

And create the cgi-bin dir directly under /www/


________________________________________________


I try it , but it is not work !
How can i do it ?
Where to put the cgi-bin file ?
THX
Logged
Anonymous
Guest
« Reply #4 on: August 27, 2003, 09:35:02 AM »

Add ScriptAlias /cgi-bin/ "/www/cgi-bin/" to httpd.conf,
then apache is not start

the error is :

Syntax error on line 114 of C:/www/Apache2/conf/httpd.conf:
Invalid comand 'ScriptAlias'. perhaps mis-spelled or defined by a module not included in the server configuration

 :?:
Logged
Anonymous
Guest
« Reply #5 on: August 27, 2003, 04:24:46 PM »

#LoadModule alias_module modules/mod_alias.so

Uncomment the above line in httpd.conf, and restart apache.
Uncomment by taking out the '#'
Logged
Anonymous
Guest
« Reply #6 on: August 27, 2003, 04:26:58 PM »

ScriptAlias /cgi-bin/ "/www/cgi-bin/"

and the above has a space between '/cgi-bin/' and  '"/www/cgi-bin/"', if you did not notice.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!