DeveloperSide.NET Forums
July 06, 2020, 05:14:35 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: 1 [2]
  Print  
Author Topic: noob tutorial needed  (Read 29214 times)
0 Members and 1 Guest are viewing this topic.
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #15 on: May 21, 2004, 05:52:41 PM »

ok,
open op the command promt again(run->cmd)
cd to the folder where .htaccess.txt is
when your there,
type:
rename .htaccess.txt .htaccess
it should now hopefully work
Logged

jboy
Jr. Member
**
Posts: 39


View Profile
« Reply #16 on: May 22, 2004, 02:58:25 AM »

Still didn't work, Im going to start over from the begining unless you have a better Idea. Im sure its something ive done wrong....thanks for all the help....let me know if you can think of anything else.
Logged
jboy..
Guest
« Reply #17 on: May 22, 2004, 04:49:55 AM »

Ive messed around with the code and files, I cant even get a error its like the htpasswd and htaccess are not reconized by the apache, the website opens up and runs great. any ideas
Logged
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #18 on: May 22, 2004, 07:44:47 AM »

yes, open op you htttpd.conf file and look for:
Code:

<Directory />
    ...
</Directory>

then add:
Code:

AuthUserFile E:\www\Apache2\Conf\.htpasswd
AuthName Webroot
AuthType Basic
require valid-user

above the </Directory> tag.

btw make sure to make a backup just in case
Logged

jboy..
Guest
« Reply #19 on: May 22, 2004, 03:46:17 PM »

I think im finaly getting somewhere I didnt get the pass word to work but I did get a error {this page cannot be found} It the first timethe web page didnt open . this is what the file looked like before

<Directory />
   Options FollowSymLinks
   AllowOverride All
   order allow,deny
   deny from all
</Directory>


<Directory "/www/webroot">
   order allow,deny
   allow from all
</Directory>


<IfModule mod_cgi.c>
   <IfModule mod_alias.c>
      ScriptAlias /cgi-bin/ "/www/cgi-bin/"
   </IfModule>

   <Directory "/www/cgi-bin">
      Options None
      AllowOverride None
      order allow,deny
      allow from all
   </Directory>
</IfModule>


<IfModule mod_alias.c>
   Alias /phpMyAdmin "/www/phpMyAdmin"
</IfModule>

<Directory "/www/phpMyAdmin">
   Options None
   AllowOverride None
   order deny,allow
   deny from all
   allow from 127.0.0.1
</Directory>


<Directory "/www/webroot/stats">
   order deny,allow
   deny from all
   allow from 127.0.0.1
</Directory>


And this is what it looked like after I put In the code

</Location>


<Directory />
   Options FollowSymLinks
   AllowOverride All
   order allow,deny
   deny from all
       
        AuthUserFile E:\www\Apache2\Conf\.htpasswd
        AuthName Webroot
        AuthType Basic
        require valid-user

</Directory>


<Directory "/www/webroot">
   order allow,deny
   allow from all
</Directory>


<IfModule mod_cgi.c>
   <IfModule mod_alias.c>
      ScriptAlias /cgi-bin/ "/www/cgi-bin/"
   </IfModule>

   <Directory "/www/cgi-bin">
      Options None
      AllowOverride None
      order allow,deny
      allow from all
   </Directory>
</IfModule>


<IfModule mod_alias.c>
   Alias /phpMyAdmin "/www/phpMyAdmin"
</IfModule>

<Directory "/www/phpMyAdmin">
   Options None
   AllowOverride None
   order deny,allow
   deny from all
   allow from 127.0.0.1
</Directory>


<Directory "/www/webroot/stats">
   order deny,allow
   deny from all
   allow from 127.0.0.1
</Directory>

I know I probable but it In the wrong place  If you see anything wrong let me know.....thanks again
Logged
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #20 on: May 22, 2004, 04:24:32 PM »

ok your conf i a bit diferent fro mmine so that probebly why you get and erro page not found instead of a password box try this:
Code:

<Directory />
Options FollowSymLinks
AllowOverride All
order allow,deny
deny from all
</Directory>

<Directory "/www/webroot">
order allow,deny
allow from all


AuthUserFile E:\www\Apache2\Conf\.htpasswd
AuthName Webroot
AuthType Basic
require valid-user

</Directory>

<IfModule mod_cgi.c>
<IfModule mod_alias.c>
ScriptAlias /cgi-bin/ "/www/cgi-bin/"
</IfModule>

<Directory "/www/cgi-bin">
Options None
AllowOverride None
order allow,deny
allow from all
</Directory>
</IfModule>

<IfModule mod_alias.c>
Alias /phpMyAdmin "/www/phpMyAdmin"
</IfModule>

<Directory "/www/phpMyAdmin">
Options None
AllowOverride None
order deny,allow
deny from all
allow from 127.0.0.1
</Directory>

<Directory "/www/webroot/stats">
order deny,allow
deny from all
allow from 127.0.0.1
</Directory>
Logged

jboy,
Guest
« Reply #21 on: May 22, 2004, 05:12:25 PM »

When I put the code in the website will not open when I take it out it opens right up
Logged
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #22 on: May 22, 2004, 05:34:16 PM »

hmmz ok,
leave it out and chekc your pm, there is somthign there that will help(i hope)
Logged

jboy
Jr. Member
**
Posts: 39


View Profile
« Reply #23 on: May 22, 2004, 07:52:26 PM »

Ran in to a few problems and im reinstalling windows 2000 (starting fresh). I do have a couple of questions about the program in one part asks you for the realm (think thats what its called) and do I need to make the htpasswd and htaccess files again or will the program make it. and one more question  it ask for a ip address. Is it the ip asigned to my lancard the ip from my router? i have dsl so the ip changes every 10 min so i use dynamic  dns from dynu, thanks
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #24 on: May 22, 2004, 07:58:04 PM »

You have not told Apache to pick up the .htaccess files...


Code:

AccessFileName .htaccess

<Files ~ "^\.htaccess$">
Order allow,deny
Deny from all
</Files>


If you search the forums with search term "htaccess" you will get several threads on how to do what you are asking.

And have you uncommented(removed '#')...

Code:

LoadModule auth_module modules/mod_auth.so


...under httpd.conf?
"AuthUserFile" needs that module loaded, and by default it is commented out.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
jboy
Jr. Member
**
Posts: 39


View Profile
« Reply #25 on: May 22, 2004, 09:12:41 PM »

admin, I think your forgeting i am a noob to to all this ,cmd ,scripts, and everything else in this forum
Logged
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #26 on: May 22, 2004, 09:30:30 PM »

ok add:
Code:

AccessFileName .htaccess

<Files ~ "^\.htaccess$">
Order allow,deny
Deny from all
</Files>

some where in the htttpd.conf file(at the back)
then look for:
Code:

#LoadModule auth_module modules/mod_auth.so

and change it into
Code:

LoadModule auth_module modules/mod_auth.so
Logged

jboy-
Guest
« Reply #27 on: May 23, 2004, 01:20:05 AM »

I did everything I was told "i think" and when I try to bring up the web page I get  "page can't be found" The page comes right up with the default code so I must have put somthing in the wrong place here is the code


<Location />
   <IfModule mod_deflate.c>
      AddOutputFilterByType DEFLATE text/html text/plain text/css
      <IfModule mod_headers.c>
         Header append Vary User-Agent
      </IfModule>
   </IfModule>
</Location>


<Directory />
   Options FollowSymLinks
   AllowOverride all
   order allow,deny
   deny from all
</Directory>


<Directory "/www/webroot">
   order allow,deny
   allow from all

AuthUserFile c:\www\Apache2\Conf\.hdpasswd
AuthName Webroot
AuthType Basic
require valid-user

</Directory>

AccessFileName .htaccess

<Files ~ "^\.htaccess$">
Order allow,deny
Deny from all
</Files>  

<IfModule mod_cgi.c>
   <IfModule mod_alias.c>
      ScriptAlias /cgi-bin/ "/www/cgi-bin/"
   </IfModule>

   <Directory "/www/cgi-bin">
      Options None
      AllowOverride None
      order allow,deny
      allow from all
   </Directory>
</IfModule>


<IfModule mod_alias.c>
   Alias /phpMyAdmin "/www/phpMyAdmin"
</IfModule>

<Directory "/www/phpMyAdmin">
   Options None
   AllowOverride None
   order deny,allow
   deny from all
   allow from 127.0.0.1
</Directory>


<Directory "/www/webroot/stats">
   order deny,allow
   deny from all
   allow from 127.0.0.1
</Directory>


<IfModule mod_log_config.c>
   LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-agent}i\"" combined
   CustomLog logs/access.log combined
   <IfModule mod_deflate.c>
      DeflateFilterNote Input instream
      DeflateFilterNote Output outstream
      DeflateFilterNote Ratio ratio
      LogFormat '"%r" %{outstream}n/%{instream}n (%{ratio}n%%)' deflate
      CustomLog logs/deflate.log deflate
   </IfModule>
</IfModule>

and i did take the # off the line of code any Ideas....And im not crying theise are tears of joy because this is so much fun....lol
Logged
jboy
Jr. Member
**
Posts: 39


View Profile
« Reply #28 on: May 23, 2004, 03:43:54 AM »

Yaaaayyyy It works I did everything you told me{it took my noob mind a few days to figure it out} and removed all the # on anything that said auth  restarted and it works great!!!!!!  Thanks Jorge I couldnt have done it without you and thanks admin. And if any other noob read this post before you install dont worry the software works great out of the box. it was code 4 the password that slowed me down but this forum has great people that are willing to help you even if your a noob like me.


Thank u thank u thanku thank u thank u thank u thank u thank u thank u
Logged
Anonymous
Guest
« Reply #29 on: May 31, 2004, 09:58:26 PM »

Thank you all very much, this should be a tutorial somewhere *request* Tutorial section.

Now to figure out how to setup ftp access per user.
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!