DeveloperSide.NET Forums
February 22, 2020, 06:47:46 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1] 2
  Print  
Author Topic: New NON-SSL Package out w/ mod_perl and Apache::ASP  (Read 20369 times)
0 Members and 1 Guest are viewing this topic.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« on: September 09, 2003, 06:28:35 AM »

mod_perl 1.99_09
Apache::ASP 2.55
updated PHP 4.3.3

September 09, 2003

Let me know if anyone has any problems with the new components.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #1 on: September 09, 2003, 06:13:21 PM »

ok, i like to compile every thing my self, but i teste your package on my laptop(test box) on a clean system and i can't get apache to run
if i do net start apache2 it would give a msg that the service made could not start, but with apache -t give's no errors
Logged

Anonymous
Guest
« Reply #2 on: September 09, 2003, 07:32:46 PM »

I assume you removed any previous Apache installed from the services?

Then under the \www\Apache2\bin\ dir...
apache -k install
apache -k start
Logged
Anonymous
Guest
« Reply #3 on: September 09, 2003, 09:21:41 PM »

I also have a problem starting the service.

Regards,

Alex
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #4 on: September 09, 2003, 09:36:53 PM »

I've tried it with my original www and the downloaded www.rar.  Everything is fine on my end.

What exactly is the message your getting?

Nothing has changed with Apache2, except for the inclusion of mod_perl.so under the modules directory, and a few header files under the include directory.  And a few additions to the httpd.conf file.

Again, if you have an older Apache on your system, that Apache must be, under services, stoped and uninstalled.

Also, did you copy the new php.ini to your system root directory?  Since we upgraded PHP 4.3.2 to 4.3.3 I believe php.ini has changed.  With an older php.ini from the previous version of PHP, Apache starting with the new PHP module and an older php.ini might result in some problems.

Remember to also reflect the correct drive letter in my.ini and php.ini.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #5 on: September 09, 2003, 10:44:00 PM »

Another point, is if you have ActiveState Perl, and that is set before \www\perl\bin under the PATH variable, your going to have problems when Apache tries to load mod_perl.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Anonymous
Guest
« Reply #6 on: September 10, 2003, 07:20:01 AM »

Hi...still getting a server specific error code 1 running XP Pro.sp1. MySQL is working but apache is giving problems.  Other than this, thanks for taking the time to create a setup like this. I hope I can get it working.

regards,

Alex
Logged
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #7 on: September 10, 2003, 10:44:58 AM »

the same msg when you make a mistake in the config file and try to start with net start apache2
Logged

Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #8 on: September 10, 2003, 04:26:54 PM »

-k install work,
-k start won't, same goes for net start apache2
btw check your mail box for the pic
Logged

admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #9 on: September 10, 2003, 06:50:27 PM »

I finally was able to reproduce the error on my system.

From the first looks of it, it might be a drive letter problem, I built on drive E: and most people run on drive C:.  I've tried very hard to keep all the builds "drive independant", but mod_perl seems to be having a problem with this, and hard-coded itself to E:.

Anyways, I'll get on it...
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #10 on: September 10, 2003, 09:05:26 PM »

Hmm, now, after a reboot, it seems to be working on drive C:.  I did the reboot, because phpinfo() was showing an old PATH.

I ran Apache2 through Dependancy Walker, and it shows the problem is with PHP!  But the Event Viewer shows that Apache exits because it can not 'find mod_perl' (under the correct drive letter and location), so it can not load mod_perl.

I do not think the reboot is what fixed this, more likely, I disabled mod_perl and started Apache2, which in effect, now that it worked, reset the internal PATH that something(Apache, PHP, mod_perl) hard stores, which changed E: to C: for Apache, PHP, and more importantly, mod_perl.



[UPDATE]

Just to double check, I downloaded www.rar from the site and tried again to replicate the problem.

To my surprise, Apache2 started just fine on drive C:!

The next logical step was to place this www onto drive E:.

Installed and started Apache2, and it failed.  Even though I updated the PATH to reflect the change.

Something is going on....
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #11 on: September 11, 2003, 02:45:20 AM »

It all comes down to this...

Before Apache will start with mod_perl, <drive>:\...\perl\bin has to be in the PATH.
The problem is, even if you edit the PATH variable under the System, and that change takes effect, Apache will not load mod_perl until your system is REBOOTED.

That is all it takes, change the PATH under the System to reflect the location of \perl\bin and REBOOT your computer.  Then Apache2 will start.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
guest
Guest
« Reply #12 on: October 02, 2003, 10:45:58 AM »

I am attempting a new install on drive E.
unfortunately, I have followed all that is said here and even added path e:\www\apache2\modules (where mod_perl.so is located) apache -k install generates message:
syntax error on line 85 of  e:\www.apache2\conf\httpd.conf: cannot load e:/www/apache2/modules/mod_perl.so into server: The specified module cound not be found
 :?: :?:  :?:
Logged
guest (sonos)
Guest
« Reply #13 on: October 02, 2003, 12:24:46 PM »

i put the full e:/... to the mod_perl in httpd at line 85 and recieve same message.

Invalid command "PerlModule", perhas misspelled or defined by a module not included in the server configuration
then I # for the PerlModule call:









and the apache -k install is successful :wink:
Logged
sonos
Guest
« Reply #14 on: October 02, 2003, 12:39:35 PM »

apache2 service  is now startted (listed under net start)

e:/www/mysql/bin>net start mysql fils however:
system error 3 has occured
the system cannot find the path specified. :?:  :?:  :?:
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!