DeveloperSide.NET Forums
July 07, 2020, 06:48:33 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Updated version of Web-Server Suite (std and SSL) released.  (Read 7870 times)
0 Members and 1 Guest are viewing this topic.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« on: November 25, 2004, 11:46:57 PM »

If anyone has any problems, let me know.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Ghostnet
Member
*
Posts: 6


View Profile
« Reply #1 on: November 26, 2004, 01:09:52 AM »

Thank you, thank you, and thank you!

And now for the problems :P
I think the basedir and datadir variables are missing form the my.ini file in the www-ssl.rar package .
I copied the my.ini file from my own server setup and seems to work.

Also...
I made a couple of .bat files to help me install, uninstall and run my compile from the tutorials. Maybe someone here will find them useful.

Setup.bat
Code:

C:\www\Apache2\bin\Apache.exe -D SSL -k install
C:\www\mysql\bin\mysqld-max-nt.exe --install-manual

copy C:\www\mysql\my.ini C:\WINODOWS
copy C:\www\php\php.ini C:\WINDOWS

NET START Apache
NET START MySQL


AllStop.bat
Code:

NET STOP Apache
NET STOP MySQL

del C:\WINDOWS\php.ini
del C:\WINDOWS\my.ini

C:\www\Apache2\bin\Apache.exe -k uninstall
C:\www\mysql\bin\mysqld-max-nt.exe --remove


This is really so I can make changes in the php and MySQL folders alone and have them reflect whenever the servers restart...  Without having to manually copy them over to C:\WINDOWS . (Yes.. I'm lazy ;) )

Of course they can be split up into separate files like startApache.bat and startMySQL.bat   ... Just a thought for you.
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #2 on: November 26, 2004, 01:28:20 AM »

MySQL 4.0.22 does not use base_dir and data_dir anymore.  Those values are automatically detected.  There are also some other minor changes (IIRC), so you might want to use the fresh my.ini over whatever was included in the older package.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Ghostnet
Member
*
Posts: 6


View Profile
« Reply #3 on: November 26, 2004, 01:31:46 AM »

Sweet!
Thanks
Logged
rockrun
Member
*
Posts: 2


View Profile
« Reply #4 on: November 27, 2004, 10:23:53 PM »

Quote from: "admin"
If anyone has any problems, let me know.


I have some problem downloading the updated version. I live in Austin, Texas, and my ISP is roadruner with Time Warner Cable.  I was able to download the old ssl-enabled server. My IP address is 70.113.82.65 and I am not behind a firewall. Can you please help me downloading the ssl-enabled server?

thanks,

rockrun
Logged
rockrun
Member
*
Posts: 2


View Profile
« Reply #5 on: November 30, 2004, 03:11:50 AM »

Quote from: "admin"
Try this link now...
...


I actually compiled the apache+ssl following your direction and it worked very well. Now I got the whold package. Thanks again.

rockrun
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!