DeveloperSide.NET Forums
January 19, 2020, 09:45:53 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Web-Server NON-SSL Package, v 1.06 Installation Problems  (Read 13425 times)
0 Members and 1 Guest are viewing this topic.
jimmy123
Member
*
Posts: 4


View Profile
« on: October 22, 2003, 11:39:53 AM »

Hi, I recently installed "Web-Server NON-SSL Package, version 1.06".  I'm quite new to this but just wish to test some of my php script from home (I'm at uni) where I don't have internet access.

The problems I'm getting is when I goto a php page (.php extension - .html working fine) I just get a blank page.

I think the step that beat me was:

Quote

(7) Go to Settings >> Control Panel >> System >> Advanced >> Environment Variables... >> System variables >> Path
Add to Path <drive:>\www\Apache2\bin;<drive:>\www\mysql\bin;<drive:>\www\perl\bin;<drive:>\www\php\dlls
NOTE that the individual locations are separated with a ";" and that you will need to place a ";" at the end of the original PATH, to separate it from the first appended location.


I followed what it said and then when I clicked edit on path and added the bit to the end replacing <drive:> with c:

I also messed up one other bit.  I deleted all the existing mysql databases using phpmyadmin.  I want to add the database db_home and add a user bog with password 12345 so it reflects my database settings for the website I wish to test but I don't know how.

If I made a mess up by deleting the existing databases please could you tell me how to reinstall mysql.

Finally what is the difference between the NON-SSL Package and the SSL Package.  I checked the file contents and saw OpenSSL 0.9.7c was the only real difference.  Why is it necessary to have two versions one with and one without.

I'd be very greatful for any support you can give.

Thanx - oh remember newbie :?
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #1 on: October 22, 2003, 03:09:22 PM »

Quote
I also messed up one other bit. I deleted all the existing mysql databases using phpmyadmin.


MySQL will not work without the "mysql" database.  Just unpack the \www\mysql\data directory from www.rar over your existing \www\mysql\data directory.

Quote
want to add the database db_home and add a user bog with password 12345 so it reflects my database settings for the website I wish to test but I don't know how.


http://www.mysql.com/documentation/mysql/bychapter/index.html

Quote
Finally what is the difference between the NON-SSL Package and the SSL Package.


Strong encryption.  US laws regulate the exportation of strong encryption.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
jimmy123
Member
*
Posts: 4


View Profile
« Reply #2 on: October 23, 2003, 11:08:24 AM »

Cheers, helped alot, so do you know how to fix the php issue.  Thanx again
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #3 on: October 23, 2003, 03:54:17 PM »

If http://localhost/phpinfo.php works, your scripts are not coded properly.

If phpinfo.php does not work, than you did not install the package properly.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
jimmy123
Member
*
Posts: 4


View Profile
« Reply #4 on: October 24, 2003, 09:05:00 AM »

Sorry it was my bad, there was an error in the page I was testing.  Didn't think to test the temporary page.  All working fine now.  Thanx for putting a great package together.

Just one quick thing.  What would be the path for the cookie domain.  Usually I'd put $cookiedomain = "./domain.com"; but I've tried numerous things with no luck.  Thanx
Logged
jimmy123
Member
*
Posts: 4


View Profile
« Reply #5 on: October 29, 2003, 01:06:13 PM »

Quote from: "jimmy123"
Sorry it was my bad, there was an error in the page I was testing.  Didn't think to test the temporary page.  All working fine now.  Thanx for putting a great package together.

Just one quick thing.  What would be the path for the cookie domain.  Usually I'd put $cookiedomain = "./domain.com"; but I've tried numerous things with no luck.  Thanx


So any luck with this?
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #6 on: October 29, 2003, 06:07:36 PM »

Quote
So any luck with this?


Well, if your asking what I think your asking, just substitute for localhost or 127.0.0.1
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!