DeveloperSide.NET Forums
September 20, 2019, 10:24:40 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Apache 2 startup gives unresolved external on HP UX11i  (Read 6761 times)
0 Members and 1 Guest are viewing this topic.
vivekgupta23
Member
*
Posts: 2

vivekgupta23@yahoo.com
View Profile
« on: May 05, 2005, 05:18:52 PM »

I am really struggling with this issue with no clue of how to narrow down that whether the issue is in my environment / my build process / or my custom module:-

I am bit new to HP UX still tried the following

$ httpd
Syntax error on line 233 of /home1/saurabhs/vivek/apache2Install/conf/httpd.conf:
Cannot load /home1/saurabhs/vivek/apache2Install/modules/myModuleApache.so into server: Unresolved external

This error doesn't indicate which symbol its not able to locate...
Have following options tried:
$ ldd -r dynamoApache.so
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        /usr/lib/libdld.2 =>    /usr/lib/libdld.2
        /usr/lib/libc.2 =>      /usr/lib/libc.2
        symbol not found: apr_bucket_type_eos   (myModuleApache.so)
        symbol not found: ap_hook_child_init    (myModuleApache.so)
        symbol not found: ap_hook_handler       (myModuleApache.so)
        symbol not found: ap_hook_translate_name        (myModuleApache.so)
        symbol not found: ap_hook_fixups        (myModuleApache.so)
        symbol not found: apr_pool_cleanup_register     (myModuleApache.so)
        symbol not found: apr_palloc    (myModuleApache.so)
        symbol not found: ap_log_error  (myModuleApache.so)
        symbol not found: ap_get_server_name    (myModuleApache.so)
        symbol not found: apr_table_get (myModuleApache.so)
        symbol not found: ap_get_remote_host    (myModuleApache.so)
        symbol not found: ap_get_server_port    (myModuleApache.so)
        symbol not found: ap_run_http_method    (myModuleApache.so)
        symbol not found: apr_table_elts        (myModuleApache.so)
        symbol not found: apr_brigade_create    (myModuleApache.so)
        symbol not found: ap_get_brigade        (myModuleApache.so)
        symbol not found: apr_brigade_destroy   (myModuleApache.so)
        symbol not found: apr_brigade_flatten   (myModuleApache.so)
        symbol not found: ap_rwrite     (myModuleApache.so)
        symbol not found: ap_rflush     (myModuleApache.so)
        symbol not found: apr_pstrdup   (myModuleApache.so)
        symbol not found: apr_pstrcat   (myModuleApache.so)
        symbol not found: apr_table_add (myModuleApache.so)
        symbol not found: apr_table_set (myModuleApache.so)
        symbol not found: ap_os_escape_path     (myModuleApache.so)
        symbol not found: ap_construct_url      (myModuleApache.so)
        symbol not found: apr_table_setn        (myModuleApache.so)

And
$ chatr myModuleApache.so
myModuleApache.so:
         shared library
         shared library dynamic path search:
             SHLIB_PATH     enabled   second
             embedded path  enabled   first  /home1/saurabhs/vivek/apache2Install/modules
         internal name:
             myModuleApache.sl
         shared library list:
             dynamic   /usr/lib/libc.2
         shared vtable support disabled
         static branch prediction disabled
         executable from stack: D (default)
         kernel assisted branch prediction enabled
         lazy swap allocation disabled
         text segment locking disabled
         data segment locking disabled
         third quadrant private data space disabled
         fourth quadrant private data space disabled
         data page size: D (default)
         instruction page size: D (default)

Tried running pxdb debugger but no success, tried with lot of CFLAGS settings / SHLIB_PATH but with no success.

any indication of how to debug this problem further wud be gr8 help. Thanks...
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!