DeveloperSide.NET Forums
June 05, 2020, 02:48:13 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: https://localhost You don't have permission to access...  (Read 33830 times)
0 Members and 1 Guest are viewing this topic.
ufo
Member
*
Posts: 17


View Profile
« on: October 23, 2003, 01:17:42 PM »

I downloaded the NON-SSL package and re-compiled Apache with the MOD_SSL module.

Everything is working as it should be. All tests that are mentioned in the readme1st.txt are working perfectly!

If I connect to (I am typing this on the server) http://localhost, all is ok. If I connect to https://localhost, I get to accept my certificate and than I get the message:

Forbidden
You don't have permission to access / on this server.
--------------------------------------------------------------------------------
Apache/2.0.47 (Win32) mod_perl/1.99_10 Perl/v5.8.1 mod_ssl/2.0.47 OpenSSL/0.9.7c PHP/4.3.3 Server at localhost Port 443



I used the httpd.conf that was in the NON-SSL package. I gues it has something to do with this part of the config file but I am not sure:

<Directory "/www/webroot">
   order allow,deny
   allow from all
</Directory>


Can some one help me on this one. I want to get my HTTPS working.

Thanx :!:
Logged
Anonymous
Guest
« Reply #1 on: October 23, 2003, 01:23:38 PM »

Laat het me weten als je iets hebt zeg  :shock:
Logged
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #2 on: October 23, 2003, 02:15:30 PM »

You said you downlouded the NON-SSL package, try donwloading the SSL package.
Logged

ufo
Member
*
Posts: 17


View Profile
« Reply #3 on: October 23, 2003, 02:17:29 PM »

Jorge..............is that suppose to be funny?! I am the one that was not located in the US and was asking for someone to uload it to me a couple of days ago!

 :shock:
Logged
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #4 on: October 23, 2003, 02:22:47 PM »

A sry, i just forgot it was you.
ok it can be a few problems:
1. Your server.key and server.crt are nor set up corectly.
2. A misconfiguration.
I thing its to so i'll post a part of my config file:
In your ssl.conf you schou have simthing like:
Code:

<VirtualHost _default_:443>


DocumentRoot "c:/www/webroot"
ServerName Hostname:443
ServerAdmin Webmaster@Host
ErrorLog logs/error.log
TransferLog logs/access.log

Make sure the DocumentRoot is set up correctly
Logged

ufo
Member
*
Posts: 17


View Profile
« Reply #5 on: October 23, 2003, 02:58:02 PM »

Yep, that seems to be the problem. I had an "." too much in there!

Thanx again.


Do you also have a solution for my Apache service starting up verry slowly? It takes about 1m30s if I start the Apache service. There is nothing in the error logs (LogLevel is set to error).

And IF the service runs, the site runs fast. No further performance problems.

Al the previous version I had started in about 10s or so.
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #6 on: October 23, 2003, 03:57:37 PM »

Quote
It takes about 1m30s if I start the Apache service.


It has something to do with mod_perl being loaded.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #7 on: October 23, 2003, 04:13:42 PM »

yep
if you have somthing like:
PerlRequire "C:/server/Apache/conf/extra.pl"
try removing it, it will ge a bit faster
Logged

ufo
Member
*
Posts: 17


View Profile
« Reply #8 on: October 23, 2003, 04:18:41 PM »

Quote
It has something to do with mod_perl being loaded.


I disabled the mod_perl and it restarted within 10s.
So is this normal? Is everyone having this "feature"?

What happens if I leave this module disabled? I gues I will not be able to have perl script on the server and that ASP pages will not be possible but what else? Is SSL or anything else affected by this?
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #9 on: October 23, 2003, 04:21:38 PM »

It takes only 15 seconds or so to start on my system, vs. 3 or 5 without.

SSL is not affected by mod_perl.

It is not that big of a wait, even at 1:30 minutes.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
ufo
Member
*
Posts: 17


View Profile
« Reply #10 on: October 23, 2003, 04:33:16 PM »

Thnx for the help so far!!

I'll do without perl for now....until I need it. My server needs every availible bit of mem and cpu it can get :)
Logged
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #11 on: October 24, 2003, 01:31:32 PM »

It around 4-6sec here, i load php+ssl and ssi that about all,
with mod_perl without startup script its around 20sec with script: 40sec
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!