DeveloperSide.NET Forums
February 22, 2020, 07:48:31 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: 1 [2] 3 4 ... 8
  Print  
Author Topic: After upgrade Gallery does not work!  (Read 129079 times)
0 Members and 3 Guests are viewing this topic.
pvdgulik
Jr. Member
**
Posts: 57


View Profile WWW
« Reply #15 on: January 16, 2006, 08:43:34 AM »

Hello,

I changed "register_globals = On", but with the same result  :cry:

Here's the content of my httpd.conf:

Quote
###*********************************************************
###*  DeveloperSide.NET                                    *
###*  http://www.devside.net                               *
###*  admin@devside.net                                    *
###*  v1.15s                                               *
###*********************************************************


Listen 80
ServerRoot "/www/Apache2"
#DocumentRoot "d:/www/webroot/phpnuke"

#ServerName localhost:80
#ServerAdmin admin@localhost

NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost:80
DocumentRoot d:/www/webroot/phpnuke
ServerAdmin admin@localhost
</VirtualHost>

<VirtualHost *:80>
ServerName mysite1.domain.nl
DocumentRoot d:/www/webroot/phpnuke
ServerAdmin mysite1@domain.nl
</VirtualHost>

<VirtualHost *:80>
ServerName test.mysite1.nl
DocumentRoot d:/www/webroot/phpnuke
ServerAdmin mysite1@domain.nl
ServerAlias mysite1.nl *.mysite1.nl
</VirtualHost>

<VirtualHost *:80>
ServerName test.mysite1.com
DocumentRoot d:/www/webroot/phpnuke
ServerAdmin mysite1@domain.nl
ServerAlias mysite1.com *.mysite1.com
</VirtualHost>

<VirtualHost *:80>
ServerName test.mysite2.nl
DocumentRoot d:/www/webroot/mysite2.nl
ServerAdmin mysite2@mysite2.nl
ServerAlias mysite2.nl *.mysite2.nl
</VirtualHost>

<VirtualHost *:80>
ServerName test.mysite3.nl
DocumentRoot d:/www/webroot/mysite3.nl
ServerAdmin mysite3@mysite3.nl
ServerAlias mysite3.nl *.mysite3.nl
</VirtualHost>


ServerSignature On
ServerTokens Full

DefaultType text/plain
AddDefaultCharset ISO-8859-1

UseCanonicalName Off

HostnameLookups Off

ErrorLog logs/error.log
LogLevel error
#LogLevel warn

PidFile logs/httpd.pid

Timeout 300

KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15


<IfModule mpm_winnt.c>
   ThreadsPerChild 250
   MaxRequestsPerChild 0
</IfModule>

LoadModule access_module modules/mod_access.so
#LoadModule actions_module modules/mod_actions.so
LoadModule alias_module modules/mod_alias.so
#LoadModule asis_module modules/mod_asis.so
LoadModule auth_module modules/mod_auth.so
#LoadModule auth_anon_module modules/mod_auth_anon.so
#LoadModule auth_dbm_module modules/mod_auth_dbm.so
#LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule autoindex_module modules/mod_autoindex.so
#LoadModule cern_meta_module modules/mod_cern_meta.so
LoadModule cgi_module modules/mod_cgi.so
#LoadModule dav_module modules/mod_dav.so
#LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule dir_module modules/mod_dir.so
#LoadModule env_module modules/mod_env.so
#LoadModule expires_module modules/mod_expires.so
#LoadModule file_cache_module modules/mod_file_cache.so
LoadModule headers_module modules/mod_headers.so
#LoadModule imap_module modules/mod_imap.so
#LoadModule include_module modules/mod_include.so
LoadModule info_module modules/mod_info.so
#LoadModule isapi_module modules/mod_isapi.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule mime_module modules/mod_mime.so
#LoadModule mime_magic_module modules/mod_mime_magic.so
#LoadModule proxy_module modules/mod_proxy.so
#LoadModule proxy_connect_module modules/mod_proxy_connect.so
#LoadModule proxy_http_module modules/mod_proxy_http.so
#LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
#LoadModule negotiation_module modules/mod_negotiation.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule setenvif_module modules/mod_setenvif.so
#LoadModule speling_module modules/mod_speling.so
LoadModule status_module modules/mod_status.so
#LoadModule unique_id_module modules/mod_unique_id.so
#LoadModule userdir_module modules/mod_userdir.so
#LoadModule usertrack_module modules/mod_usertrack.so
#LoadModule vhost_alias_module modules/mod_vhost_alias.so
<IfDefine SSL>
   LoadModule ssl_module modules/mod_ssl.so
</IfDefine>
LoadModule logio_module modules/mod_logio.so
LoadModule deflate_module modules/mod_deflate.so

LoadFile "/www/perl/bin/perl58.dll"
LoadModule perl_module modules/mod_perl.so
PerlRequire "/www/Apache2/conf/extra.pl"

#LoadFile "/www/php5/php5ts.dll"
LoadFile "/www/php/php4ts.dll"
#LoadModule php5_module /www/php5/php5apache2.dll
LoadModule php4_module /www/php/php4apache2.dll

<Location />
   <IfModule mod_deflate.c>
      AddOutputFilterByType DEFLATE text/html text/plain text/css
      <IfModule mod_headers.c>
         Header append Vary User-Agent
      </IfModule>
   </IfModule>
</Location>

AccessFileName .htaccess
 
<Files ~ "^\.htaccess$">
  order allow,deny
  deny from all
</Files>

<Directory />
   Options None
   AllowOverride None
   Order allow,deny
   Deny from all
</Directory>


<Directory "/www/webroot">
   AllowOverride All
   Order allow,deny
   Allow from all
</Directory>

<IfModule mod_auth.c>
   <Files ~ "^\.ht">
      Order allow,deny
      Deny from all
   </Files>

   Alias /private "/www/private"

   <Directory "/www/private">
      <IfModule mod_autoindex.c>
         Options Indexes
      </IfModule>

      Order allow,deny
      Allow from all

      AuthType Basic
      AuthName "Private Access"
      AuthUserFile "/www/private/.htpasswd"
      require valid-user
   </Directory>
</IfModule>

<IfModule mod_cgi.c>
   ScriptAlias /cgi-bin/ "/www/cgi-bin/"

   <Directory "/www/cgi-bin">
      Options None
      AllowOverride None
      Order allow,deny
      Allow from all
   </Directory>
</IfModule>


<IfModule mod_alias.c>
   Alias /phpMyAdmin "/www/phpMyAdmin"
</IfModule>

<Directory "/www/phpMyAdmin">
   Options None
   AllowOverride None
   Order deny,allow
   Deny from all
   Allow from 127.0.0.1
</Directory>


<Directory "/www/webroot/stats">
   Order deny,allow
   Deny from all
   Allow from 127.0.0.1
</Directory>


<IfModule mod_log_config.c>
   LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-agent}i\"" combined
   CustomLog logs/access.log combined
   <IfModule mod_deflate.c>
      DeflateFilterNote Input instream
      DeflateFilterNote Output outstream
      DeflateFilterNote Ratio ratio
      LogFormat '"%r" %{outstream}n/%{instream}n (%{ratio}n%%)' deflate
      CustomLog logs/deflate.log deflate
   </IfModule>
</IfModule>


<IfModule mod_dir.c>
   DirectoryIndex index.html index.php
</IfModule>


<IfModule mod_mime.c>
   TypesConfig conf/mime.types
   AddType application/x-compress .Z
   AddType application/x-gzip .gz .tgz
   AddType application/x-rar-compressed .rar
   <IfModule mod_php5.c>
      AddType application/x-httpd-php .php
      AddType application/x-httpd-php-source .phps
   </IfModule>
</IfModule>


<IfModule mod_setenvif.c>
   BrowserMatch "Mozilla/2" nokeepalive
   BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
   BrowserMatch "RealPlayer 4\.0" force-response-1.0
   BrowserMatch "Java/1\.0" force-response-1.0
   BrowserMatch "JDK/1\.0" force-response-1.0
   BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
   BrowserMatch "^WebDrive" redirect-carefully
   BrowserMatch "^WebDAVFS/1.[012]" redirect-carefully
   BrowserMatch "^gnome-vfs" redirect-carefully
   <IfModule mod_deflate.c>
      BrowserMatch ^Mozilla/4 gzip-only-text/html
      BrowserMatch ^Mozilla/4\.0[678] no-gzip
      BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
   </IfModule>
</IfModule>


<IfModule mod_status.c>
   ExtendedStatus On
   <Location /server-status>
      SetHandler server-status
      Order deny,allow
      Deny from all
      Allow from 127.0.0.1
   </Location>
</IfModule>


<IfModule mod_info.c>
   <Location /server-info>
      SetHandler server-info
      Order deny,allow
      Deny from all
      Allow from 127.0.0.1
   </Location>
</IfModule>


<IfModule mod_perl.c>
   PerlModule Apache2::Status
   <Location /perl-status>
      SetHandler perl-script
      PerlResponseHandler Apache2::Status
      Order deny,allow
      Deny from all
      Allow from 127.0.0.1
   </Location>
</IfModule>


<IfModule mod_ssl.c>
   Include conf/ssl.conf
</IfModule>


##### Start -- mod_perl Hello example, \www\perl\site\lib\Apache2\Hello.pm
#
<IfModule mod_perl.c>
   PerlModule Apache2::Hello
   <Location /hello>
      SetHandler modperl
      PerlResponseHandler Apache2::Hello
      Order deny,allow
      Deny from all
      Allow from 127.0.0.1
   </Location>
</IfModule>
#
##### End -- mod_perl Hello example

##### Start -- Gallery addon, P. van der Gulik, 11-12-2005
#

#AddModule mod_rewrite.c
RewriteEngine On
<Directory "D:\www\webroot\phpnuke\modules\Gallery">
        AllowOverride Options FileInfo
</Directory>

<Directory "D:\www\webroot\mysite2.nl\modules\Gallery">
        AllowOverride Options FileInfo
</Directory>

<Directory "D:\www\webroot\mysite3.nl\modules\Gallery">
        AllowOverride Options FileInfo
</Directory>

#
##### End -- Gallery


Thank you again! I'm sure I did something wrong in the upgrade but I'm
totally lost now  :roll:

Pieter
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #16 on: January 16, 2006, 08:54:53 AM »

Quote

<IfModule mod_php5.c>
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
</IfModule>


Change to...
Quote

<IfModule sapi_apache2.c>
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
</IfModule>


Forgot about that one.  Restart Apache.  That should fix something, but you might still have problems with the way you have those VHs configured.
And for the mean time, I would keep Globals On.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #17 on: January 16, 2006, 09:16:05 AM »

Quote

ServerRoot "/www/Apache2"
#DocumentRoot "d:/www/webroot/phpnuke"

#ServerName localhost:80
#ServerAdmin admin@localhost

NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost:80
DocumentRoot d:/www/webroot/phpnuke
ServerAdmin admin@localhost
</VirtualHost>

<VirtualHost *:80>
ServerName mysite1.domain.nl
DocumentRoot d:/www/webroot/phpnuke
ServerAdmin mysite1@domain.nl
</VirtualHost>

<VirtualHost *:80>
ServerName test.mysite1.nl
DocumentRoot d:/www/webroot/phpnuke
ServerAdmin mysite1@domain.nl
ServerAlias mysite1.nl *.mysite1.nl
</VirtualHost>

<VirtualHost *:80>
ServerName test.mysite1.com
DocumentRoot d:/www/webroot/phpnuke
ServerAdmin mysite1@domain.nl
ServerAlias mysite1.com *.mysite1.com
</VirtualHost>

<VirtualHost *:80>
ServerName test.mysite2.nl
DocumentRoot d:/www/webroot/mysite2.nl
ServerAdmin mysite2@mysite2.nl
ServerAlias mysite2.nl *.mysite2.nl
</VirtualHost>

<VirtualHost *:80>
ServerName test.mysite3.nl
DocumentRoot d:/www/webroot/mysite3.nl
ServerAdmin mysite3@mysite3.nl
ServerAlias mysite3.nl *.mysite3.nl
</VirtualHost>


Have you registerd any of the domain names you are using?
Are you using the Windows Hosts file?
Change the above to...

Quote

ServerRoot "D:/www/Apache2"
DocumentRoot "D:/www/webroot"

ServerName localhost:80
ServerAdmin admin@localhost

NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
ServerName mysite1.domain.nl
DocumentRoot "d:/www/webroot/phpnuke"
ServerAdmin mysite1@domain.nl
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.mysite1.nl
DocumentRoot "d:/www/webroot/phpnuke"
ServerAdmin mysite1@domain.nl
ServerAlias mysite1.nl *.mysite1.nl
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.mysite1.com
DocumentRoot "d:/www/webroot/phpnuke"
ServerAdmin mysite1@domain.nl
ServerAlias mysite1.com *.mysite1.com
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.mysite2.nl
DocumentRoot "d:/www/webroot/mysite2.nl"
ServerAdmin mysite2@mysite2.nl
ServerAlias mysite2.nl *.mysite2.nl
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.mysite3.nl
DocumentRoot "d:/www/webroot/mysite3.nl"
ServerAdmin mysite3@mysite3.nl
ServerAlias mysite3.nl *.mysite3.nl
</VirtualHost>
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #18 on: January 16, 2006, 09:21:30 AM »

And I though Gallery was stand alone, not a phpnuke module?
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
pvdgulik
Jr. Member
**
Posts: 57


View Profile WWW
« Reply #19 on: January 16, 2006, 01:31:01 PM »

Hello,

I changed all the domain names in the post for security resons. All the
domain names is use are registerd and worked with in the orginal configuration, and even after the upgrade tot DevSide 1.15. The only problem was Gallery.

The problems I now have are since I degraded tot PHP 4.0 on my test sites, which were the same until the upgrade to DevSide 1.15

I changed:

Quote
Quote:

<IfModule mod_php5.c>
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
</IfModule>
 


Change to...
Quote:

<IfModule sapi_apache2.c>
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
</IfModule>


which helped a little bit: The pages now show in content instead of the script, but still:
Quote
(mod_info)
http://localhost/server-info Result: the Gallery output

(mod_status) with/"ExtendedStatus On"
http://localhost/server-status Result: the Gallery output

(mod_perl Apache::Status)
http://localhost/perl-status Result: the Gallery output

Important Notes -- Testing
(test Apache2)
http://localhost  Result: white page!! :?

(test PHP)
http://localhost/phpinfo.php Result: the PHP-info output

(test CGI)
http://localhost/cgi-bin/printenv.pl Result: Ok

(test mod_perl)
http://localhost/hello Result: the Gallery output

(test phpMyAdmin)
http://localhost/phpMyAdmin/ Result: "Kan de mysqli extentie niet laden,
Controleer de PHP Configuratie Documentatie" which means: "Cannot load the mysqli extension, check the PHP configuration."
This is logical, because you asked me to:
Quote
1 line change -- edit phpMyAdmin's config.ini.php to reflect the use of php_mysql vs php_mysqli -- which does not exist under PHP v4.4.

(Generate Analog, log analyzer, report)
http://localhost/stats/Report.html Result: The page cannot be found
http://localhost/stats/anlgform.html Result: The page cannot be found

(test user/password protected directory "private")
http://localhost/private/ Result: Ok


Would it help to post my php.ini mysql.ini?

Thanks again.
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #20 on: January 16, 2006, 09:21:49 PM »

PHP 4.4 is now setup on your system and should be working just fine.

Did you change those VHs under httpd.conf like I posted?  The change should not mess anything up, maybe just fix a thing or two.
(You can keep your '*:80' entry for each one -- the 127.0.0.1 is just a test case to rule out any problems.
I'm more intrested in getting rid of that 1st VH block and the 1st 2 lines that you had edited)

You can always just save your current httpd.conf as backup.

And how is it that Gallery is a module for phpnuke? Did you just install it under the phpnuke modules dir?

If those VHs changes do not help you, than whatever is happening has nothing to do with the config of PHP or Apache.  But probably the way you have your PHPNuke and Gallery setup and whatever .htaccess files they added.
http://forums.devside.net/viewtopic.php?p=4485#4480

After this, unless you want to look at those .htaccess file, I would try to find a way of 'manually' backing up your Gallery data.  I believe most of your problems here are a result of phpnuke.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Jorge
Customer, Basic Support
Guru
*****
Posts: 544

jorge_schrauwen@msn.com
View Profile WWW
« Reply #21 on: January 16, 2006, 10:12:49 PM »

Dutch:
Wat staat er in logs/error.log?

English:
What does logs/error.log contain?
Logged

pvdgulik
Jr. Member
**
Posts: 57


View Profile WWW
« Reply #22 on: January 16, 2006, 10:18:53 PM »

Hello,

I changed the VH's as you asked. Same result. This config for VH's already works for 2 years, so I didn't expected it was wrong.

I installed Gallery as a module in PHP-nuke liked instructed in the installation guide of Gallery. And it all worked fine...
Quote
D:\www\webroot\phpnuke\modules\Gallery


You can check if you want on tebogo.com Especially the last on has a big Gallery. It is the DevSide 1.09

It looks verry standard, I know.  But after two years, I have at last time to go futher there where I left it. So I wanted to first upgrade and then go furter with the websites.

Thanks
Logged
pvdgulik
Jr. Member
**
Posts: 57


View Profile WWW
« Reply #23 on: January 16, 2006, 10:22:06 PM »

Hello Jorge,

Quote from: "Jorge"
Dutch:
Wat staat er in logs/error.log?

English:
What does logs/error.log contain?


It says:
Quote
[Sat Jan 14 22:57:02 2006] [notice] Apache/2.0.54 (Win32) PHP/5.0.5 mod_perl/2.0.1 Perl/v5.8.7 configured -- resuming normal operations
[Sat Jan 14 22:57:02 2006] [notice] Server built: Jul 25 2005 17:33:17
[Sat Jan 14 22:57:02 2006] [notice] Parent: Created child process 764
[Sat Jan 14 22:57:17 2006] [notice] Child 764: Child process is running
[Sat Jan 14 22:57:17 2006] [notice] Child 764: Acquired the start mutex.
[Sat Jan 14 22:57:17 2006] [notice] Child 764: Starting 250 worker threads.
[Sun Jan 15 14:37:33 2006] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sun Jan 15 14:37:34 2006] [notice] Child 764: Exit event signaled. Child process is ending.
[Sun Jan 15 14:37:35 2006] [notice] Child 764: Released the start mutex
[Sun Jan 15 14:37:59 2006] [notice] Child 764: Waiting for 250 worker threads to exit.
[Sun Jan 15 14:37:59 2006] [notice] Child 764: All worker threads have exited.
[Sun Jan 15 14:37:59 2006] [notice] Child 764: Child process is exiting
[Sun Jan 15 14:38:04 2006] [notice] Parent: Forcing termination of child process 424
[Sun Jan 15 14:40:39 2006] [notice] Apache/2.0.54 (Win32) PHP/4.4.2 mod_perl/2.0.1 Perl/v5.8.7 configured -- resuming normal operations
[Sun Jan 15 14:40:39 2006] [notice] Server built: Jul 25 2005 17:33:17
[Sun Jan 15 14:40:40 2006] [notice] Parent: Created child process 3100
[Sun Jan 15 14:40:56 2006] [notice] Child 3100: Child process is running
[Sun Jan 15 14:40:56 2006] [notice] Child 3100: Acquired the start mutex.
[Sun Jan 15 14:40:56 2006] [notice] Child 3100: Starting 250 worker threads.
[Sun Jan 15 14:41:15 2006] [notice] Parent: Received restart signal -- Restarting the server.
[Sun Jan 15 14:41:15 2006] [notice] Child 3100: Exit event signaled. Child process is ending.
[Sun Jan 15 14:41:16 2006] [notice] Child 3100: Released the start mutex
[Sun Jan 15 14:41:25 2006] [notice] Apache/2.0.54 (Win32) PHP/4.4.2 mod_perl/2.0.1 Perl/v5.8.7 configured -- resuming normal operations
[Sun Jan 15 14:41:25 2006] [notice] Server built: Jul 25 2005 17:33:17
[Sun Jan 15 14:41:25 2006] [notice] Parent: Created child process 3064
[Sun Jan 15 14:41:25 2006] [notice] Child 3100: Waiting for 250 worker threads to exit.
[Sun Jan 15 14:41:26 2006] [notice] Child 3100: All worker threads have exited.
[Sun Jan 15 14:41:27 2006] [notice] Child 3100: Child process is exiting
[Sun Jan 15 14:41:42 2006] [notice] Child 3064: Child process is running
[Sun Jan 15 14:41:42 2006] [notice] Child 3064: Acquired the start mutex.
[Sun Jan 15 14:41:42 2006] [notice] Child 3064: Starting 250 worker threads.
[Sun Jan 15 14:44:34 2006] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sun Jan 15 14:44:34 2006] [notice] Child 3064: Exit event signaled. Child process is ending.
[Sun Jan 15 14:44:35 2006] [notice] Child 3064: Released the start mutex
[Sun Jan 15 14:44:36 2006] [notice] Child 3064: Waiting for 250 worker threads to exit.
[Sun Jan 15 14:44:36 2006] [notice] Child 3064: All worker threads have exited.
[Sun Jan 15 14:44:36 2006] [notice] Child 3064: Child process is exiting
[Sun Jan 15 14:44:36 2006] [notice] Parent: Child process exited successfully.
[Sun Jan 15 14:45:19 2006] [notice] Apache/2.0.54 (Win32) PHP/4.4.2 mod_perl/2.0.1 Perl/v5.8.7 configured -- resuming normal operations
[Sun Jan 15 14:45:19 2006] [notice] Server built: Jul 25 2005 17:33:17
[Sun Jan 15 14:45:19 2006] [notice] Parent: Created child process 2996
[Sun Jan 15 14:45:35 2006] [notice] Child 2996: Child process is running
[Sun Jan 15 14:45:35 2006] [notice] Child 2996: Acquired the start mutex.
[Sun Jan 15 14:45:35 2006] [notice] Child 2996: Starting 250 worker threads.
[Sun Jan 15 14:46:06 2006] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sun Jan 15 14:46:06 2006] [notice] Child 2996: Exit event signaled. Child process is ending.
[Sun Jan 15 14:46:07 2006] [notice] Child 2996: Released the start mutex
[Sun Jan 15 14:46:08 2006] [notice] Child 2996: Waiting for 250 worker threads to exit.
[Sun Jan 15 14:46:08 2006] [notice] Child 2996: All worker threads have exited.
[Sun Jan 15 14:46:08 2006] [notice] Child 2996: Child process is exiting
[Sun Jan 15 14:46:08 2006] [notice] Parent: Child process exited successfully.
[Sun Jan 15 14:53:10 2006] [notice] Apache/2.0.54 (Win32) PHP/4.4.2 mod_perl/2.0.1 Perl/v5.8.7 configured -- resuming normal operations
[Sun Jan 15 14:53:10 2006] [notice] Server built: Jul 25 2005 17:33:17
[Sun Jan 15 14:53:10 2006] [notice] Parent: Created child process 988
[Sun Jan 15 14:54:02 2006] [notice] Child 988: Child process is running
[Sun Jan 15 14:54:03 2006] [notice] Child 988: Acquired the start mutex.
[Sun Jan 15 14:54:03 2006] [notice] Child 988: Starting 250 worker threads.
[Sun Jan 15 23:53:59 2006] [error] [client 127.0.0.1] File does not exist: D:/www/webroot/phpnuke/stats
[Sun Jan 15 23:54:32 2006] [error] [client 127.0.0.1] File does not exist: D:/www/webroot/phpnuke/stats
[Sun Jan 15 23:54:37 2006] [error] [client 127.0.0.1] File does not exist: D:/www/webroot/phpnuke/stats
[Sun Jan 15 23:55:20 2006] [error] [client 127.0.0.1] user admin: authentication failure for "/private/": Password Mismatch
[Sun Jan 15 23:55:33 2006] [error] [client 127.0.0.1] user root not found: /private/
[Sun Jan 15 23:55:38 2006] [error] [client 127.0.0.1] user root not found: /private/
[Sun Jan 15 23:55:43 2006] [error] [client 127.0.0.1] user root not found: /private/
[Sun Jan 15 23:55:52 2006] [error] [client 127.0.0.1] user Admin not found: /private/
[Sun Jan 15 23:55:58 2006] [error] [client 127.0.0.1] user Admin not found: /private/
[Sun Jan 15 23:56:12 2006] [error] [client 127.0.0.1] user TauAdmin not found: /private/
[Sun Jan 15 23:56:16 2006] [error] [client 127.0.0.1] user TauAdmin not found: /private/
[Sun Jan 15 23:56:28 2006] [error] [client 127.0.0.1] user Admin not found: /private/
[Sun Jan 15 23:56:33 2006] [error] [client 127.0.0.1] user Admin not found: /private/
[Sun Jan 15 23:56:38 2006] [error] [client 127.0.0.1] user Admin not found: /private/
[Mon Jan 16 01:38:32 2006] [error] [client 66.111.202.32] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Mon Jan 16 09:18:33 2006] [notice] Parent: Received restart signal -- Restarting the server.
[Mon Jan 16 09:18:33 2006] [notice] Child 988: Exit event signaled. Child process is ending.
[Mon Jan 16 09:18:34 2006] [notice] Child 988: Released the start mutex
[Mon Jan 16 09:18:58 2006] [notice] Child 988: Waiting for 250 worker threads to exit.
[Mon Jan 16 09:19:00 2006] [notice] Child 988: All worker threads have exited.
[Mon Jan 16 09:19:01 2006] [notice] Child 988: Child process is exiting
[Mon Jan 16 09:21:05 2006] [notice] Apache/2.0.54 (Win32) PHP/4.4.2 mod_perl/2.0.1 Perl/v5.8.7 configured -- resuming normal operations
[Mon Jan 16 09:21:05 2006] [notice] Server built: Jul 25 2005 17:33:17
[Mon Jan 16 09:21:06 2006] [notice] Parent: Created child process 988
[Mon Jan 16 09:21:27 2006] [notice] Child 988: Child process is running
[Mon Jan 16 09:21:27 2006] [notice] Child 988: Acquired the start mutex.
[Mon Jan 16 09:21:27 2006] [notice] Child 988: Starting 250 worker threads.
[Mon Jan 16 09:26:34 2006] [notice] Parent: Received restart signal -- Restarting the server.
[Mon Jan 16 09:26:34 2006] [notice] Child 988: Exit event signaled. Child process is ending.
[Mon Jan 16 09:26:35 2006] [notice] Child 988: Released the start mutex
[Mon Jan 16 09:26:36 2006] [notice] Child 988: Waiting for 250 worker threads to exit.
[Mon Jan 16 09:26:36 2006] [notice] Child 988: All worker threads have exited.
[Mon Jan 16 09:26:37 2006] [notice] Child 988: Child process is exiting
[Mon Jan 16 09:26:50 2006] [notice] Apache/2.0.54 (Win32) PHP/4.4.2 mod_perl/2.0.1 Perl/v5.8.7 configured -- resuming normal operations
[Mon Jan 16 09:26:50 2006] [notice] Server built: Jul 25 2005 17:33:17
[Mon Jan 16 09:26:50 2006] [notice] Parent: Created child process 988
[Mon Jan 16 09:27:08 2006] [notice] Child 988: Child process is running
[Mon Jan 16 09:27:08 2006] [notice] Child 988: Acquired the start mutex.
[Mon Jan 16 09:27:08 2006] [notice] Child 988: Starting 250 worker threads.
[Mon Jan 16 09:29:40 2006] [notice] Parent: Received restart signal -- Restarting the server.
[Mon Jan 16 09:29:40 2006] [notice] Child 988: Exit event signaled. Child process is ending.
[Mon Jan 16 09:29:41 2006] [notice] Child 988: Released the start mutex
[Mon Jan 16 09:29:42 2006] [notice] Child 988: Waiting for 250 worker threads to exit.
[Mon Jan 16 09:29:43 2006] [notice] Child 988: All worker threads have exited.
[Mon Jan 16 09:29:43 2006] [notice] Child 988: Child process is exiting
[Mon Jan 16 09:29:56 2006] [notice] Apache/2.0.54 (Win32) PHP/4.4.2 mod_perl/2.0.1 Perl/v5.8.7 configured -- resuming normal operations
[Mon Jan 16 09:29:56 2006] [notice] Server built: Jul 25 2005 17:33:17
[Mon Jan 16 09:29:56 2006] [notice] Parent: Created child process 2984
[Mon Jan 16 09:30:13 2006] [notice] Child 2984: Child process is running
[Mon Jan 16 09:30:13 2006] [notice] Child 2984: Acquired the start mutex.
[Mon Jan 16 09:30:13 2006] [notice] Child 2984: Starting 250 worker threads.
[Mon Jan 16 13:44:13 2006] [notice] Parent: Received restart signal -- Restarting the server.
[Mon Jan 16 13:44:13 2006] [notice] Child 2984: Exit event signaled. Child process is ending.
[Mon Jan 16 13:44:16 2006] [notice] Child 2984: Released the start mutex
[Mon Jan 16 13:44:25 2006] [notice] Child 2984: Waiting for 250 worker threads to exit.
[Mon Jan 16 13:44:25 2006] [notice] Child 2984: All worker threads have exited.
[Mon Jan 16 13:44:26 2006] [notice] Child 2984: Child process is exiting
[Mon Jan 16 13:45:13 2006] [notice] Apache/2.0.54 (Win32) PHP/4.4.2 mod_perl/2.0.1 Perl/v5.8.7 configured -- resuming normal operations
[Mon Jan 16 13:45:13 2006] [notice] Server built: Jul 25 2005 17:33:17
[Mon Jan 16 13:45:13 2006] [notice] Parent: Created child process 988
[Mon Jan 16 13:45:33 2006] [notice] Child 988: Child process is running
[Mon Jan 16 13:45:33 2006] [notice] Child 988: Acquired the start mutex.
[Mon Jan 16 13:45:33 2006] [notice] Child 988: Starting 250 worker threads.
[Mon Jan 16 13:46:14 2006] [notice] Parent: Received restart signal -- Restarting the server.
[Mon Jan 16 13:46:14 2006] [notice] Child 988: Exit event signaled. Child process is ending.
[Mon Jan 16 13:46:15 2006] [notice] Child 988: Released the start mutex
[Mon Jan 16 13:46:16 2006] [notice] Child 988: Waiting for 250 worker threads to exit.
[Mon Jan 16 13:46:17 2006] [notice] Child 988: All worker threads have exited.
[Mon Jan 16 13:46:18 2006] [notice] Child 988: Child process is exiting
[Mon Jan 16 13:46:25 2006] [notice] Apache/2.0.54 (Win32) PHP/4.4.2 mod_perl/2.0.1 Perl/v5.8.7 configured -- resuming normal operations
[Mon Jan 16 13:46:26 2006] [notice] Server built: Jul 25 2005 17:33:17
[Mon Jan 16 13:46:26 2006] [notice] Parent: Created child process 2984
[Mon Jan 16 13:46:46 2006] [notice] Child 2984: Child process is running
[Mon Jan 16 13:46:46 2006] [notice] Child 2984: Acquired the start mutex.
[Mon Jan 16 13:46:46 2006] [notice] Child 2984: Starting 250 worker threads.
[Mon Jan 16 13:58:01 2006] [error] [client 127.0.0.1] PHP Notice:  Undefined variable:  forum_admin in D:\\www\\webroot\\phpnuke\\mainfile.php on line 71
[Mon Jan 16 13:58:01 2006] [error] [client 127.0.0.1] PHP Notice:  Undefined variable:  inside_mod in D:\\www\\webroot\\phpnuke\\mainfile.php on line 74
[Mon Jan 16 13:58:02 2006] [error] [client 127.0.0.1] PHP Notice:  Undefined variable:  inside_mod in D:\\www\\webroot\\phpnuke\\db\\db.php on line 44
[Mon Jan 16 13:58:05 2006] [error] [client 127.0.0.1] PHP Fatal error:  Call to undefined function:  message_die() in D:\\www\\webroot\\phpnuke\\db\\db.php on line 88
[Mon Jan 16 14:04:13 2006] [error] [client 127.0.0.1] File does not exist: D:/www/webroot/phpnuke/stats
[Mon Jan 16 14:04:28 2006] [error] [client 127.0.0.1] File does not exist: D:/www/webroot/phpnuke/stats
[Mon Jan 16 14:04:50 2006] [error] [client 127.0.0.1] client denied by server configuration: D:/www/private/.htpasswd
[Mon Jan 16 22:57:34 2006] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Jan 16 22:57:35 2006] [notice] Child 2984: Exit event signaled. Child process is ending.
[Mon Jan 16 22:57:36 2006] [notice] Child 2984: Released the start mutex
[Mon Jan 16 22:57:54 2006] [notice] Child 2984: Waiting for 250 worker threads to exit.
[Mon Jan 16 22:57:55 2006] [notice] Child 2984: All worker threads have exited.
[Mon Jan 16 22:57:56 2006] [notice] Child 2984: Child process is exiting
[Mon Jan 16 22:58:04 2006] [notice] Parent: Forcing termination of child process 140
[Mon Jan 16 23:00:48 2006] [notice] Apache/2.0.54 (Win32) PHP/4.4.2 mod_perl/2.0.1 Perl/v5.8.7 configured -- resuming normal operations
[Mon Jan 16 23:00:48 2006] [notice] Server built: Jul 25 2005 17:33:17
[Mon Jan 16 23:00:48 2006] [notice] Parent: Created child process 684
[Mon Jan 16 23:01:05 2006] [notice] Child 684: Child process is running
[Mon Jan 16 23:01:05 2006] [notice] Child 684: Acquired the start mutex.
[Mon Jan 16 23:01:05 2006] [notice] Child 684: Starting 250 worker threads.


If you have any idea, of een goed idee ;-)

Thanks
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #24 on: January 16, 2006, 11:34:07 PM »

Quote

(mod_info)
http://localhost/server-info Result: the Gallery output

(mod_status) with/"ExtendedStatus On"
http://localhost/server-status Result: the Gallery output

(mod_perl Apache::Status)
http://localhost/perl-status Result: the Gallery output

...


This should not be so, and aside from the VHs and other lines that I pointed out I do not see anything else causing this (from a first look) except .htaccess files.
Is there one under \www\webroot ?

Quote

[Mon Jan 16 13:58:01 2006] [error] [client 127.0.0.1] PHP Notice: Undefined variable: forum_admin in D:\\www\\webroot\\phpnuke\\mainfile.php on line 71

I would check that file and line to see what it is referring to.

Quote

I changed the VH's as you asked. Same result. This config for VH's already works for 2 years, so I didn't expected it was wrong.

You did delete the entire quote block and replaced with the new one?
It got rid of one VH and edited other lines.
You did stop/start Apache after changes?

Now that PHP 4.4 is working, what exactly are the main problems?
Also, unless the changes made something worse, I would keep them in the mean time and keep globals On.
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #25 on: January 16, 2006, 11:42:01 PM »

http://codex.gallery2.org/index.php/Main_Page

Maybe its been a while since I looked at Gallery, but I do not see anything about it requiring PHPNuke.

Or is there some type of a Gallery mod for phpnuke?

Did you uncomment php extension GD?
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
pvdgulik
Jr. Member
**
Posts: 57


View Profile WWW
« Reply #26 on: January 17, 2006, 10:46:47 AM »

With the httpd.conf as you instructed:

Quote
ServerRoot "D:/www/Apache2"
DocumentRoot "D:/www/webroot"

ServerName localhost:80
ServerAdmin admin@localhost

NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
ServerName mysite1.domain.nl
DocumentRoot "d:/www/webroot/phpnuke"
ServerAdmin mysite1@domain.nl
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.mysite1.nl
DocumentRoot "d:/www/webroot/phpnuke"
ServerAdmin mysite1@domain.nl
ServerAlias mysite1.nl *.mysite1.nl
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.mysite1.com
DocumentRoot "d:/www/webroot/phpnuke"
ServerAdmin mysite1@domain.nl
ServerAlias mysite1.com *.mysite1.com
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.mysite2.nl
DocumentRoot "d:/www/webroot/mysite2.nl"
ServerAdmin mysite2@mysite2.nl
ServerAlias mysite2.nl *.mysite2.nl
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.mysite3.nl
DocumentRoot "d:/www/webroot/mysite3.nl"
ServerAdmin mysite3@mysite3.nl
ServerAlias mysite3.nl *.mysite3.nl
</VirtualHost>


All the sites show the "Test Page for Apache Installation". The same when I changed the names back to the corresponding sitenames.

Quote

ServerRoot "D:/www/Apache2"
DocumentRoot "D:/www/webroot"

ServerName localhost:80
ServerAdmin admin@localhost

NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
ServerName tebogo.xs4all.nl
DocumentRoot "d:/www/webroot/phpnuke"
ServerAdmin tebogo@xs4all.nl
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.tebogo.nl
DocumentRoot "d:/www/webroot/phpnuke"
ServerAdmin tebogo@xs4all.nl
ServerAlias tebogo.nl *.tebogo.nl
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.tebogo.com
DocumentRoot "d:/www/webroot/phpnuke"
ServerAdmin tebogo@xs4all.nl
ServerAlias tebogo.com *.tebogo.com
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.boschdijk.nl
DocumentRoot "d:/www/webroot/boschdijk.nl"
ServerAdmin boschdijk@boschdijk.nl
ServerAlias boschdijk.nl *.boschdijk.nl
</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName test.vdgulik.nl
DocumentRoot "d:/www/webroot/vdgulik.nl"
ServerAdmin vdgulik@vdgulik.nl
ServerAlias vdgulik.nl *.vdgulik.nl
</VirtualHost>


Quote

You did delete the entire quote block and replaced with the new one?
It got rid of one VH and edited other lines.
You did stop/start Apache after changes?


See above
Yes I did restart. Apache

Quote
Is there one under \www\webroot ?
Yes, there was! It should not be there! I removed it but, no difference.

Quote
(mod_info)
http://localhost/server-info Result: Apache Server Information

(mod_status) with/"ExtendedStatus On"
http://localhost/server-status Result: Apache Server Status for localhost

(mod_perl Apache::Status)
http://localhost/perl-status Result: Embedded Perl version v5.8.7 for Apache/2.0.54 process 2692,


Important Notes -- Testing
(test Apache2)
http://localhost Result:blank page :!:

(test PHP)
http://localhost/phpinfo.php Result: PHP Version 4.4.2

(test CGI)
http://localhost/cgi-bin/printenv.pl Result: COMSPEC="C:\WINNT\system32\cmd.exe" etc....

(test mod_perl)
http://localhost/hello Result: Hello from Apache2::Hello!

(test phpMyAdmin)
http://localhost/phpMyAdmin/ Result: Kan de mysqli extentie niet laden,
Controleer de PHP Configuratie  :!:


(Generate Analog, log analyzer, report)
http://localhost/stats/Report.html Result: The page cannot be found
http://localhost/stats/anlgform.html Result: The page cannot be found

(test user/password protected directory "private")
http://localhost/private/ Result: Index of /private
Parent Directory
Apache/2.0.54 (Win32) PHP/4.4.2 mod_perl/2.0.1 Perl/v5.8.7 Server at localhost Port 80


Quote
Now that PHP 4.4 is working, what exactly are the main problems?
Also, unless the changes made something worse, I would keep them in the mean time and keep globals On


The main problem is that i always get the Apache Test Page for all my sites, Localhost is blank and PhPAdmin does not load.

When the site load again, I can check Gallery again. Thats where we started ;-)
Logged
pvdgulik
Jr. Member
**
Posts: 57


View Profile WWW
« Reply #27 on: January 17, 2006, 03:17:51 PM »

Quote from: "admin"
http://codex.gallery2.org/index.php/Main_Page

Maybe its been a while since I looked at Gallery, but I do not see anything about it requiring PHPNuke.

Or is there some type of a Gallery mod for phpnuke?


http://phpnuke.org/modules.php?name=PHP-Nuke_HOWTO&page=php-nuke-gallery-module.html

Quote
Did you uncomment php extension GD?


Would that be extension=php_gd2.dll? No, but no difference for the above problems. I think it might help when everything works again and I can test Gallery again.  :)
Logged
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #28 on: January 17, 2006, 06:58:02 PM »

Quote

Would that be extension=php_gd2.dll? No, but no difference for the above problems. I think it might help when everything works again and I can test Gallery again.

Yes, and that is the only way it probably can display images.


Quote

I removed it but, no difference.

Quote:
(mod_info)
http://localhost/server-info Result: Apache Server Information

(mod_status) with/"ExtendedStatus On"
http://localhost/server-status Result: Apache Server Status for localhost

(mod_perl Apache::Status)
http://localhost/perl-status Result: Embedded Perl version v5.8.7 for Apache/2.0.54 process 2692,

...


It looks like we are getting closer now as the above works.
(Whether that is a result of the VH chages or the removal of the .htaccess file)
Does \www\webroot have an index.php or index.html page?  As that is what is going to be brought up as you access localhost.

Quote

(test phpMyAdmin)
http://localhost/phpMyAdmin/ Result: Kan de mysqli extentie niet laden,
Controleer de PHP Configuratie  


Did you edit \www\phpMyAdmin\config.ini.php and change...
Quote

$cfg['Servers'][$i]['extension']     = 'mysqli';
to...
Quote

$cfg['Servers'][$i]['extension']     = 'mysql';


OR have both these lines uncommented under C:\Windows\php.ini
Quote

extension=php_mysql.dll
extension=php_mysqli.dll
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
admin
Administrator
Master of All Subjects
*****
Posts: 3272


View Profile WWW Email
« Reply #29 on: January 17, 2006, 07:11:40 PM »

I checked the sites you have listed under the VHs, and they all work?  The 1st one as it is, and the rest work when you use 'www.' instead of 'test.'  How are these sites different from your 'test.'?
Logged

DeveloperSide.NET
Advanced PHP and MySQL Solutions for your Web Design and Development needs with Web.Developer Server Suite.
Pages: 1 [2] 3 4 ... 8
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.9 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!